Results 1 to 4 of 4

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: 3g - 4.0 rollback help

  1. #1
    Default 3g - 4.0 rollback help
    Hey, I've got an iphone 3g that's currently running iOS 4.0. I'm trying to roll back to 3.1.3 so I can get back to using all of my old jailbroken apps. I have 3.1.3 ipsw and itunes 9.1.1.12. When I shift+restore I get the "Iphone could not be restored, firmware is not compatible" message. Please help!

  2. #2
    Drinks the Kool Aid Captinsmooth's Avatar
    Join Date
    Mar 2010
    Location
    New York
    Posts
    1,322
    Thanks
    131
    Thanked 351 Times in 199 Posts

    You can jb 4.0 on a 3g. http://modmyi.com/guides/?p=3260
    This post infers no rights and is provided as is.

    Click here to follow me on twitter

  3. #3
    Quote Originally Posted by Captinsmooth View Post
    You can jb 4.0 on a 3g.
    yeah, my phone is currently JB but so many apps aren't compatible yet that I'd like to go back. Also, my phone ran much faster on 3.1.3

  4. #4
    Livin the iPhone Life
    Join Date
    Oct 2007
    Location
    Alaska
    Posts
    1,021
    Thanks
    41
    Thanked 116 Times in 113 Posts

    Download the 3.1.3 firmware from the downloads section. Then hold "shift" if you're on a PC and click restore to chose the 3.1.3 firmware you just downloaded. If you're on a mac hold "option" and click restore.
    Have they released the jailbreak in the app store yet?

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •