Results 1 to 4 of 4

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: 3GS upgraded to 4.0 is all lost for me?

  1. #1
    Arrow 3GS upgraded to 4.0 is all lost for me?
    I have spent days going through multiple threads posts youtube videos and downloads and nothing has helped so now I throw it over to you for help. (I will include all needed stats)

    I have PC using win7 and Mac using snow leopard
    My Iphone is a 3GS with i~boot 359.3 (which is the old one)
    I was jailbroken on 3.1.2 (untethered of course cos of the old i~boot)


    I had to upgrade my iphone 3GS to 4.0 as I was crashed and stuck in boot-loop (very stuck i tried more than a few methods to get out of it). I had to let itunes upgrade it on a complete restore.

    Before it crashed I used a program called"AutoSHSH" where it saved a blob.shsh file to my desktop (not uploaded to sauriks server though) I believe that to be my 3.1.2 shsh thingy.

    I have used "F0rcast" that says my iphone can be jailbroken

    I have used redsn0w sn0wbreeze and pwnage all create a custom ispw but itunes refuses it (PC and mac), either it will hang on a message about waiting for iphone or trying to confirm ispw with itunes (not exact terms but i forget now) Or it will throw me a 16XX error.

    I have edited my host file on mc and PC to show sauriks server but itunes still hangs

    I have "tinyUmbrella" which tells me that "The following Devices /ECIDs can be restored safely

    iPhone 3GS 3.1.3 (7E18)-my_ecid (never had iphone on 3.1.3)
    iPhone 3GS 4.0 (8A293)-my_ecid (my current version)
    ipod 2G 3.1.2 (7D11)-my_ecid (never had an ipod 2G)

    I have navigated to the .shsh folder that holds the above files and dragged the blob.shsh file into it in the hope that it will upload it to sauriks server but no such luck.

    anyone know how i can get the blob.shsh file to sauriks server or how i can navigate my hosts file to it on my hardrive instead of searching as it does itunes or when edited sauriks server (as it just hangs)

    Is the jailbreak possible as i dont understand why I Cant downgrade!! or jailbreak

    your thoughts please

  2. #2
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    You do not need to be at OS 3.1.3 for Cydia to save your shsh blogs as you were once at OS 3.1.2.
    Now your option is only to downgrade to 3.1.3.
    Do this again :
    Edit your hosts file to point to Cydia , save it and restart your pc.
    Now put your Iphone into DFU mode, if it doesn't try recovery mode.
    Do a Shift + Restore to the 3.1.3 ipsw you have downloaded.
    If the progress bar is going, then it is a good sign.
    You will eventually error at 1015, this is normal.
    Since you can't use quickpwn or ireb to get out of this loop, run Blackra1n for 9.1, if an error occurs and blackra1n crashes, put your Blackra1n in this directory : CPrograms files\Common Files\Apple\Apple Application Support\Blackra1n.exe and run it from there.
    Your Iphone will boot up into Emergency.
    Now you have to insert your official sim to activate.
    Once activated, you can jailbreak with Spirit again and then unlock with Ultrasn0w.

  3. #3
    tried it all and more and got different errors each time, now im stuck on preparing iphone for restore in itunes

  4. #4
    My iPhone is a Part of Me
    Join Date
    Apr 2010
    Location
    N. Ireland
    Posts
    649
    Thanks
    10
    Thanked 81 Times in 75 Posts

    Yeow202's post assumes that your SHSH are saved via Cydia to saurik which only happened if you pressed the 'make my life easier' button. If you have them on the local machine tho all is not lost. You need to setup a local server, read this

    http://modmyi.com/forums/3g-s-downgr...ecid-shsh.html

    once you have restored to 3.1.3 you can JB with spirit, add iWooWiz repo and install Spirit2Pwn then reboot the phone and JB (while the phone is booted, NOT using DFU or recovery) to restore you Pwnage cooked 4.0 IPSW (redsn0w does not support 3GS).

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •