Results 1 to 2 of 2

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone 3G 4.0 Jailbroken will not charge in iPod radio

  1. #1
    Default iPhone 3G 4.0 Jailbroken will not charge in iPod radio
    I have an Emerson Alarm Clock Radio with iPod dock connector.

    For at least a week to 2 weeks, maybe more, my iPhone 3G worked like a charm in said device, playing music and charging.

    Then suddenly for no apparent reason, when I plug the device in, I get the Dismiss button that this device isn't made for the iPhone and the one about interference to cell phone calls, which I say dismiss to both.

    But instead of charging, it flip flops between charging and not charging.

    The battery light will change to the USB charging icon to not charging, continuing over and over.

    The weird part of it all is, the stereo will play the music from the device no problem, it just doesn't want to charge from it.

    I can charge the phone using a normal USB cable and the stereo can charge my iPhone 2G 3.1.2 jailbroken with no problems at all.

    So the problem is only when 3G mets stereo.

    EDIT: I don't know for a fact if this is fixed or not, but it appears to be so far.

    The weird part is all I did after reinstalling NoAccessorySplash iOS4 and everything, was just to give it a 100% charge using the cable, then tried the stereo.

    Seems to be working now for some reason.

    It seemed like when the iPhone was almost dead of battery, the phone worked but it acted like it didn't have enough "power/energy" to bring up "Accessory Splash" or "No Accessory Splash", it would take a minute to come up with "Dismiss", but for some reason after it was charged a while, that window came up basically instantly on the stereo.
    Last edited by redpenguin; 2010-07-10 at 10:20 AM. Reason: Automerged Doublepost

  2. #2
    Hey, cool I also just bought an Emerson ipod radio, from overstock.com (refurbished). Its a great ipod radio, small size, loud and good quality audio output. Ive only had it for 2 days. The specific model number for mine is iP100 (iTone), whats yours?

    From what Ive read many times in MMi, stingy Apple prevents the full use of some 3rd party accessories. They would rather make you pay a large price for their official accessories. This stinginess mostly applies to TV out cables and ipod docks. Charging via a 3rd party ipod dock was discontinued after 2G idevice models/a certain FW (3.x?). But, with 3rd party TV out cables, hackers have made cydia apps that will override Apple's stinginess, allowing full use of the TV cable. Could there be a cydia app out there that overrides the stinginess for ipodocks?

    Mine wont charge either, even on day one. I have a ipt3 3.1.2 blackra1n. I also downloaded NoAccessorySplash, still no charging. And when battery was around 30%, popup appeared.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •