Results 1 to 3 of 3

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Virgin 3G/3.0 Firmware..Should I upgrade and jailbreak to 3.1.2?

  1. #1
    Default Virgin 3G/3.0 Firmware..Should I upgrade and jailbreak to 3.1.2?
    Hi, just bought a non-jailbroken 3g on craigslist. And I'm considering jailbreaking and unlocking it. But I wanted to ask you guys should I just stay with the current firmware/04.26.08 baseband and proceed with the mods or will I gain alot upgrading to 3.1.2?

  2. #2
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    Quote Originally Posted by elcubano1 View Post
    Hi, just bought a non-jailbroken 3g on craigslist. And I'm considering jailbreaking and unlocking it. But I wanted to ask you guys should I just stay with the current firmware/04.26.08 baseband and proceed with the mods or will I gain alot upgrading to 3.1.2?
    If you want to keep your baseband, download Redsn0w 0.8 and also download 3.0 ipsw. Use Redsn0w 0.8 to jailbreak first.

    Why don't you go to 3.1.3 upgrade instead of 3.1.2 : To do that : PC , download SnowBreeze 1.5.2, For Mac Download Pwnage tools 3.1.5. You will also need the 3.1.3 ipsw while creating a custom ipsw. When you are done creating, do a shift + Restore and browse to the cfw located on your desktop. When you are done restoring, you are jailbroken at 3.1.3, you can then install Ultrasn0w from Cydia.

    You should restore to atleast 3.1.3 because most new apps require 3.1.3 or even 4.0. You can even jailbreak 4.0 but there has been many complaints about 4.0 because of multitasking causes the 3G iphone to be too slow on opening the apps.

  3. The Following User Says Thank You to iYeow For This Useful Post:

    elcubano1 (2010-07-08)

  4. #3
    @yeow202 thanks for the great info. I'm glad I asked this question before going on ahead with jailbreaking. So the new apps coming out require 3.1.3 and higher. I've seen on itunes in the app descriptions say "requires 3.0 or higher" I though i could just get by with this oh well then. The reason I've been hesitant about upgrading is because of the battery issues I've heard people say that 3.1.2 and newer drains battery quicker on the 3G. Is there any truth to this?

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •