Results 1 to 11 of 11

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Majorly stuck after upgrade to iOS4 - Horrid Wifi issues - Need Help - 3G

  1. #1
    Default Majorly stuck after upgrade to iOS4 - Horrid Wifi issues - Need Help - 3G
    Hey all,
    I upgraded to iOS4 on my iPhone 3G which was earlier running on 3.1.2. Everything was working perfectly fine until I upgraded to the latest firmware.

    After upgrading to iOS4 I noticed that the wifi was acting erratic, it would not detect my wifi connection and when it would, it would refuse to join the network and when it did join, it would drop the connection within no time. I had jailbroken using redsn0w and unlocked using ultrasn0w.

    So, stuck in this situation, I reinstalled (restored) iOS4 hoping it would be the solution to all the wifi problems with the newly released redsn0w beta 4. But for all I knew, my problems were about to get worse. My iPhone would fail to recognize my wifi connection AT ALL.

    Worried, I downgraded to 3.1.2, to my surprise, the same freakin issue! WiFi is not being detected AT ALL, even in 3.1.2. To top it all off, my baseband has been upgraded to 05.13.04.

    Messed up and worried, I again upgraded to iOS4, this time using sn0wbreeze, didn't work either. Then I restored the original iOS4 image from Apple and redsn0w JB'd it.

    Now I'm on iOS4, I had to install ultrasn0w without a wifi connection using Cyder or some tool.

    Can someone tell me what on earth is going on with the iOS4? And if there is ANY fix out there?

    Shall I just downgrade to 3.1.2? is there an unlock for that baseband for 3G (3.1.2)?

    Bleh
    Sibot

  2. #2
    try resetting your network setting. Or go to your wifi settings and try manually, making sure your wifi IS ON, and you have the proper wifi connection.. ;-)
    I'm a violent computer geek!

  3. #3
    I tried all of that! Believe me, I wouldn't make the effort to type such a long post if I hadn't already checked out the most basic things.

    I also have an iPhone 2G on 3.1.x with me, which can connect to the wifi without any hassles! Its only the darned 3G on iOS4 that is giving problems and is acting erratic with the wifi connectivity. Just to point out a plethora of people are facing this problem not only with their 3G but also 3GS. Hope Apple sorts this blunder out at the earliest. Its like taking away the arms and legs off a phone.

  4. #4
    Did you update to the new baseband that comes with iOS4, or did you keep your old one?

  5. #5
    Yes, it upgraded on its own. =/ I'm on 05.13.04 now.

  6. #6

  7. #7

  8. #8
    Ok. Mine is fixed. Reset network settings fixed mine

  9. #9
    It did? Sadly that fixes nothing for me. I'm still stuck with the issue.

    What a PITA.

  10. #10
    Somehow i think MyWi messed mine up. I uninstalled MyWi, reset network settings and at first I had a greyed out WiFi but then after another reset it all worked fine. Really bizarre behavior.

  11. #11
    sibot,

    Did you ever get your wifi issue resolved? Im having the same problem with a 3GS.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •