Page 1 of 3 123 LastLast
Results 1 to 20 of 59

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Trying to sn0wbreeze, getting "error (2)"

  1. #1
    Default Trying to sn0wbreeze, getting "unknown error occurred (2)"
    My iPhone 3gs is on firmware 3.1.2

    blackra1n'd, on AT&T

    I created a custom IPSW using sn0wbreeze.

    Put the phone into Recovery mode.

    Shift+Restore, selected the sn0wbreeze'd IPSW

    sn0wbreeze logo shows up on iPhone

    But then the whole process stops and in iTunes, an error pops up that the phone cannot be restored because of an "unknown error occurred (2)"

    Any advice?

    SOLUTION: Do a google search for the Crispytech IPSW. Something about sn0wbreeze isn't playing nicely with some 3Gs devices. An IPSW created with Pwnage works fine.
    Last edited by bridea; 2010-06-28 at 07:33 PM.

  2. #2
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    Use ireb or irecovery to get you out of this loop

  3. #3
    The loop isn't the problem.

    The not being able to restore to a custom IPSW is the problem.

    I've tried restoring the custom IPSW from both recovery mode and DFU mode, neither are working. I'm fairly confident my iDevice is "compatible" with the sn0wbreeze jailbreak, as it's currently jailbroken with blackra1n.
    Last edited by bridea; 2010-06-24 at 07:26 PM.

  4. #4
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    Is your Iphone with old bootrom. I am pretty sure , you are in a loop. Try using tools like ireb, rslite or even quickpwn22 to get you out of this error. There is no harm in trying with those tools, right ?

  5. #5
    iREB doesn't support the iPhone 3gs

  6. #6
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    Quote Originally Posted by bridea View Post
    iREB doesn't support the iPhone 3gs
    Yes, it does. But you have to install libusb if you are a window user. If you are using vista or win7, make sure you change the compatibility mode of libusb to xp2 first before installing.
    Once installed , you can run ireb to get you out of the loop.

  7. #7
    fascinating! ok let me try that. I have libusb installed.

  8. #8
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    Quote Originally Posted by bridea View Post
    fascinating! ok let me try that. I have libusb installed.
    Itunes 9.1 and above kills quickpwn 22, I don't know about whether it will also kill ireb. Give it a shot and let us know. You won't brick your Iphone.

  9. #9
    iREB does nothing.

  10. #10
    Same error (2), restored back to 3.1.2 and jailbroken using blackra1n

    Looks like sn0wbreeze doesn't work on 3GS with the old boot rom

  11. #11
    ok so now I'm thinking I may not have a "qualifying" bootrom.

    I ran f0recast which told me:

    Baseband: 05.11.07
    Bootloader: 6.4

    Nothing about a Bootrom, though. Am I hosed?

  12. #12
    I am going through the exact same situation as bridea; consistent error (2) when attempting to restore to custom sn0wbreeze 4.0 firmware. I created my .ipsw in an XP environment with sn0wbreeze 1.6.1, I have a release day 3GS, have successfully restored to 3.1.2 and blackrained untethered numerous times. iREB or any other tools do not accomplish anything towards remedying this issue. There has to be a common denominator here that is separating the successful from the unsuccessful sn0wbreeze jailbreakers. There seem to be few success stories to begin with.

  13. #13
    I'm in the same boat with the error (2).

    My phone was JB'd on 3.1.2 using an .ipsw created by pwnagetool (I am PC based but used a Mac to build this ipsw).

    I have never used blackra1n and have never had to use a tethered jailbreak.
    I have SHSH on file going back to 3.0.
    My model number starts with MC and my serial number is **934***...2009, week 34, which should indicate old bootrom.
    I'm on baseband 04.26.08 - wonder if this has anything to do with it? Would sn0wbreeze care about this and be expecting 05.x?

    After multiple attempts at using .ipsw created by sn0wbreeze 1.6.1 I've gone back to 3.1.2. (Fortunately I had no issues loading the custom 3.1.2 ipsw using iTunes 9.2)

    Guess I'll wait to hear more about the 4.0 JB solutions but for now wanted to add my error (2) experiences and data to the thread.

  14. #14
    I'm having the same problem as well, maybe it's because of the version of sn0wbreeze?
    But I don't think there is a 1.6 sn0wbreeze..

  15. #15
    Same issue here. 3GS, old bootrom, 3.1.2 jailbroken with blackra1n. Error code 2, infinite recovery loop until I restore to 3.1.2 or 4.0 official.

  16. #16
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    Guys, Today , I uninstalled Itunes and everything that goes with Itunes. Then I started installing Itunes 8.2 >9.0, my Quickpwn can still open. But as soon as I installed Itunes 9.1 and then 9.2, quickpwn crashes. I think the version of Itunes has something to do with the tools need to get out of the loop. If you have a second computer, itunes 8.2 > 9.0.3 should work with quickpwn or Ireb.
    When you get error #2, you are in recovery loop, unplug your Iphone and plug into another pc with Itunes < 9.1, and run quickpwn or Ireb gui 3.1,1 or Irecovery will boot your Iphone out of this loop

    I have successfully restored two of my 3GS old bootrom to snowbreeze_iOS 4.0 with no error.( touch wood , so far so good )
    So guys, use another pc to error this out. Please thank me if it works out for you guys

  17. The Following User Says Thank You to iYeow For This Useful Post:

    mael (2010-06-25)

  18. #17
    Retired Moderator j3st3r's Avatar
    Join Date
    Mar 2008
    Location
    Louisiana
    Posts
    2,447
    Thanks
    42
    Thanked 405 Times in 395 Posts

    This how to get quickpwn to work in iTunes 9.1 or 9.2

    3. Extract Quickpwn (free extractor) BUT DO NOT RUN IT. This is where it can get a bit tricky, so pay attention.

    Navigate to:

    32-bit windows: C: \Program Files\Common Files\Apple\Mobile Device Support

    32-bit windows: C: \Program Files (x86)\Common Files\Apple\Mobile Device Support

    You should no see a whole lot of files and folders...good! Now right click and create a new folder called 'bin' (yes no caps, just bin). Drag everything you see in the \Mobile Device Support folder into the bin folder. You should now only have a 'bin' folder in \Mobile Device Support folder. Good! This was done so quickpwn can work with the latest iTunes versions (9+).


    4. Run quickpwn. You should get a box saying something like 'your phone needs to be powered on, please hold the home button and sleep\wake button for 15 seconds'. Just do what it says- EXACTLY. When you see the apple logo on your phone, press OK. A blue box will appear after, just press OK to that as well.


    5. Your phone should now boot normally. when it does,CLOSE QUICKPWN, IT IS NOT USED TO JAILBREAK.[/COLOR]


    6. This step is extremely important if you don't want to re-install iTunes! Remember that bin folder we made? yeah... iTunes wont work right until you undo what we did. So cut everything in the 'bin' folder you put in earlier, place everything back into the \Mobile Device Support folder (where the bin folder is). After everything is back, DELETE the empty bin folder**. Itunes is not happy until the 'bin' gone too! You should now have everything back in the \Mobile Device Support folder and there should be NO bin folder.

  19. The Following User Says Thank You to j3st3r For This Useful Post:

    mael (2010-06-25)

  20. #18
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    Hmmm, how did you learn that?, amazing...Nice.. I will keep that in mind to teach other newbies. ..Cheers

    One more thing Guys : On both of my Iphone after restoring to iOS 4.0 made by SnowBreeze, my YouTube could not connect. If that happens, install either Push fix or Push Doctor will fix the YouTube issue.
    Last edited by iYeow; 2010-06-25 at 02:51 AM.

  21. #19
    Quote Originally Posted by yeow202 View Post
    Guys, Today , I uninstalled Itunes and everything that goes with Itunes. Then I started installing Itunes 8.2 >9.0, my Quickpwn can still open. But as soon as I installed Itunes 9.1 and then 9.2, quickpwn crashes. I think the version of Itunes has something to do with the tools need to get out of the loop. If you have a second computer, itunes 8.2 > 9.0.3 should work with quickpwn or Ireb.
    When you get error #2, you are in recovery loop, unplug your Iphone and plug into another pc with Itunes < 9.1, and run quickpwn or Ireb gui 3.1,1 or Irecovery will boot your Iphone out of this loop

    I have successfully restored two of my 3GS old bootrom to snowbreeze_iOS 4.0 with no error.( touch wood , so far so good )
    So guys, use another pc to error this out. Please thank me if it works out for you guys
    So we basically do the same procedure on a different computer if we get error 2?

  22. #20
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    Quote Originally Posted by Munchzors View Post
    So we basically do the same procedure on a different computer if we get error 2?
    Yes, use a different computer that has itunes < 9.1 to get you out of the loop.
    Or you can use the method of by j3st3r to make Itunes not to crash quickpwn, then you can use the same computer to get you out of this loop. I am pretty sure, when you encounter error #2, you are already successfully jailbroken but just in a loop and can't get out because itunes = > 9.1 causes the crash.
    Try it and get back to us.

    Quote Originally Posted by j3st3r3 View Post
    This how to get quickpwn to work in iTunes 9.1 or 9.2

    3. Extract Quickpwn (free extractor) BUT DO NOT RUN IT. This is where it can get a bit tricky, so pay attention.

    Navigate to:

    32-bit windows: C: Program FilesCommon FilesAppleMobile Device Support

    32-bit windows: C: Program Files (x86)Common FilesAppleMobile Device Support

    You should no see a whole lot of files and folders...good! Now right click and create a new folder called 'bin' (yes no caps, just bin). Drag everything you see in the Mobile Device Support folder into the bin folder. You should now only have a 'bin' folder in Mobile Device Support folder. Good! This was done so quickpwn can work with the latest iTunes versions (9+).


    4. Run quickpwn. You should get a box saying something like 'your phone needs to be powered on, please hold the home button and sleepwake button for 15 seconds'. Just do what it says- EXACTLY. When you see the apple logo on your phone, press OK. A blue box will appear after, just press OK to that as well.


    5. Your phone should now boot normally. when it does,CLOSE QUICKPWN, IT IS NOT USED TO JAILBREAK.[/COLOR]


    6. This step is extremely important if you don't want to re-install iTunes! Remember that bin folder we made? yeah... iTunes wont work right until you undo what we did. So cut everything in the 'bin' folder you put in earlier, place everything back into the Mobile Device Support folder (where the bin folder is). After everything is back, DELETE the empty bin folder**. Itunes is not happy until the 'bin' gone too! You should now have everything back in the Mobile Device Support folder and there should be NO bin folder.
    Hey J3st3r3, I just simulated by putting all the files into bin and run quickpwn, it still crashes, any idea. If they cannot use the tools to get out of loop, then they are basically stucked in the loop.
    Last edited by iYeow; 2010-06-25 at 03:48 AM. Reason: Automerged Doublepost

Page 1 of 3 123 LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •