Results 1 to 9 of 9

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: How to Upgrade to iOS4 & Jailbreak a 3Gs currently running 3.0.1

  1. #1
    Default How to Upgrade to iOS4 & Jailbreak a 3Gs currently running 3.0.1
    I've been running the original iOS 3.0.1 on my iphone since I purchased it 10 months ago (its serial number shows it being a week 32 iphone). I have AT&T I want to upgrade to the iOS4 but also jailbreak the phone so I can purchase the MyWi program (which is the ONLY reason I want to jailbreak my phone). I updated a AT&T profile about 9 months ago giving me the ability to tether which is why I've never upgraded since. I want to get the new iOS4. What are the steps I need to take to make this happen and get MyWi? Figuratively speaking, if I jailbreak the phone after upgrading to iOS4 and apple release an newer version of iOS (lets call it iOS 4.0.1 what happens then? Would you simply hook my jailbroken phone to itunes and update the to the new iOS 4.0.1, thus whiping out all the jailbreak feature or does it become a "brick" somehow?

  2. #2
    My iPhone is a Part of Me
    Join Date
    Apr 2010
    Location
    N. Ireland
    Posts
    649
    Thanks
    10
    Thanked 81 Times in 75 Posts

    Well on 3.0.1 you should be able to upgrade to a jailbroken iOS4. You need to JB it first with Redsn0w v0.8 or Pwnage tool. Then you should be able to upgrade to iOS4 with the latest Pwnage Tool.

    Then in future if you want to keep your JB simply dont upgrade. It wont brick or lose JB if you keep it on iOS4.

  3. #3
    Default Why JB first
    Since I'm running the original 3.0.1 iOS why would I want to jailbreak it first? My understanding is that I upgrade to iOS4 using iTunes then jailbreak it to get the MyWi, which is the only reason I want to JB in the first place. Correct me if I'm wrong.

  4. #4
    My iPhone is a Part of Me
    Join Date
    Apr 2010
    Location
    N. Ireland
    Posts
    649
    Thanks
    10
    Thanked 81 Times in 75 Posts

    You are wrong, the phone MUST be JB to accept a customer iOS4 firmware.

  5. #5
    Default Wait it out???
    My biggest worry is if I jailbreak it now that something will go wrong. 3 Questions for you in general.

    1) If I Jailbreak my 3GS running 3.0.1 then install the the iOS4 firmwire using one of the tools and decide to just go back to a nonjailbroken state. Could I do that?

    2) Or say I JB it on 3.0.1 then using iTunes do the update. Does it simply wipe out the jailbreak and return the phone to a normal iPhone with iOS4?

    3) Do you think they will release a jailbreak for iOS4? Meaning I can upgrade through iTunes then JB with iOS4 already installed from Apple.

  6. #6
    Retired Moderator bhz1's Avatar
    Join Date
    Sep 2007
    Location
    Southeastern Pennsylvania
    Posts
    2,528
    Thanks
    92
    Thanked 361 Times in 271 Posts

    Just upgraded a 3G still on 3.0 yesterday. I installed a stock 3.1.2 via iTunes then used pwnage to jb/ unlock. Then used pwnage 4.0 to upgrade to 4.0. Problem was when I tried to do this straight from 3.0 I got error 1. But upgrade to a pwned 3.1.2 first did the trick.

  7. #7
    My iPhone is a Part of Me
    Join Date
    Apr 2010
    Location
    N. Ireland
    Posts
    649
    Thanks
    10
    Thanked 81 Times in 75 Posts

    To answer your questions:

    1. If you wanted to go back to 'normal' you could just do a restore to stock FW 4.0
    2. That would wipe the 3.0.1 JB and put you on stock iOS4
    3. Difficult to say, i'd say they are working on, but i'd say they want to be iP4 compatible too, so it could be a while.

  8. #8
    In your opinion what is the best route I should take to have iOS4 and be jailbroken, knowing that currently I have a 32nd week 3GS phone on Modem Firmware 04.26.08 running 3.0.1 (WINDOWS ONLY)?


    Also, do you have the ability to chose which firmware you can have on iTunes? Or do they only offer the lastest without the ability to downgrade?

  9. #9
    I also have a 3GS running 3.0.1 7A400 04.26.08. I have a custom 4.0 restore and all i get is 16XX errors. How can i jailbreak as i stand now? Anytime you install ipsw it needs to be signed by apple, right? So how do i upgrade to 3.1.2 if i dont have SHSH for 3.1.2? I have attempted to reinstall 3.0.1 but apple wont sign that either. Or should i be able to and im screwing something up?

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •