Ok so I've read, read and re-read everything I can find and for the life of me can't figure out what's wrong. I updated my 3G to iOS 4.0 through iTunes, downloaded redsn0w 0.9.5b5-3 and iPhone1,2_4.0_8A293_Restore to run with redsn0w. When I try to run redsn0w it says "Unable to recognize specified IPSW". I have no idea why. So I went back to iTunes did Shift+Restore and used the iPhone1,2_4.0_8A293_Restore file I downloaded instead in hopes that would change something. It didn't. Anyone have any ideas? Any help is greatly appreciated.

Edit: I have iTunes 9.2