Results 1 to 9 of 9

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Can't get iTunes to restore with Sn0wbreeze IPSW

  1. #1
    Default Can't get iTunes to restore with Sn0wbreeze IPSW
    Am I not doing this right?
    3g Phone was restored to 3.1.3
    The IPSW was selected in Sn0wbreeze and jailbroken
    Phone is put in DFU mode
    Shift+Restore in iTunes, Sn0wbreezed IPSW restore file is selected
    iTunes extracts the software, "Preparing for iPhone restore..." prompt comes up, then...
    Error message: The iPhone could not be restored. An unknown error occurred (1604).

    On another note, I tried processing the original IPSW file through redsnow and I get the error message "Unable to recognize specified IPSW." I thought maybe this IPSW file was corrupt or the wrong one, but when I Shift+Restore and select it through iTunes it processes it just fine.

    Any thoughts?

  2. #2
    Retired Moderator
    Join Date
    Jun 2009
    Location
    Alhambra, CA
    Posts
    16,904
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    Redsn0w only processes 3.1.2 ipsw's. This works on both 3.1.3 and 3.1.2, they both just use the 3.1.2 ipsw so any 3.1.3 ipsw Redsnow won't read.

    If you want to restore your phone, just restore it to the stock 3.1.2 if your custom fw isn't working.

    Edit* Redsn0w also doesn't process custom firmwares. The whole point of running Redsn0w is to jailbreak your phone. Custom firmwares basically jailbreak the phone automatically via iTunes restore.
    Last edited by i.Annie; 2010-06-18 at 06:46 PM. Reason: Automerged Doublepost

  3. #3
    It was the official firmware, but like you said, it was the 3.1.3 IPSW when redsnow wants 3.2.1. Anyway, thanks for the info. I still could not get the Sn0wbreeze IPSW to work, but I downloaded the 3.1.2 IPSW and it ran fine with redsnow. Thank god this is an earlier version of the 3G so I was able to get it unlocked.

  4. #4
    So you were able to restore to 3.1.2 from 3.1.3 with no issues?

  5. #5
    According to the phone it is still on 3.1.3, but the IPSW I used for RedSnow was definitely the official 3.1.2 firmware. It worked, but as for why it worked I could not tell you. If you can't get Sn0wbreeze to work, then try Redsnow, just be sure you use the 3.1.2 IPSW. You can get the firmware from here - iPod, iPhone and iPad Firmware Download

  6. #6
    Retired Moderator
    Join Date
    Jun 2009
    Location
    Alhambra, CA
    Posts
    16,904
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    3.1.2 worked on redsn0w being on 3.1.3 cuz thats what youre supposed to do

    Being on 3.1.2 or 3.1.3 both require the 3.1.2 ipsw to make redsn0w work cuz redsn0w doesnt read 3.1.3 ipsw.

  7. #7
    Livin the iPhone Life
    Join Date
    Oct 2009
    Location
    Europe
    Posts
    2,830
    Thanks
    76
    Thanked 382 Times in 368 Posts

    The reason sn0wbreeze didn't work, is because the phone needs to be already jailbroken.
    We're all just toymakers in the game of life.

  8. #8
    Hrm, then what is the purpose of Sn0wbreeze?

  9. #9
    Livin the iPhone Life
    Join Date
    Oct 2009
    Location
    Europe
    Posts
    2,830
    Thanks
    76
    Thanked 382 Times in 368 Posts

    Quote Originally Posted by ThrowingChicken View Post
    Hrm, then what is the purpose of Sn0wbreeze?
    Upgrading past what you're already on without updating the baseband.

    Example, you're on 3.1.2 and need to unlock but you want to go to 3.1.3. If you restore to stock 3.1.3, you update the baseband to a version that isn't unlockable. Instead, you can use a custom firmware that updates the firmware version without updating the baseband version, thus preserving the ability to unlock.
    We're all just toymakers in the game of life.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •