Page 1 of 2 12 LastLast
Results 1 to 20 of 21

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Here's a tough one... Could use some advice from an expert!

  1. #1
    Default Here's a tough one... Could use some advice from an expert!
    Hey everyone,

    This is my first post here, I have a unique request in which I have been searching for hours and unable to find an answer so I am asking you guys. If this particular topic has been covered I am sorry and I hope someone can direct me to it.

    First of all here is my CURRENT hardware and software information:

    iPhone 3GS 32GB(early model - MB718LL) (serial # 5K9370KN3NS)
    IPSW 3.1.2 w/baseband 05.11.07 and bootloader 6.4

    It is CURRENTLY jailbroken using blackra1n. I do not require a unlock at this time. I DO have SHSHs on file with Cydia for 3.1.2 and 3.1.3 according to my cydia home page.

    (see attached image of f0recast)


    I am traveling on June 23 to china for 3 weeks and will need my Rogers unit unlocked. I already know all about blacksn0w RC2 and have tested it and it works fine at this time with another SIM but have since uninstalled it via Cydia.

    My issue is I have installed way too much BS on my phone via cydia and over the months a few things like scanner and camera wizard and things of that nature do not work anymore on my windows or mac machines with my phone and would like to start fresh with a new restore. (I'm sure its not my computer causing these issues)


    Is there ANY method (if I have to make a custom IPSW thats fine) where I can perform a RESTORE of my phone and either keep it on OS 3.1.2 /baseband 5.11.07

    OR

    upgrade to OS 3.1.3 and keep the current baseband 5.11.07

    (obviously in effort to be able to unlock it in a couple weeks and have a stable clean running phone with minimal services installed from Cydia)

    I have attempted to use Sn0wbreeeze but get an error when selecting the ORIGINAL 3GS 3.1.3 firmware. I do not even know if I should use sn0wbreeze when it is already jailbroken on 3.1.2.

    I have attached the sn0wbreeze error.


    Any help would be greatly appreciated

    Thanks!

  2. #2
    Retired Moderator battlecrushr's Avatar
    Join Date
    Jun 2009
    Location
    Houston follow @al_da_beast
    Posts
    7,940
    Thanks
    273
    Thanked 1,034 Times in 956 Posts

    nope.

    actually one sec, u mite be able to.
    one sec

    yea no u cant
    Last edited by battlecrushr; 2010-06-09 at 03:46 AM. Reason: Automerged Doublepost

  3. #3
    Yes you can.

    It would be 3.1.3 but it would keep the same baseband.

    ill link u in a sec.

    http://modmyi.com/forums/general/712...-baseband.html

    only follow the first 4 steps!!!!!!!
    Last edited by EuroDub; 2010-06-09 at 03:53 AM.

  4. The Following User Says Thank You to EuroDub For This Useful Post:

    battlecrushr (2010-06-09)

  5. #4
    Retired Moderator battlecrushr's Avatar
    Join Date
    Jun 2009
    Location
    Houston follow @al_da_beast
    Posts
    7,940
    Thanks
    273
    Thanked 1,034 Times in 956 Posts

    on a 3gs?

    i think maybe u could restore to a custom baseband.
    im not sure as well

  6. #5
    Livin the iPhone Life CaptainChaos's Avatar
    Join Date
    Sep 2008
    Location
    In a van down by the river
    Posts
    4,824
    Thanks
    553
    Thanked 515 Times in 427 Posts

    You can simply download a custom 3.1.2 firmware from the net and use a Shift/Restore in iTunes to reload the firmware. Since it is jailbroken already it bypasses the iTunes verification process. Or you can do it another way: alter your hosts file to point it at Sauriks server, load a stock 3.1.2, jailbreak with blackrain and then unlock. The custom firmware is easy peasy though. Stay away from 3.1.3 for now. It offers nothing except for the opportunity to blow the whole deal and update your baseband.

    Also...since you have a mac use the pwnage tool to create your own custom 3.1.2 that way you don't have to find one via google b
    Last edited by CaptainChaos; 2010-06-09 at 03:55 AM. Reason: Automerged Doublepost

  7. The Following User Says Thank You to CaptainChaos For This Useful Post:

    battlecrushr (2010-06-09)

  8. #6
    Retired Moderator battlecrushr's Avatar
    Join Date
    Jun 2009
    Location
    Houston follow @al_da_beast
    Posts
    7,940
    Thanks
    273
    Thanked 1,034 Times in 956 Posts

    ya ill let these experts handle it

  9. #7
    Livin the iPhone Life CaptainChaos's Avatar
    Join Date
    Sep 2008
    Location
    In a van down by the river
    Posts
    4,824
    Thanks
    553
    Thanked 515 Times in 427 Posts

    /me chuckles at battle

  10. #8
    Retired Moderator battlecrushr's Avatar
    Join Date
    Jun 2009
    Location
    Houston follow @al_da_beast
    Posts
    7,940
    Thanks
    273
    Thanked 1,034 Times in 956 Posts

    lol

  11. #9
    Quote Originally Posted by CaptainChaos View Post
    You can simply download a custom 3.1.2 firmware from the net and use a Shift/Restore in iTunes to reload the firmware. Since it is jailbroken already it bypasses the iTunes verification process. Or you can do it another way: alter your hosts file to point it at Sauriks server, load a stock 3.1.2, jailbreak with blackrain and then unlock. The custom firmware is easy peasy though. Stay away from 3.1.3 for now. It offers nothing except for the opportunity to blow the whole deal and update your baseband.

    Also...since you have a mac use the pwnage tool to create your own custom 3.1.2 that way you don't have to find one via google b
    Oh so what your saying is that because my phone is already jailbroken I can simply go to itunes, shift-restore and select the Original 3GS 3.1.2 ISPW and it will let me use that even though it is outdated according to apple? I could do the host file mod but I would rather not if I dont need to.

    EDIT!:

    I didnt read it carefully sorry. so I can use a stock unmodified 3.1.2 file if I DO the host file mod..?
    Last edited by mcozea; 2010-06-09 at 04:08 AM.

  12. #10
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    Did you have the latest framwork.net installed to use the gui of Snowbreeze

    I hope you have not restore to any stock apple fw yet. I assume you are still jailbroken,

    Put your Iphone into Recovery mode ( Itunes Cable Logo )
    First step : Use snowbreeze ver 1.5.2 to create a cfw of 3.1.3, you will need the stock fw 3.1.3. If you are having problem for Snowbreeze to detect the stock 3.1.3 fw, download again from here : > http://iclarified.com/entry/index.php?enid=750d Once ceeated it will be placed on your Desktop.

    Second Step : Shift + Restore to Snowbreeze 3.1.3 fw on your desktop

    Third Step : It should restore successfully, if you get an error other than 16xx, you are in a loop. Run quickpwn22.1 (just to get you out of recovery and not to jailbreak) , you will then boot up into Home Screen

    Then add this repo in your Cydia Source : cydia.pushfix.info

    Install blacksn0wRC2.

    You are done, jailbroken and unlock at version 3.1.3
    Last edited by iYeow; 2010-06-09 at 04:53 AM.

  13. #11
    Quote Originally Posted by yeow202 View Post
    Did you have the latest framwork.net installed to use the gui of Snowbreeze

    I hope you have not restore to any stock apple fw yet. I assume you are still jailbroken,

    Put your Iphone into Recovery mode ( Itunes Cable Logo )
    First step : Use snowbreeze ver 1.5.2 to create a cfw of 3.1.3, you will need the stock fw 3.1.3. Once created it will be placed on your Desktop.

    Second Step : Shift + Restore to Snowbreeze 3.1.3 fw on your desktop

    Third Step : It should restore successfully, if you get an error other than 16xx, you are in a loop. Run quickpwn22.1 (just to get you out of recovery and not to jailbreak) , you will then boot up into Home Screen

    Then add this repo in your Cydia Source : cydia.pushfix.info

    Install blacksn0wRC2.

    You are done, jailbroken and unlock at version 3.1.3


    this sounds like a good method. I just downloaded that v1.5.2 snowbreeze and it still gives me the same message that i showed you in the screenshot above when i select the 3.1.3 FW.

    can i just ignore this and continue?

    yes I do have the latest .net updates
    Last edited by mcozea; 2010-06-09 at 04:51 AM.

  14. #12
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    Just ignore and continue and let it create a cfw of 3.1.3 on your desktop
    Last edited by iYeow; 2010-06-09 at 05:00 AM.

  15. #13
    I was just advised by the snowbreeze program to not use blacksn0w with 3.1.3...




    now I'm concerned and am looking for the definite way to restore to 3.1.2 with bb 5.11.7.

    is there any way to do this on windows? I do have my host file modified now. and i do have the original 3.1.2 IPSW.

  16. #14
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    Don't worry about to restore to 3.1.2 or 3.1.3, your BB will still be at 05.11.07. Once you restored to cfw 3.1.3 you created, you are already jailbroken, no more jailbreaking is needed.


    You can even restore back to 3.1.2 by using Pwnage Tools. Use it to create a cfw 3.1.2 and restore again. No need to point to Saurik Server.
    Last edited by iYeow; 2010-06-09 at 05:06 AM.

  17. #15
    So your saying that snowbreeze is wrong about blacksnow not working very well because of how it hooks commcenter... (as I posted the last screenshot) on 3.1.3 w/ 5.11.7?

    lol thanks for all your guys help so far

  18. #16
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    Have you restored successfully ? If you did, please press Thanks and we are done.

  19. The Following User Says Thank You to iYeow For This Useful Post:

    mcozea (2010-06-09)

  20. #17
    yes it made the custom firmware and i will be restoring sometime tonight after i backup a few more items that itunes does not back up.

    Thanks!

  21. #18
    Livin the iPhone Life CaptainChaos's Avatar
    Join Date
    Sep 2008
    Location
    In a van down by the river
    Posts
    4,824
    Thanks
    553
    Thanked 515 Times in 427 Posts

    To answer your questions directed to me:
    Since you are jailbroken you can simply Shift/Restore to a customized 3.1.2 firmware in iTunes. Not a stock firmware. You can only use a stock 3.1.2 firmware IF you have redirected your hosts file to hit Sauriks server instead of Apples. This is very easy to do. Just create the custom 3.1.2 firmware yourself. I would download the Pwnage Tool for your Mac. It is the best and easiest tool to use or google for a custom 3.1.2. Shift/Restore is the simplest way to do it.

    Edit: I see you have your hosts file modded. Put your stock 3.1.2 firmware you downloaded onto your Windows desktop. Press Shift/Restore in iTunes and select the firmware on your desktop. It will restore it to factory 3.1.2. Download and run blackrain after.
    Last edited by CaptainChaos; 2010-06-09 at 05:46 AM. Reason: Automerged Doublepost

  22. #19
    Thank you captianchaos,

    I have already made a custom 3.1.3 FW as yeow202 directed.

    I made it in expert mode so I could disable the custom bootscreens and added the pushfix repo into cydia in the custom FW beforehand.

    I see that in the upgrade from 3.1.2 --> 3.1.3 there are the following changes:

    # Improves accuracy of reported battery level on iPhone 3GS
    # Resolves issue where third-party apps would not launch in some instances
    # Fixes bug that may cause an app to crash when using the Japanese Kana keyboard
    # Fixes security bugs in CoreAudio, ImageIO, Recovery Mode and WebKit


    would you advise that I AVOID using the custom 3.1.3 FW I already made skipping the update and make the custom 3.1.2 using pwnagetool on my mac or should I just go ahead and use my custom 3.1.3 followed with blacksn0w RC2? if 3.1.3 works fine with blacksn0w RC2 I think I would rather use it.

    sorry to keep this thread dragging on but I just want it to be the most stable as it can be.

    Thanks

  23. #20
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    You can just skip and go to cfw 3.1.3 and from now on use CFW for upgrades and you wiill remain unlocked with Blacksn0w all the time

  24. The Following User Says Thank You to iYeow For This Useful Post:

    mcozea (2010-06-09)

Page 1 of 2 12 LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •