Results 1 to 6 of 6

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Here is a Working 3Gs Jailbreak for 4.0 Beta 4

  1. #1
    Default Here is a Working 3Gs Jailbreak for 4.0 Beta 4
    I might get flamed for this, but here is PwnageTool that I took from @4n0nym0u5DEV, and I replaced the Cydia from Redsn0w for 4.0 Beta 4, and added the firmware to the supported firmwares for cydia, and created a custom IPSW file. Installed it, and fired up cydia and added http://apt.saurik.com/cydia-3.7 as the repo.

    The jailbreak worked, and I was able to install lots of things. seems Mobile substrate doesn't work on it, so things like sbsettings didn't work.

    I have my UUID registered, so there is nothing wrong with me doing this, apart from Apples dislike of jailbreaking

    As it sits, it is nowhere near prime time.. Unless there is a Mobile Substrate, and other things already made, and not released to the public, it would probably be best to stay at 3.1.x for a while after the real 4.0 is out. It was fun to play with.

    All the crazyness about not getting this out there because it could hurt the community like what was said on twitter is silly. This isn't any different than the Redsnow for the 3g. It also doesn't give anything away to apple for them to plug the hole, as it uses the existing exploits.

    In fact, it might even help the community, so they can test their apps on a 3gs, and not just a 3g. Especially if they only have a 3gs.
    Last edited by jaminmc; 2010-06-02 at 08:09 PM. Reason: Fixed Link

  2. #2
    Does that mean if i update my 3gs 3.1.3 to 4.0 then i can Jailbreak it?
    Last edited by lapot; 2010-06-02 at 01:11 PM.

  3. #3
    You need to be already at 3.1.2, and jailbreaked with either PwnageTool or Redsnow in order to install a custom IPSW.

    This also preserves the Baseband. (Mine is still at the baseband from beta 3, because I have installed that real ipsw.

    Also it ONLY works on the old bootrom. So if you needed a tethered jailbreak before Spirit came out, stay away!

  4. #4
    thanks mate, mine has been already updated by mistake to 3.1.3 BB 5.12.01
    so i will have to wait more.

  5. #5
    I'm on the new bootrom.. and on Spirit... before reading your posting here.. I tried exactly what you say you did.. created the new ipsw.. but, could NOT get itunes to move past preparing your iphone.. or somethign to that extent. Is that why? I have used 4.0 b4 and it's really very good.. but, really like having backgrounder and callme at least on the phone.. so I downgraded to 3.1.3 --

  6. #6
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    Quote Originally Posted by joejoeiphone1 View Post
    I'm on the new bootrom.. and on Spirit... before reading your posting here.. I tried exactly what you say you did.. created the new ipsw.. but, could NOT get itunes to move past preparing your iphone.. or somethign to that extent. Is that why? I have used 4.0 b4 and it's really very good.. but, really like having backgrounder and callme at least on the phone.. so I downgraded to 3.1.3 --
    Spirit jailbreak is currently not compatible with Custom Firmware (Old bootrom). Hopefully MuscleNerd or Dev Team will look into this compatibilty issue for all Iphones except those with New Bootrom.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •