Results 1 to 15 of 15

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: 3GS, Jailbroken, but can't install Winterboard and others

  1. #1
    Default 3GS, Jailbroken, but can't install Winterboard and others
    3GS, 3.1.3(7E18), 5.12.01, MC model, jailbroken with Spirit. Which worked flawlessly I might add.

    However, there is a number (almost all packages) within Cydia that won't install. I really want to change the skins/themes, but w/o Winterboard I don't think I can do that. After searching around for a bit, I've basically come to the conclusion that you can't get the apps to work thru Cydia at this time (with the newer bootrom).

    Is this correct? Or can someone steer me in the right direction? Thanks!!

  2. #2
    Livin the iPhone Life
    Join Date
    Oct 2009
    Location
    Europe
    Posts
    2,830
    Thanks
    76
    Thanked 382 Times in 368 Posts

    That's not correct. Cydia works fine with your phone. Your best bet would be to restore fresh and then jailbreak using Spirit again.

    I can't explain why it's not working, but a lot of the time, restores will fix errors. As you already have baseband 05.12.01 you really have nothing to lose by restoring.

  3. #3
    iPhone? More like MyPhone
    Join Date
    Apr 2010
    Location
    NY
    Posts
    164
    Thanks
    18
    Thanked 19 Times in 17 Posts

    You might be gettng the error in cydia because u need mobilesubstrate
    Try downloading proswitcher first, then winterboard.

  4. #4
    Livin the iPhone Life
    Join Date
    Oct 2009
    Location
    Europe
    Posts
    2,830
    Thanks
    76
    Thanked 382 Times in 368 Posts

    Quote Originally Posted by dr0herb View Post
    You might be gettng the error in cydia because u need mobilesubstrate
    Try downloading proswitcher first, then winterboard.
    If that's the case, wouldn't it be easier just to download mobile substrate?

  5. #5
    When I click on Winterboard, this is the error message I get:

    Code:
    Note: The requested modifications cannot be applied due to required dependencies or conflicts that cannot be automatically found or fixed.
    
    Modifications
    Install        pincrush
                   WinterBoard
    
    WinterBoard
    Depends        preferenceloader
    Depends        libhide>=2.0.4
    To clarify...Cydia itself works great. Just can't install packages and a huge number of apps. That error message above is the general one I keep getting all the time when I try to install packages.

    I re-installed Mobile Substrate. No dice. Still can't install WinterBoard, backgrounder, etc. I will try to restore and re-Jailbreak using Spirit later.
    Last edited by TurboGoKart; 2010-05-28 at 06:41 PM. Reason: Automerged Doublepost

  6. #6
    Retired Moderator soulthoughts's Avatar
    Join Date
    Sep 2007
    Location
    Tacoma, WA
    Posts
    3,096
    Thanks
    333
    Thanked 603 Times in 506 Posts

    It says right there in the error message. You can't install Winterboard because you don't have libhid greater than 2.4 or preference loader.

  7. #7
    So I need to manually install those? Can I find those in Cydia?

  8. #8
    Livin the iPhone Life
    Join Date
    Oct 2009
    Location
    Europe
    Posts
    2,830
    Thanks
    76
    Thanked 382 Times in 368 Posts

    Do you have any updates in Cydia that you haven't done yet? For instance, did you do the 'complete' or 'essentials' upgrade when you first launched Cydia?

  9. #9
    Retired Moderator soulthoughts's Avatar
    Join Date
    Sep 2007
    Location
    Tacoma, WA
    Posts
    3,096
    Thanks
    333
    Thanked 603 Times in 506 Posts

    I'm wondering if you're missing a repo. Those should install automatically I believe.

  10. #10
    Quote Originally Posted by dhamien View Post
    Do you have any updates in Cydia that you haven't done yet? For instance, did you do the 'complete' or 'essentials' upgrade when you first launched Cydia?
    Well...I just restored my 3GS, and re-jailbroke it. And so far it's working like a charm! Just installed WinterBoard. My guess is that I didn't do the Complete upgrade when I first launched Cydia. Hence the reason why probably some stuff was missing/not updated. I'll play around with it for awhile and let you know how it goes. Thanks!

  11. #11
    Retired Moderator soulthoughts's Avatar
    Join Date
    Sep 2007
    Location
    Tacoma, WA
    Posts
    3,096
    Thanks
    333
    Thanked 603 Times in 506 Posts

    Do all the essential upgrades and let us know what happens.

  12. #12
    When I re-jailbroke it, I did the Complete upgrade and everything is working great. Is there a way to do the Essential upgrade, or do I not need to do that if it's working?

    Or does it add something if I do the essential?

  13. #13
    Retired Moderator soulthoughts's Avatar
    Join Date
    Sep 2007
    Location
    Tacoma, WA
    Posts
    3,096
    Thanks
    333
    Thanked 603 Times in 506 Posts

    Cydia will prompt you if you have an thing essential to upgrade.

  14. #14
    Livin the iPhone Life
    Join Date
    Oct 2009
    Location
    Europe
    Posts
    2,830
    Thanks
    76
    Thanked 382 Times in 368 Posts

    Quote Originally Posted by TurboGoKart View Post
    When I re-jailbroke it, I did the Complete upgrade and everything is working great. Is there a way to do the Essential upgrade, or do I not need to do that if it's working?

    Or does it add something if I do the essential?
    I believe 'Essential' is included in the 'Complete' upgrade, so no need to do anything besides what you've already done.

  15. #15
    Where do I find
    libhid
    and
    preference loader

    I updated cydia but it still says I need those to install winterboard

    any ideas

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •