Results 1 to 15 of 15

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Tried everything. Still Stuck in Recovery Mode Loop! Help...

  1. #1
    Default Tried everything. Still Stuck in Recovery Mode Loop! Help...
    iPhone 3G
    Was previously jailbroken to with 3.1.2 using blackrain months ago.

    iPhone 3G now stuck in recovery mode loop (itunes logo + usb port image)

    Cause:
    - Plugged into iTunes last night but got error "contents of phone cannot be read"
    - Tried many simple solutions, but cannot solve problem
    - Decided to upgrade FW to 3.1.3 and Jailbreak
    - Decided to use sn0wbreeze method
    - Snowbreeze altered 3.1.3 FW
    - in iTunes, i Shift-Restore button & used altered 3.1.3 FW
    - After some time, phone rebooted and showed recovery mode
    - I rebooted the phone and realised it's stuck in the DFU mode. In a loop.

    I Tried:

    Attempted to use iTunes to do clean restore with legit 3.1.3 FW
    But still am stuck in recovery mode

    Turned off phone (home + power button), and then a combination of button presses following youtube guide on getting iphone out of recovery mode.
    Didn't work. Everytime phone restarts or turns on, goes immediately to itunes logo + usb port (Recovery mode)

    iReb & iRecovery
    Tried using MAC to run iRecovery, using terminal commands, couldn't get it to work like in the guide.
    Successfully got iReb to work with Win7. But it did not solve my problem. It rebooted my phone, but phone goes right back to DFU mode. Tried more than once. Still got the DFU loop.

    Blackrain-fix.exe
    Read somewhere that some guy got phone out of DFU mode, by fixing the blackrain RC3 exe file and running the fixed exe. I did as instructed. Ran blackrain-fix.exe. Blackrain image did appear on iphone screen. But after 40 minutes, nothing changed. Plugged it out, rebooted. Back to DFU mode.

    Redsnow
    Tried using jailbreak method using Redsnow to perhaps get it out of DFU mode. Didn't work either. Phone showed all the activation, pineapple stuff. Thought i finally got something different. Phone rebooted as though it worked, then DFU mode appeared. Stuck again. Tried this more than once. Still got my best friend: the DFU mode loop.

    Spirit Jailbreak?
    Can't even use it. iPhone's plugged in, but the "Jailbreak" button in Spirit is not clickable. It says "Please connect your iPhone". But it is connected, just that it's in DFU mode. iTunes could detect my iphone (just won't restore it without 1611/1015 errors or other errors).

    Tried changing HOSTS file following (Caching Apple's Signature Server - Jay Freeman (saurik)), and restoring using unaltered 3.1.2 IPSW and did same with 3.1.3 IPSW.

    First attempt (with 3.1.2 IPSW), got 1015 error in iTunes saying cannot be restored.

    Second attempt (with 3.1.3 IPSW), got 1611 error in iTunes saying cannot be restored.


    Please help guys. I'm not a noob. But I've been trying everything for the past 20 hours. I need my phone back.

    I don't even need a jailbroken one now. Just want the phone out of DFU mode. Please help.
    Last edited by spasiphone; 2010-05-26 at 10:54 AM. Reason: Typos

  2. #2
    Green Apple
    Join Date
    Nov 2007
    Location
    Piatra Neamt, Romania
    Posts
    43
    Thanks
    7
    Thanked 69 Times in 3 Posts

    Here we go. First you need to enter DFU instructions here How To: Enter DFU Restore Mode - ModMyi - Wiki . After that restore normaly with iTunes and should be ok unless it is a hardware failure. Try an post a response. Or restore to 3.1.2 and if it gives you 1015 error just restore again and second time should give same error but it is posible to kick out with iReb or iRecovery.
    Last edited by thunderica; 2010-05-26 at 10:21 AM. Reason: more info

  3. #3
    hi. iReb and iRecovery didn't work for me. I mentioned in my first post that iReb just reboots my phone, but it just goes right back to Recovery mode.

    My issue is not getting into recovery mode, but getting out of it. Any amount of button holding just reboots it right back to recovery mode.

    I'll take a look at the wiki you provided, but it seems like something I've already done. I've almost exhausted every guide/tutorial out there on the internet.

    I just tried using Quickpwn method of kick my iphone out of recovery mode. Held down power + home buttons for 15secs, then power button down for 2secs. Didn't work.

    Installing an older version of iTunes (9.0.3) on a "clean" computer (newly formatted Win7 Home). Then plugged in my iPhone and iTunes immediately detect that it's in recovery mode.

    But no go. It spent 15minutes restoring. But when iTunes rebooted it, went right back to recovery mode - which i have to repeat - is the screen with the iTunes logo + USB Cable.

    Any help?
    Last edited by spasiphone; 2010-05-26 at 12:22 PM. Reason: Automerged Doublepost

  4. #4
    Livin the iPhone Life
    Join Date
    Oct 2009
    Location
    Europe
    Posts
    2,830
    Thanks
    76
    Thanked 382 Times in 368 Posts

    Have you been to 4.0 beta? Otherwise you shouldn't be getting 1015 error while restoring to stock 3.1.3

    If you don't need to unlock, restore to stock 3.1.3 - if still getting 1015 error, restore again to the same version. You'll get the error again and get stuck in recovery mode. Then get out by using the method described under Help! I should have listened and just left this for JB app devs! on this page: redsn0w 0.9.5 BETA [iPhone Dev Team]

  5. #5
    I've also got same problem, whenever i try and restore through iTunes, it gets stuck near the end of restoring iPhone. I've left it restoring over night, and still stuck at that, so know that is not just taking a long time...

    Anybody know any help?

  6. #6
    Livin the iPhone Life
    Join Date
    Oct 2009
    Location
    Europe
    Posts
    2,830
    Thanks
    76
    Thanked 382 Times in 368 Posts

    Quote Originally Posted by jackboddy View Post
    I've also got same problem, whenever i try and restore through iTunes, it gets stuck near the end of restoring iPhone. I've left it restoring over night, and still stuck at that, so know that is not just taking a long time...

    Anybody know any help?
    You need to be more specific. What phone do you have? What firmware version are you on now? What version are you trying to restore to? Is it a custom or stock firmware? What error are you getting?

  7. #7
    Sorry

    iPhone 3G 16gb,

    was on jailbroken 3.1.3, before I tried to downgrade to 3.1.2 official.

    A while ago i upgraded to 4.0 beta 1, (my UDID is registered), and then downgraded to 3.1.2 fine, jailbroke, then upgraded to 3.1.3.

    I think my baseband is at the highest that is out at the moment.

    I've tried doing everything, and the most I can get is do an official 3.1.2 restore (which leads to it getting stuck near the end of the restoring iphone firmware screen.) Then by doing redsn0w, for 3.1.2, then running blackra1n, then running redsn0w once more. The iPhone then reboots in firmware 3.1.2, and starts running correctly, with cydia installed, but there is no signal received, it doesn't even say 'No Service'. Wi-fi also doesn't connect.

    Thanks for your help!

  8. #8
    Livin the iPhone Life
    Join Date
    Oct 2009
    Location
    Europe
    Posts
    2,830
    Thanks
    76
    Thanked 382 Times in 368 Posts

    Quote Originally Posted by jackboddy View Post
    Sorry

    iPhone 3G 16gb,

    was on jailbroken 3.1.3, before I tried to downgrade to 3.1.2 official.

    A while ago i upgraded to 4.0 beta 1, (my UDID is registered), and then downgraded to 3.1.2 fine, jailbroke, then upgraded to 3.1.3.

    I think my baseband is at the highest that is out at the moment.

    I've tried doing everything, and the most I can get is do an official 3.1.2 restore (which leads to it getting stuck near the end of the restoring iphone firmware screen.) Then by doing redsn0w, for 3.1.2, then running blackra1n, then running redsn0w once more. The iPhone then reboots in firmware 3.1.2, and starts running correctly, with cydia installed, but there is no signal received, it doesn't even say 'No Service'. Wi-fi also doesn't connect.

    Thanks for your help!
    You're getting no service because blackra1n hactivates your device. A hactivated device must also be unlocked in order to work, but as you have baseband 05.12.01+ (whichever is from the beta), it's not possible to unlock. What you need to do is boot the device without hactivating.

    You didn't say what error you were getting, if anyone even pops up, but I assume it's 1015 which is what you'll get when you try to restore to a firmware that includes a baseband that is lower than the one installed on your device.

    There's no reason to go to 3.1.2 so I suggest you install 3.1.3 and then jailbreak with Spirit. The only problem is then to get the phone booted after restoring. How to do that is explained under the section Help! I should have listened and just left this for JB app devs! on this page: redsn0w 0.9.5 BETA [iPhone Dev Team]

    Once the phone is booted, let iTunes activate the device normally. Once activated, jailbreak with either redsn0w 0.9.2 or Spirit.

    If it doesn't work, let me know which problems you run into.

  9. #9
    Error 1611, before getting anywhere :S when trying to restore from recovery mode loop to 3.1.3...

    Cheers

    Oh, just got Error 21 trying it again...
    Last edited by jackboddy; 2010-05-30 at 10:03 PM. Reason: Automerged Doublepost

  10. #10
    Livin the iPhone Life
    Join Date
    Oct 2009
    Location
    Europe
    Posts
    2,830
    Thanks
    76
    Thanked 382 Times in 368 Posts

    Quote Originally Posted by jackboddy View Post
    Error 1611, before getting anywhere :S when trying to restore from recovery mode loop to 3.1.3...

    Cheers

    Oh, just got Error 21 trying it again...
    I'm not familiar with either of those errors. These aren't the same you recovered from when you got the phone working with redsn0w/blackra1n, right? You pretty much just have to get to the state you got when using that jailbreak combo only this time boot as described in the link I posted in my previous message.

  11. #11
    I got those errors when doing it in restore mode, but when using DFU mode, it begins to restore, but again stops at the 'Restoring iPhone Firmware" screen, near the end. After holding home and power, when it is stuck on the apple boot logo, (with the bar that tracks progress underneath about 2/3rds of the way) i tried to use rslite with the above steps, but it comes to an error when i type restore, and it just restores in recovery mode.

    I think the problem is that no restore is even completed enough to 1015...

    Cheers

  12. #12
    Livin the iPhone Life
    Join Date
    Oct 2009
    Location
    Europe
    Posts
    2,830
    Thanks
    76
    Thanked 382 Times in 368 Posts

    Unfortunately I don't think I can help you then. Have you tried from different computers? Tried uninstalling all your USB ports and then rebooting the computer?

    You might want to google for the specific error codes you're getting.

  13. #13
    Hmm no worries, yeah i'll give all that a try.

    Thanks a lot for your help so far mate!

  14. #14
    Just to let you know i had the same problem always restoring but nothing happens well i shut-down Zonealarm and 1st time it works

  15. #15
    Quote Originally Posted by spasiphone View Post
    hi. iReb and iRecovery didn't work for me. I mentioned in my first post that iReb just reboots my phone, but it just goes right back to Recovery mode.

    My issue is not getting into recovery mode, but getting out of it. Any amount of button holding just reboots it right back to recovery mode.

    I'll take a look at the wiki you provided, but it seems like something I've already done. I've almost exhausted every guide/tutorial out there on the internet.

    I just tried using Quickpwn method of kick my iphone out of recovery mode. Held down power + home buttons for 15secs, then power button down for 2secs. Didn't work.

    Installing an older version of iTunes (9.0.3) on a "clean" computer (newly formatted Win7 Home). Then plugged in my iPhone and iTunes immediately detect that it's in recovery mode.

    But no go. It spent 15minutes restoring. But when iTunes rebooted it, went right back to recovery mode - which i have to repeat - is the screen with the iTunes logo + USB Cable.

    Any help?
    I had the same issue my iphone was upgraded by my cousin to 3.1.3 and it was stuck at the itunes logo . after several attempts all i did was manually put the phone into DFU and then used official 3.0 ipsw and it worked for me . for some reason the iphone would not get detected on my desktop so i used my laptop . it took me several tries and combination to figure this out . Now my phone is on 3.0 and it works perfectly well.

    Hope this helped

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •