Results 1 to 13 of 13

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: 2.2.1 to 3.0

  1. #1
    Default 2.2.1 to 3.0
    I've done some searching and can't find the solution to my problem.

    I've got an old 3G that was broken that I recently fixed. I'm now trying to get it up to speed, but am having issues. It was on 2.2.1 and I'm trying to get it to 3.0 to jailbreak, then install custom 3.1.3. The only problem is I can't get it to restore to 3.0. iTunes keeps giving me 1604 errors when I shift-restore. I tried it on my main laptop which has iTunes 9.1.1 and my netbook which I installed 7.7.1. I tried DFU mode. I've tried different USB ports and different cables.

    Can anyone help me get this damn phone to restore?

  2. #2
    You have to go straight to 3.1.3 apple doesn't allow older FW anymore.

  3. #3
    I thought that restriction doesn't apply to the 3G as the firmwares for it don't have to be signed like they do the 3gs.

    Besides, just tried installing custom 3.1.3 made with pwnage on a mac. Still no dice. 1604.

    EDIT: Tried a DFU restore on Windows with custom 3.1.3. Error 1600.

    To sum up:

    Windows 7, iTunes 9.1.1, recovery? (non-DFU), 2.2.1 = 1604
    Windows 7, iTunes 9.1.1, recovery, 3.0 = 1604
    Windows 7, iTunes 9.1.1, DFU, 3.0 = 1604
    Windows 7, iTunes 9.1.1, DFU, custom 3.1.3 = 1600

    Different laptop
    Windows 7, iTunes 7.7.1, recovery, 3.0 = 1604
    Windows 7, iTunes 7.7.1, DFU, 3.0 = 1604

    OSX, iTunes ?, DFU, custom 3.1.3 = 1604

    I think there was a 1603 error mixed in there as well.

    Doing some searching I read that the errors could also be caused by a broken docking port on the iPhone. However I don't know if it applies as it charges through USB, iTunes recognizes, and before I started this I pulled off the photos through USB.

    Any help getting this fixed would be great.
    Last edited by brentbizzle; 2010-05-24 at 01:30 AM.

  4. #4
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    Quote Originally Posted by brentbizzle View Post
    I thought that restriction doesn't apply to the 3G as the firmwares for it don't have to be signed like they do the 3gs.

    Besides, just tried installing custom 3.1.3 made with pwnage on a mac. Still no dice. 1604.

    EDIT: Tried a DFU restore on Windows with custom 3.1.3. Error 1600.

    To sum up:

    Windows 7, iTunes 9.1.1, recovery? (non-DFU), 2.2.1 = 1604
    Windows 7, iTunes 9.1.1, recovery, 3.0 = 1604
    Windows 7, iTunes 9.1.1, DFU, 3.0 = 1604
    Windows 7, iTunes 9.1.1, DFU, custom 3.1.3 = 1600

    Different laptop
    Windows 7, iTunes 7.7.1, recovery, 3.0 = 1604
    Windows 7, iTunes 7.7.1, DFU, 3.0 = 1604

    OSX, iTunes ?, DFU, custom 3.1.3 = 1604

    I think there was a 1603 error mixed in there as well.

    Doing some searching I read that the errors could also be caused by a broken docking port on the iPhone. However I don't know if it applies as it charges through USB, iTunes recognizes, and before I started this I pulled off the photos through USB.

    Any help getting this fixed would be great.
    If you have a 3G, you can restore to 3.1.2 and then unlock with Blacksn0w with no problem...

    Quote Originally Posted by yeow202 View Post
    If you have a 3G, you can restore to 3.1.2 with no problem...
    But the best thing for you to do is as follows :

    Restore to 3.0 > use Redsn0w 0.8 and jailbreak

    Cook a custom firmware for using Snowbreeze 1.5.2 and restore to the CFW 3.1.3

    Once done..

    Install Ultrasn0w to Unlock..

    You are all set....enjoy your jailbroken 3.1.3 and unlock with Ultrasn0w..
    Last edited by iYeow; 2010-05-24 at 04:36 AM. Reason: Automerged Doublepost

  5. #5
    You must not have read my original post. That is EXACTLY what I'm trying to do. Hell, it's even in my thread title... 2.2.1 to 3.0. The problem is iTunes isn't letting me restore to 3.0. It keeps producing a 1604 error, preventing me from getting ANY firmware on the damn thing.

  6. #6
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    Quote Originally Posted by brentbizzle View Post
    You must not have read my original post. That is EXACTLY what I'm trying to do. Hell, it's even in my thread title... 2.2.1 to 3.0. The problem is iTunes isn't letting me restore to 3.0. It keeps producing a 1604 error, preventing me from getting ANY firmware on the damn thing.
    Have you tried uninstalling Itunes and installing it again, I see no reason why can't you restore to a higher version rather than downgrading.

    Try putting your Iphone in Recovery Mode, which uses iboot..

  7. #7
    I haven't tried a reinstall on my main machine, but my netbook was a fresh install of 7.7.1. Besides, it didn't work on 2 windows machines or OSX, so I doubt iTunes itself is the issue.

    iREB doesn't do anything. When I click on iPhone 3G, it just doesn't do anything.

    EDIT: Just a follow up.

    Still no go. I've tried it on now a 3rd Windows PC and still no go. I was getting 1603 errors on it. I tried swapping the dock connector on it and that hasn't changed anything. 3 different Windows PCs. 3 different versions of iTunes. All getting 160x errors. I also got iREB to run on one of them and still, it did not work.
    Last edited by brentbizzle; 2010-05-24 at 10:57 AM.

  8. #8
    Retired Moderator
    Join Date
    Jun 2009
    Location
    Alhambra, CA
    Posts
    16,904
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    Have you tried restoring to a stock firmware? You keep saying you tried on a custom firmware--use a stock on from the Downloads section here.

    Download the 3.1.2 stock ipsw and use that (doesn't need to be 3.1.3, doesn't do anything much at all) to restore to.

    It will up your baseband to 5.11.07 which is ok.

    Use Blackra1n and Blacksnow (comes with Blackra1n) to jailbreak and unlock.

    *Edit* Of course, put phone in DFU mode then restore, blah blah the usual
    Last edited by i.Annie; 2010-05-25 at 01:42 AM. Reason: Automerged Doublepost

  9. #9
    Please read my posts. I didn't say I kept trying custom, I already said that I tried 2.2.1, and 3.0. I think I even tried 3.1.2 as a last ditch effort but didn't say that. The ONLY custom firmware I tried was a custom 3.1.3, which I noted above as well. The phone won't accept ANY firmware.

  10. #10
    Retired Moderator
    Join Date
    Jun 2009
    Location
    Alhambra, CA
    Posts
    16,904
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    Well excuse me. I read your posts. As far as I can see most points lead to using custom fw. Sorry for trying to help. That was rude. Good luck to you then.

  11. #11
    Quote Originally Posted by Anniex423 View Post
    Well excuse me. I read your posts. As far as I can see most points lead to using custom fw. Sorry for trying to help. That was rude. Good luck to you then.
    Wasn't trying to be rude, but in my second post I said that I tried 2.2.1, 3.0, and custom 3.1.3.

  12. #12
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    Quote Originally Posted by brentbizzle View Post
    Wasn't trying to be rude, but in my second post I said that I tried 2.2.1, 3.0, and custom 3.1.3.
    You have to jailbreak 3.0 with Redsn0w 0.8 first before you can proceed with CFW 3.1.3 and then unlock with Ultrasn0w. Try putting Iphone in Rec mode and restore to 3.0 again. You might even want to try out DFU mode to restore to 3.0 depending if you have screwed it up by restoring to cfw 3.1.3 without jailbreaking at 3.0. If you encounter error 1015, run quickpwn 22.1 to get out of recovery loop. Hope this helps.....don't be mad, keep smiling your bb has not been updated to 3.1.3 yet ...
    Last edited by iYeow; 2010-05-25 at 07:39 AM.

  13. #13
    Ok, now this is getting annoying... you guys aren't reading my posts. I can't restore to ANY firmware.

    STOCK 2.2.1 (the original firmware) doesn't work.
    STOCK 3.0 doesn't work.
    STOCK 3.1.2 doesn't work.
    Neither does custom 3.1.3.

    The main focus is getting 3.0 to work for the baseband update to unlock with ultrasn0w. That's why the TOPIC is 2.2.1 to 3.0

    The issue isn't getting a custom ipsw to work.
    The issue is getting ANY ipsw to work.

    Restore mode doesn't work.
    DFU mode doesn't work.
    iREB didn't work.

    No matter what firmware, no matter the iTunes version, no matter the computer I'm getting a 160x error.

    I appreciate you guys TRYING to help, but you didn't try very hard because you obviously didn't read all of my posts. Sorry to sound like an ***, but I haven't received a single relevant response.

    I think there might just be a hardware problem. I plan on swapping mainboards tonight to see if another board already at 3.1.3 will even restore. If it does, I'll know for sure the rest of the hardware is fine.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •