Page 2 of 2 FirstFirst 12
Results 21 to 26 of 26

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Problem with iphone spirit jail break "no service"

  1. #21
    Default A fix for "no service" and "waiting for activiation" on 3G
    I recently jailbroke my iPhone 3G with JailBreakMe. One of the first apps I downloaded was iPhoneModem. It worked great! I was so excited that I would not have to purchase internet service. But then I periodically started getting "no service" that day. I had gotten periods of "no service" before, so I didn't worry about it too much. That is, until it lasted for a whole day. I finally broke down and restored, and unfortunately had to upgrade to iOS4 to do it. But still... NO SERVICE! I got "waiting for activiation, this may take some time" and then "no service" still. "Some time" turned out to be never. So I had to get on the phone to AT&T who transferred me to Apple. My phone is waaay out of warranty but I was able to finally talk to someone after being on hold for about 20 minutes. I had to call back today and speak to the activation department and finally was able to talk to a SENIOR support representative, who actually seemed to know what he was talking about.

    Anyway here's how we fixed it:

    • Reset all phone settings (Settings-->General-->Reset Settings)
    • As soon as the home screen comes back up turn off the phone--immediately.
    • Turn the phone back on.
    • Turn airplane mode on.
    • Turn airplane mode off.
    • Say a little prayer and wait.


    And.. voila! iPhone Activated!

    I asked the support guy what he did, and he said I did everything, there was no activation or any other stuff going on on his end, which is good for anyone else in this situation who might not be able to call support.

    So now, the question is, was it JailBreakMe that caused all this? Or iPhoneModem? I suspect iPhoneModem, because it screwed up my internet connection on my computer as well. Very glad I didn't fork out ten bucks for the app, but sad too, I still don't know if I should jailbreak the phone again, the support guy said there was a fix for speeding up 3G in iOS4, so maybe I will just try and be content with a working phone for a while.

  2. #22
    iPhoneaholic
    Join Date
    Jul 2010
    Location
    Bridlington, England
    Posts
    383
    Thanks
    6
    Thanked 49 Times in 46 Posts

    That tread was alittle old, but anyway, why don't you use MyWi or PDAnet?, it's much better

  3. #23
    Yeah, but it was the first one that came up when I was initially searching for solutions to the problem so I figured it was as good a place as any to post my solution. iPhoneModem is one of the "featured apps" on Cydia that's why I downloaded it in the first place. If I work up the courage to jailbreak again, I will look into both of those, are they free?

  4. #24
    iPhoneaholic
    Join Date
    Jul 2010
    Location
    Bridlington, England
    Posts
    383
    Thanks
    6
    Thanked 49 Times in 46 Posts

    You can get them free, but I know you have to pay for MyWi normally, dunno about PDAnet cause I don't use it, but a friend uses it and he said it's very good, cause we both use our iPhones as full time modems

  5. #25
    I have an iphone 3g that's on ios4 having this problem after jailbreaking with jailbreakme.com

    I restored it as a new phone before jailbreaking. I then unlocked and this happened.

    I tried the method above but still "no service" and "awaiting activation"

    EDIT: It has an AT&T SIM in it, would that make it do this? It's unlocked because I'm selling it.
    Last edited by AlecMag; 2010-08-10 at 03:07 AM.

  6. #26
    Livin the iPhone Life
    Join Date
    Oct 2009
    Location
    Europe
    Posts
    2,830
    Thanks
    76
    Thanked 382 Times in 368 Posts

    Quote Originally Posted by AlecMag View Post
    I have an iphone 3g that's on ios4 having this problem after jailbreaking with jailbreakme.com

    I restored it as a new phone before jailbreaking. I then unlocked and this happened.

    I tried the method above but still "no service" and "awaiting activation"

    EDIT: It has an AT&T SIM in it, would that make it do this? It's unlocked because I'm selling it.
    Restore and jailbreak with redsn0w instead. Then unlock using ultrasn0w.
    We're all just toymakers in the game of life.

Page 2 of 2 FirstFirst 12
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •