Page 35 of 50 FirstFirst ... 25333435363745 ... LastLast
Results 681 to 700 of 983

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: [SOLUTION] iPhone shut off during boot / Stuck Apple Logo

  1. #681
    Yes, I am trying to find someone with a mac but so far I don't know any people with one I could borrow.

    I've spent hours trying to get iRecovery to work, and yes libusb is installed. The program just refuses to see my iPhone.

    I DO have access to mac PCs on campus, but I do not get root access.

  2. #682
    Quote Originally Posted by Zekerblue View Post
    I was originally using iPhone1,1_3.1.2_7D11_Restore.ipsw
    That's because that firmware is for 2G iPhones, iPhone1,1 = iPhone 2G. iPhone2,1 = 3GS and iPhone1,2 = 3G

    That's why it didn't work for you before..

  3. #683
    Alright, I've tried msft.guy's method on an XP box. I have all the files in order, but there is no response to the "ramdisk 0x90000000" command, and I get a ".Status error!" repeatedly after the pwned kernelcache has been uploading for a while. Needless to say that it does not work.

    It is a 3G, not a 3Gs, so I'm correct in assuming it doesn't have the new bootrom?

    I'm so lost here, I just need my pictures back, I don't care about anything else they just mean a lot to me :-(

  4. #684
    FIXED!

    Beej I don't even know how much potential frustration you saved me, because after researching my issue for only a couple of hours I had the great fortune of running across your thread. My results:

    1.) 3Gs 3.1.2
    2.) not unlocked
    3.) blackrain
    4.) Windows 7
    5.) I used a Mac at work, OS X 10.6.2
    6.) As far as I can tell so far my iphone is back to normal

    Not including the time it took to download (I have a slow connection at work ), I was up and running in under 5 minutes.

    I'd buy you a beer if I knew where you lived. Paypal will suffice. Thanks for your effort!

  5. #685
    Quote Originally Posted by steinomite View Post
    thanks spooky655. how do i create the custom ipsw for 3.0.1? i'm assuming sn0wbreeze is for 3.1.2.

    you aren't available for chat are you?
    Unfortunately, the only versions of sn0wbreeze I can find support 3.1.3 (newest version) or 3.1.2. You can try using 3.1.3, but if it doesn't work you will have to use the mac pwnage tool to get the files (unless there is another way on Windows that someone knows of). Sorry

  6. #686
    What's Jailbreak?
    Join Date
    May 2010
    Location
    Bay area, north of San Francisco
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default kalb3
    Hi ibeej,

    Thanks for all you have done.

    iPhone 3gs 3,1,3, "modem firmware" 05.12.01
    Not unlocked yet, looking at using spirit, automaticiphoneunlocker, unlock-the-iphone w/cydia (seems the best of paid options), or newiphoneunlock...
    I use both Windows and Mac
    I have access to a Mac

    i am guessing that all of these use Cydia for jailbreaking, so would they all need your patch, and would it work with my OS and firmware?

    Thanks

  7. #687
    I found out why I couldn't restore to 3.1.2 even though I had my shsh blob on the cydia server. Actually I changed 2 variables

    I successfully restored on Win xp + Itunes 9.0 and failed on Win 7 + Itunes 9.1

  8. #688
    Thanks for all the work you've been doing, Beej.
    To be honest, I couldn't read through all 46 pages, and if my problem has been addressed already, I apologize.
    But here it is:

    iPhone 3GS
    3.1.2
    Jailbroken with blackra1n
    Windows 7

    This problem just hit me today, and I'm glad I stumbled across this thread (after only 3 hours of searching). I downloaded b33jsn0w and the proper (3GS) IPSW. When I run b33jsn0w, it keeps telling me that I should connect the device in Recovery mode - but recovery mode is all I've got. Holding both buttons until the message disappears just doesn't work. I tried this with redsn0w and b33jsn0w. (Keep in mind that I originally jailbroke with blackra1n.)
    If there's something else I can try that's already worked and has been addressed in this thread, please direct me to it. I'm jealous of the success stories!

    Thanks.

  9. #689
    Default Help Needed
    Hey iBeej,

    Thanks to your work I was able to retrieve my iPhone with all my data. Thank you!

    But I found a problem and need your help with this as I didn't find anything like my scenario in this thread. So here's what's happening:

    iPhone 3GS
    3.1.2
    Jailbroken with blackra1n
    Windows 7 with access to Mac OS

    -Initially, I was stuck in the USB cable/iTunes logo screen, with the iPhone rebooting right after Blackra1n (and back to previous screen)
    -Downloaded your modified redsn0w for Windows and ran (it rebooted after process)
    -ran blackra1n ->rebooted after few seconds going back to iTunes logo screen
    -Downloaded and ran modified redsn0w for Mac ->rebooted
    -ran blackra1n.... after a while... fixed!
    -Uninstalled Rock but realized WiFi in Settings was grayed, tried a Network reset -> stuck in iTunes screen again!!
    -Tried re-running redsn0w + blackra1n (Mac) -> no success=(
    -Ran your SC+DDC redsn0w ->same result
    -left blackra1n running by itself over and over.. until after few hours and.... fixed!

    Result: iPhone working, but with WiFi grayed out.
    Can't reset network settings or it will block itself again=(

    Pleaseee, Can you help me fix my WiFi??

    Thanks in advance,

    s1monst3r

  10. #690
    Smile Fixed
    I'M BACK IN BUSINESS!!!

    Finally, my phone is sorted. I'll give a little detail in the hope that it'll help someone else...

    Although my problem occurred around the same time as the Rock episode, mine was a slightly different issue (the same issue as Agent Smith and Bassix). Mine would take longer than 7 seconds to shut down (it was closer to 35s). I tried iBeej's fixes, but unfortunately they didn't help me (however full credit to iBeej... he gave me the confidence to keep trying).

    Next (after some reluctance) I decided to go down the 'Restore Ramdisk with SSH' route (thanks to MSFT). It was pretty daunting, but after a few false starts, and some assistance from MSFT himself on Google Wave, I managed to SSH in.

    The first clue to my problem was after successfully mounting disk0s1 I then attempted to mount disk0s2, but received the error 'mount_hfs: No such file or directory'. After a little head scratching I tried 'fsck_hfs /dev/disk0s2' and I received errors:

    ** Checking Non-journaled HFS Plus volume.
    ** Detected a case-sensitive catalog.
    ** Checking Extents Overflow file.
    ** Checking Catalog file.
    Invalid sibling link
    (4, 1755)
    ** Volume check failed.

    My next plan was to back up my drive image, so I connected via SFTP with Filezilla and copied /dev/rdisk0s2 to my PC (the plan was to attempt some recovery software on it, and mount it on my Mac).

    A thought occurred to me... can fsck fix the filesystem...? So I tried 'fsck_hfs -r /dev/disk0s2'.

    These seemed to be the magic words.

    After much churning away and repairing, it finally finished with a '** The volume Data was repaired successfully.'

    A quick 'kill 1' later, and my 'dead' iphone booted up into the lock screen. Everything is intact, and exactly as I had left it. It has now gone straight into my dock for a backup!!!

    I hope this can help others. I'm not very experienced when it comes to unix and SSH, so this wouldn't have been at all possible without the help iBeej and MSFT in particular. To everyone else with boot problems, chin up. You can get it sorted!!

  11. #691
    I found out what I was doing wrong! I was using the wrong file for the kernelcache. Using msft.guy's method and winscp, I have recovered my photos! THANK YOU ALL SO MUCH!

    Now, Should I do a DFU mode recovery via iTunes, or is there any way to get out of the 7 sec reboot loop with ssh access?

  12. #692
    u know whats funny (well I think so) Apple's address in Cupertino, Cali, is '1 Infinite Loop'

  13. #693
    Ok, I've had a bit of progress since my last post. I can now get beejsn0w running. I can see the pineapple and all that, but when my phone reboots, it just reboots back to the "USB/iTunes" screen.
    Before, it wasn't rebooting at all. So that's a step in the right direction. Any thoughts?

    ...And here's another disturbing development: my pc will not run properly unless my bricked phone is connected. None of the drivers work at all, including the mouse and internet access. Woohoo!
    Last edited by Hermanoid; 2010-05-27 at 09:14 PM. Reason: Automerged Doublepost

  14. #694
    Quote Originally Posted by Hermanoid View Post
    Ok, I've had a bit of progress since my last post. I can now get beejsn0w running. I can see the pineapple and all that, but when my phone reboots, it just reboots back to the "USB/iTunes" screen.
    Before, it wasn't rebooting at all. So that's a step in the right direction. Any thoughts?

    ...And here's another disturbing development: my pc will not run properly unless my bricked phone is connected. None of the drivers work at all, including the mouse and internet access. Woohoo!
    You may have installed libusb incorrectly, or maybe didn't restart.

  15. The Following User Says Thank You to spooky655 For This Useful Post:

    Hermanoid (2010-05-27)

  16. #695
    Ok, I'll try that first. Thanks.

    Thanks for the tip, Spooky. The culprit for my Windows trouble was indeed libsub. I uninstalled and we're up and running again. Now on to the phone issues...

    So my next question is this, and it's a three-parter:

    1. Is libusb necessary for the b33jsn0w fix to work, and
    2. Do I need to restart after installing libusb?
    3. Is there a version of libusb that works on Windows 7 64-bit?

    When I don't have libusb installed, b33jsn0w does what it's supposed to, apparently, but when it's finished, my phone reboots back to the USB/iTunes restore screen. When I installed libusb (probably incorrectly), b33jsn0w didn't run at all.

    Any help would be appreciated, as I'm feeling ready to hurl my phone against a wall.
    Last edited by Hermanoid; 2010-05-27 at 10:21 PM. Reason: Automerged Doublepost

  17. #696
    Quote Originally Posted by Hermanoid View Post
    So my next question is this, and it's a three-parter:

    1. Is libusb necessary for the b33jsn0w fix to work, and
    2. Do I need to restart after installing libusb?
    3. Is there a version of libusb that works on Windows 7 64-bit?
    Libusb is not necessary for b33jsn0w.

    Haven't heard of being put into recovery mode, but if b33jsn0w didn't work, you have two options:

    1. Get a hold of a mac (real or in virtual machine) and try b33jsn0w from there.

    2. Use the ramdisk method (requires libusb) to recover data from your phone, then restore, or use the ramdisk method and run fsck to fix your filesystem (not sure if this will work, but someone just had success with it).

    If you chose the second option, you'll have to find a way to install libusb. I'm not sure exactly on 64-bit, but there is some info on this around 10-20 pages back. If you can't find out how from here, you can always google it.

  18. #697
    Quote Originally Posted by spooky655 View Post
    ...or use the ramdisk method and run fsck to fix your filesystem (not sure if this will work, but someone just had success with it).
    Just to quickly add (as the 'someone' in question), my problem wasn't due to the Rock update (it just occurred at around the same time), so this only worked for me as my boot partition (/dev/disk0s1) was intact, it was my data partition (/dev/disk0s2) failing to mount that was causing my problems. A fsck got it booting again.

    As it happens, even though I was able to boot back up again, my phone kept resetting itself. This is a long standing issue with my phone... I think my data part has been corrupt for some time. I have opted for a full restore anyway, just to try and get it as stable as possible.

  19. #698
    Default Progress - from 7 sec shutdown to 7 sec reboot
    Last night I finally managed to get Mac OS running under VirtualBox on Windows (a ridiculously convoluted process) and run the b33jsn0w apps there. It was something like 3 AM when I was finally able to do so, so I don't recall the exact details -- either my iPhone switched from the shutdown to reboot problem after the DDC patcher and the SC/DDC patcher did nothing, or the other way around. In any case, my phone has now made what iBeej labeled at one point "progress".

    I know I've seen others reporting in this thread that they've gone through a similar process, so next I will review this whole thread and confirm my next steps (which I think is a backup via iRecovery, followed by an iTunes restore, and then manually replacing files from the backup over SSH).

    I am just dismayed at how many little issues had to be resolved to be able to run the Mac patcher apps. If anyone else is trying to run Mac OS in a VM on Windows and wants to ask questions, I'll try to help, I'd hate to let all these details I had to learn go to waste.

    Thanks again iBeej -- I was really hoping that the Mac apps would fix my problem 100%, but they've at least fixed the first problem, and I really appreciate the work you've put into this.

    On to the next problem!

  20. #699
    Thanks to Beej for the work and to Spooky for the tips.
    After several failed tries running b33jsn0w on Windows and then on Mac, I just restored with iTunes, and, of course, upgraded to 3.1.3. After syncing, my data was restored to where it was about a week ago. Not too bad. All contacts, photos, etc. were back. So that was nice. Then jailbroke with Spirit, installed some apps from Cydia and my phone is just like it was before (just without some music and a week's worth of messages, but no big deal).
    So my problems are sorted out, and I have 3.1.3 jailbroken with no worry about "accidentally" upgrading the firmware.
    Thanks again for the help, folks.
    Over and out.

  21. #700
    Hey folks,

    I sincerely apologize for being absent this week. It has been awful. My company imploded and all assets returned and accounted for. Including my MacBook and tools. Im unemployed and to top it off, they took my development machine. It's a double edged sword. Even after all the free work I did for them, then take the equipment, lay off everybody, and no job to afford a new machine. I'm toast at this point.

    Luckily, I have all my source code for the new recovery program I was developing for you guys, and it was about ready for a test release. But until I can afford a new machine, there is nothing I can do right now. I'm sorry. I'm really upset about all of this.

    I will continue to help here. I can post some more instructions and help you guys work through ramdisk recovery. You will have to use the tools I posted with the optional ramdisk info by msft.guy for now. Not only did my company screw me over, but all of you. Hang in there, don't give up.

    BEEJ
    Last edited by iBeej; 2010-05-28 at 07:59 PM.
    Before printing, please consider the environment.

    No trees were harmed in the generation of this post. A significant number of electrons were, however, severely inconvenienced.

  22. The Following 3 Users Say Thank You to iBeej For This Useful Post:

    buncle (2010-05-28), czxxx (2010-05-28), sprite404 (2011-12-31)

Page 35 of 50 FirstFirst ... 25333435363745 ... LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •