Results 1 to 7 of 7

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iReb doesn't work for your iPhone 3G 3.1.3 Jailbreak? Here is a solution for you!

  1. #1
    Default iReb doesn't work for your iPhone 3G 3.1.3 Jailbreak? Here is a solution for you!
    I think I got it!!I had this problem too with my iPhone 3G which was running on 3.1.3 and iReb didn't give me the white screen and I couldn't restore the Custom Firmware that I made with snowbreeze!
    I tried many many things and finally this worked:

    I used iTunes 9.0.1 and Windows Vista, if you can't find some of the folders there are hidden! You have to make them visible first!
    I put my iPhone in DFU Mode (not connected to PC yet)
    Then I went to
    C:\Users\[MY USERNAME]\AppData\Roaming\Apple Computer\iTunes
    There I went into the folder Device support and I put my custom firmware in here. Then I renamed my custom firmware to x12220000_5_Recovery.ipsw
    And the other .ipsw that was in there got deleted by me!
    Then I went into the Folder iPhone Software Updated and also put my custom firmware in there and renamed it to:
    iPhone1,2_3.1.3_7E18_Restore.ipsw
    And the other Firmware that was in there got deleted by me! It had the same name!
    So then I opened up iTunes and connected my iPhone 3G which was still in DFU Mode!
    Then I pressed Shift > Restore and chose the Firmware
    iPhone1,2_3.1.3_7E18_Restore in the folder:
    C:\Users\[MY USERNAME]\AppData\Roaming\Apple Computer\iTunes\iPhone Software Update

    Then it worked! Try it for yourself!! ;)

    Tell me how it worked for you or if you need help! :)
    Last edited by Marv1993; 2010-05-11 at 09:53 PM.

  2. #2
    Default Thanks!
    Thank you sooo much!!! Ive been trying to figure out how to do this forever! I love you!!!!!!!!!!

    wait....... actually i thought it was working and now i got an error (2)
    Last edited by CodyHollaway; 2010-05-11 at 03:11 PM. Reason: Automerged Doublepost

  3. #3
    anyone else to confirm this?

  4. #4
    Quote Originally Posted by CodyHollaway View Post
    wait....... actually i thought it was working and now i got an error (2)
    Well Error 2 is not a restore problem! I just looked it up and it is an error in the itunes program itself!
    WikiAnswers - What is itunes error 2 apple application support not found

    How to fix it:
    1. Uninstall iTunes.
    2. Download and install WinRAR.
    3. Download and Right-click the iTunesSetup.exe icon and choose "Open with WinRAR".
    4. Once the EXE is opened in WinRAR, double-click AppleApplicationSupport.msi and when the installer window is open choose "Repair".
    And then try it again

  5. #5
    I'm having the exact same trouble as CodyHallaway. Am also getting an error 2 after doing the suggested iTunes hack, and the solution provided doesn't do the trick unfortunately. It is also incomplete since you need to re-install iTunes after having uninstalled it and executed AppleApplicationSupport.msi.

    So, any hope in breaking iPhone 3.1.3?

  6. #6
    It worked!!, you are great =D

    However, i did not have the iPhone Software Update folder so i made it.

  7. #7
    Default Works
    Worked for me.
    Win 7
    Itunes 9.2.0

    the ipsw file gets deleted from the itunes software updates folder if not used soon enough but as long as its there while browsing for it after shift>browse youre good to go and the infamous white screen that ireb could not generate finally appears soon followed by the snowbreeze bootlogo from the custom firmware.

    Thanks.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •