Results 1 to 3 of 3

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone 2G won't jailbreak!

  1. #1
    Default iPhone 2G won't jailbreak!
    Hello, guy's, long time lurker, fairly new member. Thanks to everyone for all I have learned over the last year, and sorry for the long post(although I, for one, enjoy a good read ).

    I have an iPhone 2G that I have been using for a while jailbroken on 3.0 firmware. I wanted to try a new app from the App Store that keeps telling me I needed at least 3.1 to work, but I put off upgrading(and had experimented with spoofing the firmware version, with no success) until a 3.1.3 jailbreak was released. So I had a few too many last night and tried to upgrade to a CFW, and iTunes would not let me. In the process(I know!)I accidentally fully updated to factory 2G 3.1.3 firmware with 04.05.04 baseband. BTW, I have no SHSH blob(or whatever) on Cydia, as I never have seen the "Make my life easier" option, even after I was aware of it way back and looked for it(should have used Umbrella earlier, but didn't know about it back when Apple was still signing older firmware).

    So, being upset, I continued onward, trying to Blackra1n, discovering(I guess) that Blackra1n doesn't work with 3.1.3. After it says it is successful and to wait for the reboot, the phone goes from the Apple logo to a backlit black screen with the phone being in recovery mode. I can repower the unit, and it is back like it was before, showing the "Connect to iTunes" screen with "Emergency Call Only" mode.

    The problem is the phone is not Activated. I tried to activate using my pre-paid AT&T SIM card, which doesn't work(but did give me full signal and the AT&T logo by the signal meter), and I also tried a de-commissioned iPhone SIM card, which didn't work either. I also tried to use a friend's current iPhone SIM card, but iTunes wanted the last part of her Social Security number, and, being a former identity theft victim, she was uncomfortable, and I did feel that, had I gone that route, it would have disassociated her phone from her SIM card. Funny thing is, after I had put her SIM in my phone(the phone still showing the "Emergency Call Only" screen), and before I was able to try to activate it, the phone rang with an incoming call to her SIM, and I was given the option to answer the call! Strange! Many people, in my reading, seemed to indicate that an old SIM or even an activated Pre-Paid AT&T SIM could be used, some even acting like just putting the old SIM in the phone and connecting to iTunes(v 9.0.2.25 in my case) alone was enough to automatically activate it, but neither SIM worked.

    So, I then tried Redsn0w(duh, it's one of the best!), but (and here's the kicker), the ribbon cable inside my phone is torn so the Home button doesn't work, meaning no DFU. I've tried a few(old) utilites(iLiberty, et al), but could not get the phone into DFU mode.

    So now my questions are(after searching these forums for 5+ hours, and a few more on other, less respected sites )these:

    1) Are there any current utils that will put the phone into DFU mode that I don't know of?

    2) Is Blackra1n actually supposed to be working, but it's not for some reason, or is the above described behavior expected when using Blackra1n on a 3.1.3 firmware?

    3) Is there some way for me to force Activation, so I can just use Spirit?

    4) What did the fact that the phone actually let me answer a call when the phone is supposedly not Activated(or jailbroken) indicate?

    5) Any other ideas, other than taking my motherboard back out of the phone and temporarily placing it in another case with a good ribbon cable so I can Redsn0w(or replacing the cable in mine) since I really don't want to take this thing apart again? BTW, I used SBSettings to negate my need for the Home button during normal use, which is fine with me...

    Thanks in advance, and thanks for reading such a long post!

  2. #2
    Retired Moderator j3st3r's Avatar
    Join Date
    Mar 2008
    Location
    Louisiana
    Posts
    2,447
    Thanks
    42
    Thanked 405 Times in 395 Posts

    1.) not sure but I will see if I can find something for you

    2.)no nlackra1n doesn't jailbreak 3.1.3

    3.)not that I am aware of

    4.)nothing

    5.)I personally would replace the faulty ribbon cable

  3. The Following User Says Thank You to j3st3r For This Useful Post:

    Hitek146 (2010-05-08)

  4. #3
    Thanks for answering so quickly!

    In response:

    1) Thank you very much!!!

    2) That's a shame, considering it is an(supposedly) easy to work with 2G model...

    3) I read one post that said that you could edit some files, replacing some hex values at certain offsets and modify the Windows Hosts file to redirect the Activation server back to the Localhost, but the information was very vague. As a decently adept linux user(and ex-programmer), I could easily modify these files, if I knew what they were. So maybe there is a way, but it's quite convoluted and not well published? Just thinking out loud...

    4) Seems like it would mean something, considering the fact that one would think that an unactivated and unjailbroken phone would not be able to answer phone calls, considering the "Emergency Calls Only" screen. Maybe the phone is partially jailbroken and/or activated?

    5) Yea, I am going to replace the cable eventually, and now, probably sooner than later, but that will take a few weeks to be delivered, and I was using it just fine as it was(new apps excluded). Any other angles you guys can think of that I might try?

    Thanks again for the fast response!

    Wow! I had said before that my friend's iPhone SIM received a call on my non-working phone, but I just tried my Pre-Paid AT&T SIM in the locked phone, and tried to call it, and it rang and let me answer! Maybe I could use a new(unknown to me) version of the old utils I found that would get the phone out of some sort of reboot loop or "Must connect to iTunes", and then the phone(that could be already jailbroken but not activated) would work again?

    Also, if the phone were actually already jailbroken, but not letting me in because of lack of activation, is there some other way I could manipulate the phone, since it still connects to my local WiFi, and I can ping the phone? Of course, I haven't been able to manually install SSH, but maybe a partial jailbreak installed something that will let me in? I already tried SSH and telnet, and the connections were refused...

    Thanks again!
    Last edited by Hitek146; 2010-05-08 at 09:06 AM. Reason: Automerged Doublepost

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •