Results 1 to 3 of 3

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: 'Can't connect to iTunes' after using Spirit jailbreak

  1. #1
    Default 'Can't connect to iTunes' after using Spirit jailbreak
    Hi guys, got a really frustrating problem on my hands.

    I tried the Spirit jailbreak on my 3GS that's on AT&T right after it was released and stupid me did a backup but accidentally knocked my phone out of it's dock when the phone displayed 'Restore in progress' while Spirit was doing it's thing. Yanked the cord by mistake and it unplugged and went into a boot failure loop. Somehow the back up didn't take and lost all my texts, call list, game saves and so on for the last six months apparently. (iTunes doesn't show any backups until last October) So I had to do the upgrade to 3.1.3. After the upgrade I can't connect to the iTunes store, can't upgrade apps, can't download and install free apps, can't download free podcasts or anything else. When I try to log in the login & password pops up for about half a second and then disappears. Then the sign in screen in the store settings greys out. It does the same connected to wifi and EDGE. Nothing changes.

    Does anyone know how to fix this? I already tried a tip about deleting the /var/mobile/Library/Caches/com.apple.mobile.installation.plist to try and fix it and it made no difference. I also tried changing my iTunes password and trying to log in with it, and tried resetting network settings with no luck on those either. I want to avoid restoring the phone completely if possible, that's a huge pain. Pictures of what's happening are attached.

    Also, after the 3.1.3 restore I plugged in my phone at night right after jailbreaking it and when it was rebooting it showed a progress bar like the one when you do the complete wipe option in the settings and all my icons were reorganized by alphabetical order and it has happened twice again when respringing. Could this be a Spirit bug or something just plain weird?
    Attached Thumbnails Attached Thumbnails -img_0033.png   -img_0032.png   -img_0022.png  
    Last edited by KartRacer; 2010-05-06 at 12:33 AM.

  2. #2
    Anybody got an idea? 170 views and nothing?
    Last edited by KartRacer; 2010-05-07 at 04:35 AM.

  3. #3
    I figured out what was causing the problem. Dock Prefs by natetrue is somehow causing my phone to not be able to connect to either the AppStore or the iTunes Store on my phone. Strange, I don't understand how it could. After TWO full restores and setting up as a new phone, I installed DockPrefs and replicated the bug twice. Every time I install it the error is there and as soon as I uninstall it and respring the error goes away. Hmmmmmmm. Best stay away from it I guess, shame because I really like that app.

    EDIT: I suspect it was also causing my springboard to be reordered by name but I'm not willing to go through the trouble to test it. So word to the wise, don't install DockPrefs. It's a shame, but it hasn't been updated for a long time I don't think.
    Last edited by KartRacer; 2010-05-12 at 04:44 AM.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •