Results 1 to 4 of 4

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Best way to deal with wifi 3.1.3 issue on a 2G iphone

  1. #1
    Default Best way to deal with wifi 3.1.3 issue on a 2G iphone
    My wifi doesn't work with an iphone 2g upgraded to 3.1.3 jailbroken and unlocked with Redsn0w with the 3.1.2 IPSW.
    I have a pay-as-you go plan with t-mobile which works great (no data).

    I of course bought the phone used and have no way to prove that the wifi worked before it was unlocked, but based on reading on the internet, I believe it probably did. there are no shortage of stories about upgrades to 3.x breaking wifi.

    I am curious if I install Android if wifi will work on that?

    I am curious if wifi would work if I downgraded to 2.2.1? I tried to do this, but was unable to downgrade. I tried it both with the iphone connected to itunes as normal and with the iphone in DFU mode. I got an error 1600 and an error 90 I think, and I don't remember which is which.

    Do I just need an older version of iTunes to do the downgrade, or is it that I have to install fuzzyband and downgrade the baseband first?

    I could use a SIM with a data plan to install something if I had to.

    Any thoughts would be greatly appreciated!

    UPDATE:
    The intermittent nature of this bug seems to affect me as well. This morning it started randomly detecting wifi in 3.1.3...Will keep you posted...I had my phone in airplane mode overnight. not sure if that affected anything...

    UPDATE:
    The wifi is once again gone. Tried the freezer trick. Tried "Restore Network Connections" Toggled airplane mode and wifi on and off in every possibly combination.

    UPDATE:
    Will try to downgrade to 2.2.1 using an old version of iTunes and report back. May also jump straight to android. If wifi works in android, it proves it is an OS 3.x problem.

    UPDATE:
    Looks like I need wifi to do the android install...

    Update:
    Tried restore to 2.2.1 in old version 8.0 I think of iTunes. Didn't work. even in DFU mode. error 1600. Will try to mess around with the baseband to revert to 2.2.1 and see if it fixes the wifi. Intermittent issue makes me wonder if I should try to replace the wifi antenna or IC chip. If I get 2.2.1 on there and it doesn't work, then I know it is a hardware issue.

    Update:
    I'm running baseband 4.05.04_G, which should be compatible. Not sure why I'm having trouble reverting to 2.2.1
    Last edited by drjaymez; 2010-05-01 at 05:04 PM. Reason: Automerged Doublepost

  2. #2
    Still can't get back to 2.2.1, and the intermittent nature of this bug is driving me nuts. I ordered an antenna to try to fix it, and if that doesn't work, I may try to find a wifi chip. I still don't understand, though, why if you read the enough forums, this is clearly linked to OS 3.0.

  3. #3
    Did you ever get it working?

  4. #4
    I did not get it working. It seems like the wifi was heat sensitive and frequently failed on these 2g iphones, especially with heavy use. It will work for a little while if I leave the phone off for a few hours and then turn it on, so I came to the conclusion that it was a hardware problem. You can buy a wifi module for $30 on ebay, but they look like a challenge to install, so I am either going to make due or ditch it.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •