Results 1 to 12 of 12

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone 3G 3.0 Wifi Not Working??

  1. #1
    Default iPhone 3G 3.0 Wifi Not Working??
    WiFi suddenly gone on iPhone 3G 3.0...

    I've been running an unlocked & jailbroken iPhone 3G since the 3.0 upgrade with very few issues. I don't have blackra1n or blacksn0w installed. I have Cydia and Winterboard. I have stayed far away from updates.

    Suddenly today, my WiFi stopped working. It is NOT grayed out, it just will not find any WiFi. I rebooted several times. I reset my network settings. I turned off Push. I stuck the phone in the freezer. Still no WiFi.

    Sometimes it does find a WiFi signal, but it will only stay connected for a few seconds or will give me an error message that says "Unable to Connect to..." I made sure my WiFi was unrestricted, and even reset my network settings before and after.

    I did a search within these forums; all the current issues seem to be tied to blackra1n or blacksn0w unlocks, but I don't have them installed and didn't use them to unlock. I used redsn0w.

    (Sorry for the cross-post, this was asked in another forum and I decided to ask in the main forum).

    Version: 3.0
    Modem: 04.26.08

    Monday I downloaded Wifi Fix from Cydia and when I run it, not only does Wifi not work, but I cannot get on the internet at all until I reboot the phone.

    Should I upgrade to 3.1 or newer?

  2. #2
    That's AMAZING...My 3G on 3.1.3 (redsn0w) just went out too. It had been working since i bought the phone a year or so ago and then Monday, nothing. Occasionally it will show my network, but give me the unable to connect message and the network disappears again. My laptop and the wife's 3GS connect just fine. I've done the usual reset network settings, rebooted etc... I haven't restored yet and not looking forward to that. I've googled for 2 days and haven't found a fix except restore and some say that didn't even help. To make things worse, my warranty just ran out in March!

    UPDATE!

    Unbelievable! So I sync with iTunes to back everything up getting ready to do a clean restore, and as soon as the backup was done, my wifi network shows up on my phone and lets me connect. WTF??? It's been down for 3 days now and the sync/backup brought it back?? I don't get it??
    Last edited by boozie; 2010-04-28 at 07:29 PM. Reason: Automerged Doublepost

  3. #3
    I'll try syncing my phone. I haven't done that in a very long time, I just tend to keep it away from iTunes altogether. When I got my new PC earlier this year, I had to re-sync and add music to my iPhone, but I did a back-up as well. But that was months ago.

    For what it's worth: my WiFi is intermittent. Sometimes it works fine. Sometimes it doesn't work at all. Sometimes it is in-and-out.

  4. #4
    Anyone else have this issue? Is this 3.0 related or a hardware failure?

    Any assistance is most appreciated.

  5. #5
    Im with you
    im on 3.0 using cydia and winterboard and i rarely sync with Itunes, and lately i have been getting booted off my wifi. weird

    anyone know whats up?

  6. #6
    http://modmyi.com/forums/general/331...-problems.html

    Going to try these next:

    Problem: No Wi-Fi After Pwning
    Fix: Use Pwnage tool in advanced mode, make sure auto delete of bootneuter is off, and under general make sure to uncheck enable baseband update. Restore to the new .ipsw. Go to settings>General>Auto Lock, set to never. In bootneuter toggle the unlock switch to the other side that it is at now, flash that result. Then go and flip it back to what it used to be, and flash that. Your phones Wifi should work now.

    Problem: Some other weird problem
    Fix: Repwning it usually works to fix most problems, use a custom firmware and do not restore from backup, if its a wifi/bt/phone issue reflash the baseband with bootneuter.

    Now, maybe a mod is reading this and can answer for me: When I re-pwn can use my original 3.0 custom ipsw firmware, or is the Pwnage tool going to create a custom firmware that Apple won't recognize any longer and leave me with a bricked phone?

  7. #7
    The above methods didn't work, bricked my phone presumably since the Sleep button is dead. Tried creating a custom firmware in order to create an auto DFU mode but iTunes wouldn't restore with that firmware.

    The only thing I can do is restore to 3.0 but I've lost my jailbreak and carrier unlock. There doesn't seem to be a viable method to create a DFU mode. I even resorted to trying ZiPhone but of course that crap didn't work.

    Since it seems all the experts are busy answering "NO" to the constant "can I unlock my 3.1.3 firmware" questions, basically I'm screwed, right?

  8. #8
    Default Same issue
    Just wanted to chime in to say that I have the same issue.

    After using the Spirit JB, I installed SB Settings and flipped some of the toggles for turning on 3G, EDGE, and an external plug in that toggled Data. I toggled them before testing WiFi so I'm unsure that the toggles caused the issue.

    I just uninstalled OpenSSH and Rock App as suggested by other threads I found when searching for the issue and neither uninstall had any effect.

    If anyone has any other ideas, please let us know.

  9. #9
    Quote Originally Posted by rickfu View Post
    Just wanted to chime in to say that I have the same issue.
    Upon further investigation, this may not be the same issue. I've restored and tested WiFi with no success. Then re-jailbroke and still nothing.

  10. #10
    None of the suggestions from the FAQ worked. I ended bricking my phone. Once I lost the carrier unlock by restoring there is no chance of getting it back without tethering or WiFi (to add and use Cydia). With the WiFi gone it's most likely a hardware issue. Same with the Sleep button. I really shouldn't have followed these directions from ModMyi. Right now I have a dead iPhone. However, I solved my problem ultimately by purchasing an HTC HD2.

  11. #11
    My WiFi suddenly stopped working as well. Tried "Reset Network Settings", but that didn't work. Pretty odd behavior, since it was working just fine after using pwnage tool. Just stopped working and does not even find other networks.

  12. #12
    No replies...

    This WiFi issue is a dirty little secret. Fortunately it seems to only affect a handful of users. It seems like these are legitimate issues and nobody has a viable answer.

    By following the directions posted in these forums' FAQs I lost the use of my phone. My recommendation would be to either live with your WiFi issues or get a new phone. Tinkering with your unlocked phone while having WiFi issues could be disastrous.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •