Results 1 to 6 of 6

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: possible to jailbreak 3gs on 3.1.3 so long as 3.1.2 is jailbroke?

  1. #1
    Default possible to jailbreak 3gs on 3.1.3 so long as 3.1.2 is jailbroke?
    Correct me if I'm wrong here. I had my 3gs jailbroken on 3.1.3 some time ago, however after some resetting, adjusting (due to ocd) and tinkering, I have ended up back with an unjailbroken 3gs on 3.1.3.

    I know I can downgrade it by altering the hosts file and using sauriks server as I am backed up. Once I'm back at 3.1.2 if I were to use say.. blackrain to jailbreak again.. I can successfully update and retain my jailbreak on my 3gs to 3.1.3 by creating a ipsw with snowbreeze and shift+restoring to the custom ispw right?

    It could be my imagination but I could swear I do remember having it jailbroken on 3.1.3 and that I reached it via the above means. I had read somewhere that the only way to jailbreak a 3gs on 3.1.3 is if you have 3.1.2 jailbroken first?

    someone confirm?

  2. #2
    If u have an original 3.1.3 on your phone right now. Then ur answer is going to be NO u can NOT jailbreak it, even if u go back to 3.1.2.

    Because ur baseband has been upgraded and as far as i know it hasent been broken.
    Last edited by l0k0; 2010-04-24 at 04:54 AM.

  3. #3
    yea i hvae been trying (wasting hours) going back to 3.1.2 ==> jailbreaking ==> trying to upgrade with custom 3.1.3 firmware and having to start all over again lol. for some reason i was CERTAIN i had done it a few weeks ago, then i set my iphone down and for some reason attempted to do/re-do it.

    ah well, if anyone has 3.1.3 jailbroken on a 3gs - please step in. otherwise, back to 3.1.2 for now!

    thanks for the reply ^^

    Quote Originally Posted by l0k0 View Post
    If u have an original 3.1.3 on your phone right now. Then ur answer is going to be NO u can NOT jailbreak it, even if u go back to 3.1.2.

    Because ur baseband has been upgraded and as far as i know it hasent been broken.
    now that i re-think this.. im not going crazy! i swear i did hvae it accomplished before!

    Stop me if im wrong - but doesnt the newer baseband only pull the rug out from under unlocking? I do have the newer baseband, but on 3.1.2 and it is currently j/b.

    I could have sworn I was in the same position as I am now, and I either upgraded by using a custom 3.1.3 via snowbreeze then iRecovery perhaps?

    none of that sounds plausable or no one has tried it?

    Common sense would suggest "well why dont you try that then" and my answer is A) I did and with fail the first time, but every time ive tried every method i have had working, ive failed the first time and B) I have court early and I have to stop for the night with a working phone!

    in all seriousness, some tutorials do mention that you can only upgrade if your using a currently jailbroken 3gs on 3.1.2. what it doesnt mention is if having the newer baseband stops the jailbreak or just the unlock in that situation.

    I know this has been beaten to death for what.. months now since 3.1.3 came out right? I apologize for rehashing what everyone already knows. Ive already made the mistake of upgrading to 3.1.3, fixed my mistake, and somehow have convinced myself that before I let my daughter borrow my phone and set it back to normal that I had 3.1.3 and cydia. Perhaps it was in a dream... hmmm
    Last edited by klepp1214; 2010-04-24 at 06:25 AM. Reason: Automerged Doublepost

  4. #4
    Retired Moderator j3st3r's Avatar
    Join Date
    Mar 2008
    Location
    Louisiana
    Posts
    2,447
    Thanks
    42
    Thanked 405 Times in 395 Posts

    if your phone has the new iBoot (bootrom) then it will not accept custom firmware at all...if that's the case then you will only be able to jailbreak 3.1.2...whether it has the updated baseband only affects unlocking not jailbreaking...

  5. #5
    Livin the iPhone Life
    Join Date
    Oct 2009
    Location
    Europe
    Posts
    2,830
    Thanks
    76
    Thanked 382 Times in 368 Posts

    Why do you guys want to be on 3.1.3 so bad? There's no benefit to it compared to 3.1.2 and if you have apps that require 3.1.3 you can just use a firmware faker.

    Just downgrade to 3.1.2 and jailbreak from there.

    As j3st3r3 said, baseband doesn't affect jailbreaking so it's possible to go from 3.1.3 down to 3.1.2 and jailbreak from there.

  6. #6
    Well as long as u have the 3.1.2 shsh backed up on Saurik or a local server, then i'd say u should have no problem going back to 3.1.2. But going back to 3.1.2 is pointless, except for JB.....But if ur in need of unlocking, then ur screwed for the time being. Since noone has unlocked the 3.1.3 baseband.

    As for 3.1.3, my phone actually runs better on 3.1.3. It could have been my shitty custom 3.1.2. But for some reason its alot better on 3.1.3. JB and Unlocked, so i couldnt complain.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •