Results 1 to 13 of 13

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: How to Upgrade to 3.1.2. I have 3.1 JB and Unlocked

  1. #1
    Default How to Upgrade to 3.1.2. I have 3.1 JB and Unlocked
    Do i have to get a custom firmware to upgrade to 3.1.2? I tried to just do an upgrade with Itunes and 3.1.2 IPSW but then wanted me to put in an ATT simm so I got locked out of my phone. I then used blackra1n to unlock it again but I was back to 3.1. Any help would be appreciated!

  2. #2
    Forum Manager Bo Troxell's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    35,196
    Thanks
    5,590
    Thanked 12,540 Times in 7,596 Posts

    Welcome to MMi,
    Update to 3.1.2 in iTunes, and then run the jailbreak to hacktivate it.

  3. #3
    I did that but then it won't let me past the "emergency call" recovery mode? When i use blacra1n it unlocked but it was back to 3.1

  4. #4
    Forum Manager Bo Troxell's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    35,196
    Thanks
    5,590
    Thanked 12,540 Times in 7,596 Posts

    No way that blackra1n is changing the firmware.
    If your on windows, hold shift key, click restore in iTunes and point to the 3.1.2 firmware and let it update, then run blackra1n to hacktivate and jailbreak.

  5. #5
    yea beats me...I'll try again!

  6. #6
    Forum Manager Bo Troxell's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    35,196
    Thanks
    5,590
    Thanked 12,540 Times in 7,596 Posts

    cool, let us know how it works out for you.

  7. #7
    nope didn't work still 3.1 (7c144)
    baseband 5.11.07?

  8. #8
    Retired Moderator Zwayne's Avatar
    Join Date
    Nov 2007
    Location
    Independence, LA
    Posts
    5,633
    Thanks
    656
    Thanked 764 Times in 591 Posts

    itunes stop signing 3.1.2, so you can't just updated through itunes. You can build a custom ipsw 3.1.2 with pwangetool for a mac, and then shift click an install the custom ipsw 3.1.2....

  9. #9
    Forum Manager Bo Troxell's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    35,196
    Thanks
    5,590
    Thanked 12,540 Times in 7,596 Posts

    You sure you have to correct firmware? 3g or 3Gs?
    Follow this link, download the correct firmware to your desktop, and try again.

  10. #10
    Ok got it jailbroken and upgraded to 3.1.2 with firmware 5.11.07 thanks to a custom IPSW. Should I use blackra1n to unlock or ultrasnow? I saw that ultrasnow needs lower baseband but not sure if that got fixed or not.
    Last edited by schwollo; 2010-04-05 at 07:17 PM.

  11. #11
    Retired Moderator j3st3r's Avatar
    Join Date
    Mar 2008
    Location
    Louisiana
    Posts
    2,447
    Thanks
    42
    Thanked 405 Times in 395 Posts

    Quote Originally Posted by schwollo View Post
    Ok got it jailbroken and upgraded to 3.1.2 with firmware 5.11.07 thanks to a custom IPSW. Should I use blackra1n to unlock or ultrasnow? I saw that ultrasnow needs lower baseband but not sure if that got fixed or not.
    you will need to use blacksn0w rc2 final to unlock it...here is the cydia repo... Cydia.pushfix.info - then search for and install 'blacksn0w RC2 Final'.

  12. #12
    Hi,

    Would appreciate your help in resolving an issue for me.

    I have a iphone 3gS 32GB with 3.1 (7c144)and baseband 5.11.07.

    I performed the BlackRa1n process. So in this process, I was able to see GeoHot picture on my Iphone and I did get a message saying Jailbreak process is done once rebooted etc, so the iphone rebooted and when I go into the applications, I am unable to see the BlackRaIn icon. I need this in order for me to proceed further with unlocking by installing Cydia and Snow.

    I tried this process the 2nd time and I still don't see the BlackRaIn icon.

    Could someone tell me what might be wrong.Appreciate it.

    Thanks

  13. #13
    I have the same 3GS 3.1(7c144) bb 5.11.07 new bootrom

    I tried to upgrade to custom 3.1.2 but got 1604 error and was stuck in restore

    Ran blackra1n and it booted, now it's jailbroken. I need to unlock it so I can use it in my country but I read blacksn0w has some wifi issues

    I then read about blacksn0w rc2 final by msftguy, repacked by pushfix. It claimed to have no wifi issues. It says it works for 3.1.2 and 3.1.3 bb 5.11.07. I tried it with my 3.1 but didn't work obviously.

    Now, I believe I shouldn't upgrade to 3.1.3, not even a custom one because of my new bootrom (can't be jb correct?)
    so I have to upgrade to 3.1.2 to use blacksn0w rc2 final but apple isn't signing restores for 3.1.2 anymore and using custom gives a 1604 error.

    Is there any other way I can install blacksn0w rc2 final?

    Thanks

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •