Results 1 to 5 of 5

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Insomnia not keeping wifi on 3.1.2

  1. #1
    Default Insomnia not keeping wifi on 3.1.2
    I have search the forums, Google, everywhere and still haven't been able to find a fix.

    I have an iPhone 2G 8GB.

    Insomnia used to function perfectly leaving my iPhone's WiFi on day and night, even for at least 2 days I believe the one time, obviously left plugged in to the USB cable.

    Now I am using 3.1.2 and the WiFi will die after so long unless I seem to disable autolock, but then that obviously starts killing the battery.

    Has anyone found a solution?

    Google Results with similar problems all seemed to be firmwares prior to 3.0 and I'm updated through Cydia with all the latest software.

    I had to give up on Insomnia.

    I tried KeepAwake which claimed to do the same thing.

    It seems to be working excellent, it worked all night long so far.

    Also has SBSettings option, which makes it easy to turn on/off just like Insomnia.
    Last edited by redpenguin; 2010-03-30 at 10:51 PM. Reason: Automerged Doublepost

  2. #2
    did you delete the insomnia daemon?

  3. #3
    No I did not.

    What's weird is keepalive seems to work at home but not for CISCO AP at college.

    Tried reinstalling Insomnia many times, no go.

  4. #4
    Default Fixed it
    I already tried re-installing it before and it didn't work.

    But this time, I removed, rebooted, installed, rebooted, and suddenly it appears to be working now.

  5. #5
    Well, it was fixed for a while but now a new problem exists.

    Sometimes Insomnia will show as on in SBSettings and no icon exists.

    In SBSettings the toggle will be green, if you tap it, it goes from Green to Green, but then one more time it goes to red, then back to green.

    This happens after each reboot or after long periods.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •