i think perhaps i did not reboot it since last syncing with itunes (which was the first time i synced it with itunes in 6 months) (i was having a problem getting itunes to read it and cydia was crashing but i fixed the cydia problem by uninstalling cyntact, dont know what fixed itunes) itunes worked jsut fine, synced all my photos and contacts

then i tried to use logome with a picture on my phone, simply didnt do anything

so

the last thing i did was uninstall LogoMe,SwirlyMMS,Snapture, & RealSMS in cydia, asked me to reboot, i pressed it

now it only comes up the the apple logo, tried the homebutton+powerbutton reset many times, doesnt help, tried plugging into wall, and computer, doesnt help

i dont know what i should delete thru SSH to get it to boot, but how am i supposed to access it (with my winscp or iphonebrowser) if i can't get the thing to stay on/connect to wifi to get an ipaddress for winscp?


p.s.:
i would love to jailbreak/upgrade up to 3.1.2 IF i can get all my apps, and backups of settings/contacts off the phone, can i have a step by step process of that? backing everything off my 3.0 jailbreak, and he fastest method of getting a 3.1.2 just the same?