Page 1 of 2 12 LastLast
Results 1 to 20 of 22

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: itunes 1600 error trying to restore custom ipsw on my 3GS, 3.1.2, 5.11.07

  1. #1
    Default itunes 1600 error trying to restore custom ipsw on my 3GS, 3.1.2, 5.11.07
    Hi,

    I stupidly reset all my network connections on my previously pwned 3.1.2. It's now stuck on the pineapple logo continuously.

    So when I enter DFU and try to revert to my custom ipsw I always get 1600 errors in itunes. Will this be related to Apple no longer signing this version? I have tried the '74.208.10.249 gs.apple.com' entry in /etc/hosts with no luck.

    I did record my 3.1.2 shsh with cydia and umbrella returned a 66kb file.

    Would be grateful if anyone recommend an itunes or other way of getting my custom firmware back onto the phone without the itunes 1600 error.

    I had a bash using redsn0w 0.9.2. It successfully got through the install (used 3.1.2 restore file), but now my phone is just is continually in a apple reboot cycle. My phone is 3GS [iBoot-359.3] week 38. Would be grateful for any ideas....going to try verbose boot option
    Last edited by ourobrs; 2010-03-22 at 04:17 PM. Reason: Automerged Doublepost

  2. The Following User Says Thank You to ourobrs For This Useful Post:

    Valterl (2010-04-02)

  3. #2
    Retired Moderator Poseidon79's Avatar
    Join Date
    Jan 2008
    Location
    Austin, TX
    Posts
    8,264
    Thanks
    819
    Thanked 1,681 Times in 1,159 Posts

    If you are currently jailbroken then you don't need to enter DFU mode in order to restore to a custom firmware. Put your iPhone in recovery mode by holding power+home until you get the iTunes logo (or steve jobs cartoon) then restore.

  4. The Following User Says Thank You to Poseidon79 For This Useful Post:

    Valterl (2010-03-31)

  5. #3
    Thanks! It's worth noting that my phone would not go into recovery mode (or there were no logos to indicate).

    What I did was use redsn0w 0.9.2 to try to add a standard 3.1.2 on my phone. This kinda worked, in that it gave me all the logos back, but verbose boot showed a problem requiring a fsck each time. However as this gave me the recovery logos back, then itunes would work for the custom pwn restore (pointing to sauriks site)

  6. The Following User Says Thank You to ourobrs For This Useful Post:

    Valterl (2010-04-02)

  7. #4
    Retired Moderator j3st3r's Avatar
    Join Date
    Mar 2008
    Location
    Louisiana
    Posts
    2,447
    Thanks
    42
    Thanked 405 Times in 395 Posts

    if u are restoring to a custom firmware then u don't have to point iTunes at saurik's server...that only applies to official firmwares

  8. The Following User Says Thank You to j3st3r For This Useful Post:

    Valterl (2010-03-31)

  9. #5
    I have been stuck with the dreaded pineapple logo for over a week now. I am guessing this is bc I tried to reset network settings in iPhone (when I restored with custom fw but got NO service.)

    Is there anything I can do differently? I've tried:
    1. restoring with custom 3.1.2 firmware of sorts
    2. restoring with the official apple firmware (and pointing host file to Suarik's site.)
    3. restoring via Vista and Win7 PCs and using different usb ports

    Would it help if I completely deleted all the iTunes folders and start fresh? I'm not very savy with using mod software as the guys above seem to be.

    Not sure if I backed up to Saurik's server as I'm in constant pineapple logo freeze/rebootings! I know that I used a Cydia app to "back-up" the apps supposedly via iTunes(?)

    Errors I get: unknown error 1600 and the "not compatible" error.


    Thanks for your help in advance!

    [3gs/Vista & Win7/iTunes 9.0.2 and 9.0.3/Blackra1n/Cydia/baseband 5-11-07???/AT&T]

  10. #6
    Livin the iPhone Life
    Join Date
    Oct 2009
    Location
    Europe
    Posts
    2,830
    Thanks
    76
    Thanked 382 Times in 368 Posts

    Could you successfully restore to custom firmware but got no service?
    Do you use an official or unofficial carrier?
    Did you try a restore to stock 3.1.2 from both DFU and recovery mode?

  11. The Following User Says Thank You to dhamien For This Useful Post:

    Valterl (2010-04-02)

  12. #7
    Yes: restored to custom fw but then no service. (I think I initially used the wrong custom version which was "ACTIVATED" when I should have restored with "NOT ACTIVATED" firmware as I have official service with AT&T. THen I wonder if I messed up further by manually resetting "network settings" within the settings in the iphone itself (per an idiotic internet source!!) :-(


    Yes: tried to restore with both stock apple fw and the correct custom versions as itunes said "must restore". I can't seem to get out of DFU mode/frozen logo (black screen when not attempting restore). I don't ever get the 'usb connect to itunes' image anymore. (Tried several times to 'hold power+home button x 10 seconds then release power & hold home 5-10 seconds sequence' but still no luck? Was that the 'recovery mode' process? Blackra1n waits for my iphone but it never works either.

  13. #8
    Hi Valterl,

    It sounds like you may have one of the newer iPhones that needed the tethered reboot and with your various interactions, you've now left it in a state where it will only restore to 3.1.3. We have one in our house like that also!

    Then again, having the pineapple logo shows it's actually trying to boot so all may not be lost....

    Regarding making sure you are actually in Restore mode, rather than DFU. You are in DFU if itunes will allow an official restore, and your apple logo -> about this mac -> more info -> usb part says iphone DFU mode.

    So while in itunes at that point, try holding down both buttons for >10 secs, you may be lucky and get the official restore logo/russian Steve Jobs/other custom restore logo.

    Otherwise on my DFU only iphone I'm upgrading to 3.1.3 and hoping the new crack is released with the iPad in a few days
    Last edited by ourobrs; 2010-03-29 at 06:29 AM.

  14. The Following User Says Thank You to ourobrs For This Useful Post:

    Valterl (2010-03-31)

  15. #9
    Livin the iPhone Life
    Join Date
    Oct 2009
    Location
    Europe
    Posts
    2,830
    Thanks
    76
    Thanked 382 Times in 368 Posts

    Quote Originally Posted by Valterl View Post
    Yes: restored to custom fw but then no service. (I think I initially used the wrong custom version which was "ACTIVATED" when I should have restored with "NOT ACTIVATED" firmware as I have official service with AT&T. THen I wonder if I messed up further by manually resetting "network settings" within the settings in the iphone itself (per an idiotic internet source!!) :-(


    Yes: tried to restore with both stock apple fw and the correct custom versions as itunes said "must restore". I can't seem to get out of DFU mode/frozen logo (black screen when not attempting restore). I don't ever get the 'usb connect to itunes' image anymore. (Tried several times to 'hold power+home button x 10 seconds then release power & hold home 5-10 seconds sequence' but still no luck? Was that the 'recovery mode' process? Blackra1n waits for my iphone but it never works either.
    Did you try making a custom that was unactivated? Because if you did in fact choose acivated, it explains why you could boot but got no service.

    Another thing, when you want to unlock, try using blacksn0w RC2 instead of the regular one. Add the repo http://cydia.pushfix.info/ and then install it from there. This should fix the boot loops and wifi problems that the regular blacksn0w has.

    Hmm, I need to read a little better. blacksn0w is not for you if you don't need it unlocked obviously. Did you need it on an official carrier? ATT? or unofficial? T-mobile?

  16. The Following User Says Thank You to dhamien For This Useful Post:

    Valterl (2010-03-31)

  17. #10
    I think I understand the problem with lacking service initially. I've got even bigger problems now such that 1. I cannot power off the phone (only until battery runs dead), 2. stuck on pineapple logo (many button sequences only make it return or go to BLACK screen when connected to iTunes or not. 3. The phone seems to reboot about every 10 minutes or so (back to the pineapple logo.)

    I can't do anything at all. I tried so many things already, restoring with custom 3.1.2(non-activated version since I'm with AT$T) and offical apple 3.1.2 (after modifying my HOST file to point to Saurik's site), also created a custom 3.1.3 restore file using sn0wBreeze but still get the "...unknown error (1600)".

    After about 12 days of troubleshooting my iphone I think I've just about had it!!! I pray that George Hotz comes up with something good to counteract -----> 3.1.3 update cuz that's where I'm headed now!! Boo!

    Thanks to everyone who tried to help!

  18. #11
    Have a bash with redsn0w 0.9.2 and a standard 3.1.2 ipsw.

    redsn0w makes sure you are in recovery mode and there is a dialog to help you. Click already pwned and verbose boot and at least you will see why the pineapple is rebooting. In my case it had fsck errors and it made me realise how to get it into recovery mode in itunes for the custom ipsw 3.1.2 recovery.

  19. The Following User Says Thank You to ourobrs For This Useful Post:

    Valterl (2010-04-02)

  20. #12
    Great! Thanks. Well, at lease now I'm stuck back at the apple logo (no more pineapple!)

    I did the redsn0w 0.9.2 and standard 3.1.2 ipsw with both options selected as said above (pwned and verbose boot.) I finally got some stuff on the iphone that I have not seen before but first I had to hold both power + home for approx. 50-60 seconds before the redsn0w message screen went away. I ran redsn0w again and this time clicked: Install Cydia and already pwned. At some point I closed iTunes and ran blackra1n...then I got some sort of downloading disc something or other and downloading activating package - or something.

    Then, I went back to iTunes and tried to do a custom 3.1.2 restore. ---> still 1600 error! I'm still left with a frozen logo and can't seem to boot up to get to springboard. Am I FINALLY at least moving in the forward direction?

  21. #13
    hey i was doing the same thing today on my friends iPhone 3GS 3.1.2 its currently jailbroken aswell but on a recovery mode bootlooop. i made custom firmware with pwnage tool tried restoring it in DFU mode got the 1600 error and found out that i dont need to be in DFU mode. so i tried it in recovery mode and got a 1604 error message any ideas guys?

  22. The Following User Says Thank You to rphh For This Useful Post:

    Valterl (2010-04-02)

  23. #14
    The 1600 error is because you are in DFU mode, not recovery mode.

    In itunes, Do whatever you did on redsn0w to make it go into recovery mode(hold for 50 to 60 seconds) (because it had to be in recovery to allow all that stuff to happen) then select your custom ipsw. All will be good.

  24. The Following User Says Thank You to ourobrs For This Useful Post:

    Valterl (2010-04-02)

  25. #15
    Thanks ourobrs! I can't remember if I tried redsn0w with custom or not but I will give a try after work tonight and report back (hopefully with AWESOME news for a change!) :-)

  26. #16
    Valtrl:
    after reading this page, i found i have absolutely completely exactly the same problem like urs, and i've done what u had done . and i looked up many help from web, got one answer, our iphone is under DFU mode, and the problem is , whatever i did, it just cant quit the god dame DFU mode, all the 1600 error was becoz of DUF mode not revoery mode, though the itunes says "detected a iphone in recovery mode". thus im gonna try to ask help from the apple tech guys, just need get the hell out of the DFU mode. looking forward any help and info, thx all

  27. #17
    redsn0w only works with non custom ipsw's. I only asked you to try with redsn0w as it has the dialog to make sure you put your phone into recovery. And as it did all this stuff I know you had the same problem as me:

    You are not getting your phone into recovery mode in itunes. It's always in DFU.

    goto itunes and restore on the custom 3.1.2 ipsw, but do whatever you had to do in redsn0w to get it into recovery first. I have to hold both buttons for about 15 secs to see the different logo, but hold it longer if needed. once you restore on this different logo (in tunes with custom ipsw) all will be good.

    Exactly. Just play with your phone going through the dual key combinations until you get your phone into proper recovery mode. You have done it once in redsn0w when you saw the steve jobs/iphone restore different logo.

    That's what you need in itunes to get it to accept CUSTOM ipsw's
    Last edited by ourobrs; 2010-04-01 at 06:20 AM. Reason: Automerged Doublepost

  28. The Following User Says Thank You to ourobrs For This Useful Post:

    Valterl (2010-04-02)

  29. #18
    Horray!! I'm back up and completely running my JB 3GS at 3.1.2!! THANK YOU SOO MUCH EVERYONE for helping me to solve these very long and frustrating issues!! I can't even begin to tell you guys how appreciative I am!

    To attempt to summarize from what many people on this site said (and a few other friends elsewhere) this is what happened:

    1. Downloaded Redsn0w 0.9.2 from redmondpie's site.
    2. Downloaded the original fw.
    3. Downloaded the WINDOWS item (if not using a Mac) that supports Redsn0w (from redmondpie's official site, too.)
    4. Make sure your iTunes is the lateset version.
    5. Run redsn0w using original fw and follow the redmondpie's site instructions ~very carefully!~ : the phone showed me some different logos/actions and stuff when it eventually gave me the apple logo back (but still stuck in DFU mode. See 'ourobrs's entry on 3/28 above for specifics regarding this.)
    6. I eventually figured out that the only way to get out of DFU mode and into "recovery mode"(in order to restore within iTunes) was to hold power + home for about 40 seconds until you see the usb cable logo on the phone. Then release both buttons immediately.
    7. Close out of Redsn0w. Keep iphone plugged in to computer and get iTunes to give you the message to restore. Hold both iphone buttons to get recovery mode -which takes about 40 seconds.
    8. Then find your custom fw in iTunes (Click SHIFT + restore together and select the appropriate custom firmware. ***You must first have already altered your host file to make apple's 'verification process' talk to Saurik's Cydia site instead of Apple's***. Do a search online for where to locate it on your computer and how to edit that file to add a specific entry in that file.

    (NOTE: when downloading the CUSTOM firmware be sure you know the difference between "custom ACTIVATED" (for non-AT&T customers) and "custom NOT ACTIVATED" (for offical AT&T customers)!! Google those if u need more info! Choose the wrong one and you won't have cellular service --like I did at first!)
    9. Restore with the custom firmware and hopefully you will get lucky like I did! I did indeed have SHSs backed up with Cydia servers fortunately...simply because I used Cydia a lot before the crash. (I'm not certain if this was important in the my recovery process or not.)

    ***I'm no iPhone expert and I cannot be held liable for any info that I supply. Please reserve your questions/concerns for the Moderators on this site! Thanks and I hope this works for you too if this is your same exact issue!***

    Things that may have made a difference too??:
    1. restart the computer several times in between trys and take out battery (laptops) or power chords (desktops) for 30 seconds once powered down.
    2. Use different USB cables and USB ports if computer doesn't recognize your iphone as the USB device.
    3. Use Firefox or Safari (instead of internet explorer.)
    4. Someone mentioned that Windows 7 might alter your downloads somehow? I didn't know and stuck with VISTA.

  30. #19
    congratulations valterl, good to hear that u had ur iphone back to work, however im still struggling with my iphone with the same problem, i followed ur latest post, and i got a different result while the "step 5" from ur last post, when i selected the " install cydia" and click "next" , it suppose to ask me to get into DFU mode (which was to hold both buttons for 10+seconds and release the power buttonO , however it just processed itself quickly without asking me and then get the next screen displays " waiting for reboot" and stuck there forever, and my iphone was still black screen nothing happened, no log no usb --disc , no nothing just black screen as it was before, I wonder if i should run the redsn0w without running the itunes or run them both, and another question i dont know what the "items" u mentioned in ur last post as "step 3" which supports the redsn0w, i didn't use it. thanks again , thanks all the friends who helped me and this thread , looking forward helps

    Sorry for my poor English. For the question "how to get out of DFU mode" , i tried to hold both buttons for over 1 min and still didn't make any difference, the screen was still black, but i the itunes pops up that" detected an iphone in a recovery mode" when i hold both buttons, thus i press enter (ok) without release the 2 buttons on my iphone for 10 seconds the same box pops up again, so i wonder, if there was any difference between these 2 difference reactions ? and i have no idea if my iphone was out of DFU mode or not after i holding both buttons for over 1 min, coz the screen was always black.
    Last edited by malady1; 2010-04-03 at 05:40 AM. Reason: Automerged Doublepost

  31. #20
    I think that what step 5 did for me was free me from the pineapple logo (gave me the apple logo back.) Maybe it also reset some boot settings? I haven't a clue. The first time I used redsn0w 0.9.2 I only selected "already pwned" and "verbose boot" as one of the members said in an earlier post in this thread. Don't select Cydia the first go around.

    Regarding step 3: when using windows (NOT Mac) I downloaded the additional Window's download file that supposedly helps run Redsn0w: Download Redsn0w 0.9.2 to Jailbreak iPhone 3.1.2 Firmware | Redmond Pie (see download links towards bottom.)

    I would try redsn0w the first time with options selected as I said above (to try to get rid of pineapple.) Then run redsn0w again and select "already pwned" and "cydia". Then I would close redsn0w and open iTunes to try the custom firmware. As you have your phone plugged into Itunes, try again to hold BOTH power and home for about 45 seconds...if you get the usb icon then YOU ARE IN "RECOVERY" mode and may be able to install your custom 3.1.2 firmware (...that is if you were in the same boat that I was in with this issue.)

    You will know when you are out of DFU mode when you see the usb cable icon thingy.

    Best of luck! I hope this works. I'm certainly no expert in this.

Page 1 of 2 12 LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •