I posted this last night under the AT&T sub-topic and got over 130 views with no replies, so I'm posting here again hoping to get some help. Thanks



Due to a weird unexplainable jailbreaking/unlocking mishap, somehow something on my iPhone 3G got corrupted. Not sure if it's the baseband firmware due to Fuzzyband (downgrade from 05.12.01 to 04.26.08) or if it's the Bootrom or the NOR or NAND or whatever.

Now, it is essentially bricked. I cannot restore to pwned firmware, and I cannot restore to stock Apple firmware (I've tried with 3.0.1, 3.1.2, and 3.1.3, on Windows Vista, Windows 7 64-bit, Snow Leopard 10.6.2, using both iTunes 8.2 and iTunes 9.0.3).

I've tried redsn0w 0.9.4 (as well as 0.9.3, and 0.8), tried iReb 3.1.2, Sn0wbreeze 3.1.3, as well as custom firmwares made with PwnageTool.

Over the last few days, I have done nothing but restore my iPhone, and each time, iTunes' logs tell me "device returned AMR error 6." This always happens during the "operation 25" or "modifying persistent boot-flags" stage. So the restore fails each time, and the iPhone goes immediately back into DFU mode. If I run redsn0w, everything goes fine but then the phone doesn't reboot, it again goes immediately back into DFU mode.

Question 1: Can someone please tell me how to get this thing back on?


If I can save this iPhone that would be the optimal solution, but as you can see from the above I've just about tried everything. Which leads me to,

Question2: Can you recommend any smartphones running Android that I would be able to use under my current AT&T iPhone 3G plan?


I'd appreciate any help/suggestions. Thanks You.