Results 1 to 5 of 5

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: upgrading 3.0.1 to 3.1.2 and keeping baseband 4.28.08

  1. #1
    Default upgrading 3.0.1 to 3.1.2 and keeping baseband 4.28.08
    With all the talk about problems between versions, I'm somewhat confused and hoping someone can shed some light.

    I've got 3.0.1 aand BB 4.28.08. It seems there *used* to be an issue with unlocking 5.11.07 - which has been "fixed".

    Is there a way - or any reason to try and keep the older BB 4.28.08 - or do I just go straight to 3.1.2 and let it rain???

    Argg - in addition, it seems there are several ways to go to 3.1.2. One seems "custom cooked FW" - which may have to do with my specific ECID (???). With the differing ideas (some likely older and hence why they differ) I am scared... Your kind advise please... I'm already unlocked and Jailbroken...
    Last edited by rrolff; 2010-03-19 at 10:40 PM.

  2. #2

  3. #3
    Quote Originally Posted by rrolff View Post
    With all the talk about problems between versions, I'm somewhat confused and hoping someone can shed some light.

    I've got 3.0.1 aand BB 4.28.08. It seems there *used* to be an issue with unlocking 5.11.07 - which has been "fixed".

    Is there a way - or any reason to try and keep the older BB 4.28.08 - or do I just go straight to 3.1.2 and let it rain???

    Argg - in addition, it seems there are several ways to go to 3.1.2. One seems "custom cooked FW" - which may have to do with my specific ECID (???). With the differing ideas (some likely older and hence why they differ) I am scared... Your kind advise please... I'm already unlocked and Jailbroken...
    3g or 3gs?
    Best is update with custom firmware to keep the old baseband that can be used with Ultrasnow, which is more stable than blacksnow.
    Note that if you have 3gs, make sure it has old bootrom, only one with old bootrom take custom firmware.
    good luck

  4. #4
    yea, go straight from where you are now to a custom prejailbroken 3.1.3. I went from 3.0 out of the box to a custom 3.1.3 and my bb stayed at 4.26.08. no errors. I used itunes 8.2 but I don't think it really matters.

    make sure you edit your hosts file first so that when you do restore with the custom prejailbroken 3.1.3 on itunes, your SHSH hashes are intercepted by cydia's server. then when you launch cydia, you will see the message at the top that says 'this device has SHSHs on file for iPhone OS:3.1.3'.

  5. #5
    I downloaded the custom IPSW for 3.1.2, and restored it.

    I did not do the SHSH ECID - and am not sure how that is accomplished - the phone is just finishing it's app syncing.

    It does seem easy if you're on an older baseband and running a custom IPSW. Probably should've gone to 3.1.3 - but didn't see enough posts to want to play with it...

    Thanks for the advise!

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •