I'd like to know if anyone has gotten psx4iphone, or gpSPhone running yet on 3.1.2. I'm still on 3.0.1 and all is well. I have noticed however, that there's been a couple of app store apps I've wanted to download and I get the "You need 3.1 to download this app." Kinda sucks. Specifically, I'm referring to Layar.

Thanks!