Results 1 to 6 of 6

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Various Crashes Since 3.1.2 Update Solved (For Me At Least)

  1. #1
    My iPhone is a Part of Me iGuy's Avatar
    Join Date
    Feb 2008
    Location
    Hampshire, UK
    Posts
    539
    Thanks
    48
    Thanked 63 Times in 58 Posts

    Default Various Crashes Since 3.1.2 Update Solved (For Me At Least)
    Just a little background first....

    I've tried numerous times to update to 3.1.2 but the phone keeps running in "Safe Mode" after each install. I worked out that if I deleted Winterboard this wouldn't happen. I understand many people have had the same problem with other applications such as the Weather Icon & SBSettings, or apps not opening like Cycorder etc, although the vast majority don't seem to have had these problems which was even more confusing. I've been JBing/ULing my phone since the 1.1.2 days so I couldn't understand what was going wrong this time.

    So in the end I'd always revert back to 3.0 just so I could have my phone looking & acting how I wanted before my next attempt.

    I've scoured the net looking for answers/Restored/Hard Reset/Re-ran PWNage 3.1.4/ etc etc so many times these last few days (I reckon I could do them all in my sleep now) but this has all been in vain, although I did start to pick up various clues of preventing this along the way.

    One thing I did pick up was the Mobile Substrate was updated to 30xx at some point, but on my 3.1.2 it always showed as 29xx and wouldn't update, whereas on 3.0 it would.

    Today I finally found the last piece to the riddle.

    Saurik's source under 3.1.2 on Cydia is allegedly out of date. What I needed to do was to delete Winterboard etc and then add the source apt.saurik.com/cydia-3.7. After this my Cydia "Essential Updates" shot up from 5 to about 16.

    Since doing this I've reinstalled Winterboard/SBSettings/etc and everything is running as it should under 3.1.2.

    I'm not saying this will work for everyone but it has for me.

    What I've been using by the way (if anyone see's a common factor let me know):

    2G iPhone
    MacBook OS 10.6.1
    iTunes 9.0.1
    PWNage 3.1.4

    Sorry about the long post but I hope it helps someone out there.

    And a big THANK YOU to the various websites I've trawled over the last few days in trying to resolve this.
    Last edited by iGuy; 2009-10-15 at 08:02 PM.

  2. The Following User Says Thank You to iGuy For This Useful Post:

    tutumano (2009-10-25)

  3. #2
    I had the EXACT same thing happen, I wrote about it on another forum. Here are my notes about it:

    Took me a few IPSW building and restore attempts too. Kinda occupied me all day yesterday. At first I'd thought it was all working, but Cydia was acting weird (not showing me package information and screenshots like it normally does.) Then when I tried to restore from my PKGBackup, I'd get lots of springboard crashes, really slow bootups, and other weirdness. I figured it was an incompatibility with an app I had installed... but I had no way of knowing which one.

    I thought it was some problem with Winterboard, or maybe Icy? So that's where I spent the most time, kept rebuilding IPSWs, with and without each, trying to only download latest versions directly on the iPhone itself. I think I created about 6 different IPSW's...

    Still nothing was working right. I was thinking I'd have to reinstall each Cydia add-on one by one to nail down the culprit. But even when I'd install just one (like SBsettings) I'd get more "safe mode" reboots. Totally frustrating, since I know the basic add-ons were working for plenty of other folks.

    Started digging around and read that Cyntact (one of my add-ons I like) required MobileSubstrate 0.9.3051, and yet all I was able to see and download was version 0.9.2977-1. Very frustrating... I was about ready to throw in the towel and restore back to 3.0.x and move along from the headache. Why wasn't I able to get the latest versions of things?

    Then I stumbled upon this:

    If you got the old version of Telesphoreo source, there is a quick fix for all that. Just go to Cydia , tap the Sources, Edit and add: apt.saurik.com/cydia-3.7
    Sure enough, that did the trick. For whatever reason, even with a complete rebuild and restore, I was only accessing saurik's older repository. And so I wasn't getting the required updates for all of these apps to work. Once I added that new source repository, a bunch of changes/updates were downloaded, and everything started working properly again.

    Such a simple issue caused a big headache. I suppose this is the nature of the jailbreak scene. It's a big cluttered mess with everything changing all of the time. You've got to roll with the punches and stay on your toes, and be ready for some confusing challenges.

    Glad I got it resolved and hopefully this will help someone else out there if they encounter the same issue.

  4. The Following User Says Thank You to Fofer For This Useful Post:

    tutumano (2009-10-25)

  5. #3
    My experience was a little bit different (on a 3GS, blackra1ned 3.1.2), although adding the 'cydia-3.7' source, no new essential updates and the crashing to safe mode problem still exists.

    one post helped me from battlecrushr on a forum that filled with sin (can't say the real name ), the culprit was "the universal search", after uninstalling it, no more crashing to safe mode after un/installing apps from appstore or cydia.

    if u happen to have 'universal search' and experiencing crashes, uninstall it. Hopefully it will resolve the issue just like mine.
    Last edited by asae; 2009-10-20 at 03:43 AM.

  6. #4
    I have "Universal Search" installed -- no crashes, though. I am on 3.1.2 and jailbroke with PwnageTool, as detailed above.

  7. #5
    lucky for you, wished i could run univ search..possibly mobilesubstrate add-ons conflict on my side.

  8. #6
    Default Hello Guys I need help
    I'm very lost with this 3.1.2 firmware, I have a 2g iphone and Windows Vista, and I Restore my Iphone from 3.0 to 3.1.2 via Itunes. The phone was working nice, then I installed cycorder and ifile, when I installed winterboard the problem start. The iphone reboots and now the phone stays black, I just see the apple and then the phone crashes again. And I tried to put it into DFU mode, and the phone tries, but never gets into the recovery mode. So redsnow and the itunes restore finds an error with the phone. How I can fix this crash?

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •