Results 1 to 5 of 5

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: MMS problems on jailbroken 3GS with 3.1

  1. #1
    Default MMS problems on jailbroken 3GS with 3.1
    I used the PwnageTool to jailbreak my 3GS on 3.1 and everything went perfectly. I followed the always given advice to set my phone up as a new one rather than restore from a backup. However, I wanted to keep my SMS messages so I used iPhone Backup Extractor and DiskAid (from the method described at How To Recover Your iPhone Files, Photos, Contacts, Notes, SMS, Call History, Etc.) to copy over sms.db. I got my messages, including all old MMS just fine, but I can't send or receive new MMS.

    I'm not sure if this is because of the hack I did or something else. I have tried carrier 5.5 and 6.0 and it is the same. Also, everything worked fine on 3.0.

    When I try to send, it hangs with 10% and never finishes. If I leave the app and go back in, the image no longer shows up there. It's just a blank spot. If someone tries to send me a message, I get the blue circle with arrow icon, but no picture next to it.

    SMS works fine though.

    I am wondering if this is some permissions related thing and the phone is having trouble writing the image files or something along those lines?

    Any help would be appreciated.

    I've spent hours searching Google, this forum, and all of the comments on the various sites outlining the jailbreak process, I haven't found anything. Hopefully, I didn't miss something.

  2. #2
    Try reinstalling the ipcc file again. You can find a few links to the carrier update on threads here. The MMS thread on our news page (first post) by Stealth has links to the file.

    Anyways...Install it and completely turn your phone off then on again.

  3. #3
    Just tried that again with the ipcc file from that thread and it's still the same.

    I think the key to where the issue lies is the fact that the images don't stay in the conversation either. If I hit send (for a picture) and then close out while it's trying to send, there is a spot for the message when I go back, but the picture is gone.

    All previous MMS pictures show up fine though.

    If I send a contact via MMS, that works fine.

    So I guess I messed up something with where the MMS pictures are saved? Does anyone know where this is?

  4. #4
    I was having this problem too. I had copied the SMS, Notes & Call History folders and all of their contents to my computer then put them back on the phone after the restore. Couldn't send pictures, so I deleted everything in the SMS folder. Pictures became sendable again. I am thinking it has to do with sms.db or sms-legacy.db as opposed to all the other files in the subfolders. The permissions thing sounds like a valid theory to me.

    side question...How would one go about combining the contents of the sms.db & sms-legacy.db currently on the phone with their counterparts on the computer?

  5. #5
    So if I just delete everything in that folder it'll be okay? The iPhone will generate a new SMS.db file?

    I followed your advice and it worked! Then I was able to use iTextUploader to restore my SMS.

    WOO!

    Thanks!
    Last edited by Iboremyselftoo; 2009-10-07 at 05:50 PM. Reason: Automerged Doublepost

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •