Results 1 to 2 of 2

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone 2G - iRecovery log included - recovery loop

  1. #1
    Default iPhone 2G - iRecovery log included - recovery loop
    Hi all,

    I was referred here by saurik's article on downgrading the iPhone 3Gs. I noticed that in his process he experiences the same problem that I am - particularly NAND errors and fs mounting failure reported by iRecovery.

    Here is my log:
    Code:
    Microsoft Windows [Version 6.1.7100]
    Copyright (c) 2009 Microsoft Corporation.  All rights reserved.
    
    C:\Users\Terence>cd c:\
    c:\>irecovery -s
    iRecovery - Recovery Utility
    by wEsTbAeR-- and Tom3q
    
    Got USB
    
    
    =======================================
    ::
    :: iBoot for m68ap, Copyright 2009, Apple Inc.
    ::
    ::      BUILD_TAG: iBoot-596.24
    ::
    ::      BUILD_STYLE: RELEASE
    ::
    ::      USB_SERIAL_NUMBER: CPID:8900 CPRV:20 CPFM:03 SCEP:05 BDID:00 ECID:000003
    16A80DB58E IBFL:01 SRNM:[7W741XHPWH8]
    ::
    =======================================
    
    [FTL:MSG] Apple NAND Driver (AND) RO
    [NAND] Device ID           0xa585d598
    [NAND] BANKS_TOTAL         3
    [NAND] BLOCKS_PER_BANK     8320
    [NAND] PAGES_PER_BANK      1064960
    [NAND] SECTORS_PER_PAGE    4
    [NAND] BYTES_PER_SPARE     64
    [FTL:MSG] FIL_Init            [OK]
    [FTL:MSG] BUF_Init            [OK]
    [FTL:MSG] FPart Init          [OK]
    read old style signature 0x43303034 (line:301)
    [FTL:WRN] Incompatible Signature!
    [WMR:ERR] NAND format invalid (mismatch, corrupt, read error or blank NAND devic
    e)
    [WMR:ERR] boolSignatureFound false  boolProductionFormatVerified true nSig 0x433
    03034
    ******************************************************************************
    ******************************************************************************
    AND: NAND initialisation failed due to format mismatch or uninitialised NAND.
    AND: Please reboot with reformatting enabled.
    ******************************************************************************
    ******************************************************************************
    NAND FTL failed initialisation
    Boot Failure Count: 1   Panic Fail Count: 0
    Delaying boot for 0 seconds. Hit enter to break into the commad prompt...
    root filesystem mount failed
    Entering recovery mode, starting command prompt
    ←[m] (Recovery) iPhone$
    (Recovery) iPhone$
    as well, here are my environment variables

    Code:
    (Recovery) iPhone$ printenv
      build-style = "RELEASE"
      build-version = "iBoot-596.24"
      config_board = "m68ap"
      loadaddr = "0x9000000"
      boot-command = "fsboot"
      idle-off = "true"
      boot-path = "/System/Library/Caches/com.apple.kernelcaches/kernelcache.s5l8900
    x"
      display-color-space = "RGB888"
      display-timing = "optC"
    P bootdelay = "0"
    P filesize = "1153494762515329024"
    P platform-uuid = <DATA>
    P backlight-level = "65"
    P auto-boot = "true"
    P boot-device = "nand0"
    P boot-partition = "0"
      image-verson = "0x3"
      framebuffer = "0xfd00000"
      secure-boot = "0x1"
    (Recovery) iPhone$
    iTunes reads it in recovery mode, but nothing other than redsn0w and iRecovery recognizes it. I have tried a DFU recover, and normal shift-click recover with 3.0 and 3.1, to no luck. I just want it to get out of recovery mode - It dosen't matter if it is JB'd or unlocked.

    Any ideas? I am quickly running out as it is my FIRST time messing with apple code.

    I read on saurik's article that he somehow enabled NAND reformatting, followed by ANOTHER restore - how do I do that (if it is at all possible)

    Thanks, appreciate it!

  2. #2
    Exclamation same here... the error 23 is stubborn
    same here... the error 23 is stubborn

    Code:
    =======================================
    ::
    :: iBoot for m68ap, Copyright 2008, Apple Inc.
    ::
    ::      BUILD_TAG: iBoot-385.49
    ::
    ::      BUILD_STYLE: RELEASE
    ::
    ::      USB_SERIAL_NUMBER: CPID:8900 CPRV:20 CPFM:03 SCEP:04 BDID:00 ECID:000003
    1E540D830E SRNM:[87808KK7WH8]
    ::
    =======================================
    
    [FTL:MSG] Apple NAND Driver (AND) RO
    [NAND] Device ID           0x2555d5ec
    [NAND] BANKS_TOTAL         4
    [NAND] BLOCKS_PER_BANK     8192
    [NAND] PAGES_PER_BANK      1048576
    [NAND SECTORS_PER_PAGE    4
    [NAND] BYTES_PER_SPARE     64
    [FTL:MSG] FIL_Init            [OK]
    [FTL:MSG] BUF_Init            [OK]
    [FTL:MSG] FPart Init          [OK]
    [WMR:ERR] NAND format invalid (mismatch, corrupt, read error or blank NAND devic
    e)
    [WMR:ERR] boolSignatureFound false  boolProductionFormatVerified true nSig 0x0
    ******************************************************************************
    ******************************************************************************
    AND: NAND initiaisation failed due to format mismatch or uninitialised NAND.
    AND: Please reboot with reformatting enabled.
    ******************************************************************************
    ******************************************************************************
    NAND failed initialisation
    Boot Failure Count: 0   Panic Fail Count: 0
    Delaying boot for 0 seconds. Hit enter to break into the command prompt...
    root filesystem mount failed
    Radio failed to respond.
    Radio failed to respond.
    Pingng Radio Failed
    Entering recovery mode, starting command prompt
    ] (Recovery) iPhone$ printenv
      config_board = 'm68ap'
      loadaddr = '0x9000000'
      boot-command = 'fsboot'
      idle-off = 'true'
      boot-device = 'nand0'
      boot-partition = '0'
      boot-path = '/System/Library/Caches/com.apple.kernelcaches/kernelcache.s5l8900
    x'
      display-color-space = 'RGB888'
      display-timing = 'optC'
    P backlight-level = '30'
    P bootdelay = '0'
    P filesize = '39980355943395328'
    P ierase = '1'
    P auto-boot = 'true'
      image-version = '0x3'
      framebuffer = '0xfd00000'
      secure-boot = '0x1'
      radioerror = '0x200'
      radio-error-string = 'Communication failure'
    (Recovery) iPhone$ fsboot
    root filesystem mount failed

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •