Results 1 to 14 of 14

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iphone 3gs 3.0.1, itunes asking for restore after jailbreak

  1. #1
    Default iphone 3gs 3.0.1, itunes asking for restore after jailbreak
    i just had my 3gs. OTB 3.0.1, jailbroke and unlock it a while ago. now, when i plug it on my pc, itunes keep poping that i should restore. no other tabs or options was open except the summary tab on itunes and the restore button. i tried the shift restore on 3.0.1 but it doesnt seem to work. help please... what should i do?

  2. #2
    Nothing. I think it's telling you that the new OS is out. You say there is nothing other than the Summary tab and the Restore button? The 3GS can not be restored to a previous firmware at this point, so DO NOT restore or update anything if you wish to keep unlockability. If you can grab a screen shot, post that with the error and the window, it will help us help you much better and faster.

  3. #3
    thanks for the quick reply. the problem is, when i plug the iphone (jailbroken/unlocked) in the tunes. it says "itunes cannot read the contents of your iphone. go to the summary tab in the iphone preference and click restore to restore the iphone to factory setting." then when i click "ok" there isnt any other tabs except the summary tab that shows the restore button. there is no other tabs for applictions, info, etc. i dont want to update to 3.1 i need this fone jailbroken and unlocked. any ideas sir?

  4. #4
    Hmmmm. I've never had that one, I do apologise, but I have no idea on that one. LOL Does the phone still work? Maybe you could try to plug back into the program you jailbroke with and rejailbreak? It won't harm it.

  5. #5
    the phone is working fine. wifi, unlocked, cydia and everything else works. will do try to rejailbreak it... i hope it works.

  6. #6
    Well, if the phone works fine, just don't worry about pluggin into iTunes. Or are you trying to do the first sync, to get music and such onto it?

  7. #7
    rejailbroke it. but its the same problem... itunes wont let me put anything on my iphone, wtf. phone works fine, though. is there any other option? or anything i could or should try to do except update? i dont want to loose my jailbreak and unlock... thanks!

  8. #8
    Are you on iTunes 8.2 or 9.0 ?

  9. #9
    Hi, any help on this one would be very appreciated. I'm in EXACTLY the same boat... got my phone online, had it jailbroken and unlocked in America, now using it in Australia. Running 3.0.1 firmware. I received it in the mail yesterday, plugged in my sim and everything works perfectly. went to sync it with my itunes for the first time and i got the same message. "iTunes cannot read the contents of the iPhone. Go to the summary tab in iPhone preferences and click Restore to restore this phone to factory settings."

    I was running on an old itunes yesterday when I first tried it, 8.something. Then i changed cables. didn't work. then i upgraded iTunes to 9.0.1.8 last night. same message.

    Since I didn't personally do the JB and unlock, and since everything is working perfectly right now I'm super scared to do anything b/c I don't want to brick the phone. I DL'd the redsn0w file in case I need it rehack it but I am just paranoid that since I don't have those special files that everyone talked about (some signature files) that I'll struggle with the JB. any help would be soooo appreciated.

    Frustrating, but glad to see I'm not the only one in this boat.

  10. #10
    My advice for both of you is, if you can wait for the official 3.1 jailbreak to come out, do so. If the phone is jailbroken now, go ahead and get into Cydia and allow saurik to save your signatures, then once the jailbreak comes out, find the firmware you need and go from there. If you can't wait, and you are not on official carriers, then you don't really have a choice. I have never experienced this problem, so I really don't know what to say in even troubleshooting this one. It's basically like the phone is in Recovery or DFU mode, but the phones will come on and turn off normally, I have never seen this.

  11. #11
    if you need an unlock in the future, don't be tempted to restore to 3.1! it will break your unlock, probably forever! always remember that!

    as for the problem itself: since the phone seems to work fine, but itunes cannot read the phone correctly, I would think it's a problem with either the usb port or the connection cable.
    if possible, connect with a different cable to a different usb port and see if that helps anything.

    if it doesn't itunes is just weird and I guess you have to wait for the 3.1JB. if it's not that important for your to sync your phone I guess it doesn't really matter anyway, does it?
    don't forget to save your SHSH in cydia!

  12. #12
    Well I definitely know not to update to 3.1... which is why i'm so darn paranoid about doing ANYTHING! i'm in constant fear that i'll screw it up and be forced into a restore. I don't mind waiting for the official jailbreak to come out, but i'm just frustrated that in the meantime i have do deal with lame ringtones that's really all I care about... just downloaded a few from Cydia, so hopefully that will tide me over, but I am concerned that if I decide to sell this thing that someone else is going to have the same problem and i will have sold them a dud. i don't want to screw anyone.

  13. #13
    thanks a lot... will wait for the unlock/jailbreak. i'll just hold still until it comes out. iphone without ipod, i can live with that.

  14. #14
    i think i know where the problem happened... i think i used redsnow 7 instead of 8... i tried rejailbreaking again using redsnow 8... and walla! itunes work perfectly!

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •