Results 1 to 10 of 10

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: White screen when the phone awakes from sleep

  1. #1
    Default White screen when the phone awakes from sleep
    I bought a iphone 2g today from a guy on craigslist and this phone is messed up. Before I gave him the money, I played with it and seen he had jailbroken it and put a bunch of stuff on it. He said he did this himself.

    I played around with it, stuck my sim card in it and everything seemed ok. I noticed that when I put my sim card in it, the phone turned off by itself which surprised me. I made a call on it and received a text immediately and so I gave him my money.

    He drives/rides away and I am still in the parking lot putting my sim back into my own 3g iphone and I discover that the screen of the 2g I just got had a white image with blue lines running vertically. "Hell no", was the first thing to pop up in my mind and I tried to turn it off. Nothing happened. I had to hold the power button and the home button down for 10 sec for it to restart correctly, but whenever the phone goes to sleep it happens again.

    I text the guy and he says it worked great for him, but I replied that I am still in the parking lot and not even 5 minutes past by when this phone messes up. To sum everything up, what can I do to fix it cause I got a feeling it is a program that he stuck on here that is the root cause. Thanks for reading.

  2. #2
    Livin the iPhone Life SundayDuffer's Avatar
    Join Date
    Aug 2007
    Location
    Northern California
    Posts
    1,503
    Thanks
    32
    Thanked 181 Times in 164 Posts

    restore

  3. #3
    Forum Manager Bo Troxell's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    35,196
    Thanks
    5,590
    Thanked 12,540 Times in 7,596 Posts

    ^ plain and simple, yup would def agree.

  4. #4
    well....I tried to restore it. When I restored it I got the message about activating it, which I can't. I was still able to put the phone in sleep mode from the emergency screen via pressing the sleep button and the screen became white again. I then jailbroke the phone again, since I can't do a restore from the activation screen and everything went fine. Yet again, I get the white screen.

    I got hosed on this deal it seems. I don't know what else I can do. Is there any program that is notorious for this problem? Maybe I can install it and uninstall it to see if that is the problem.

  5. #5
    Forum Manager Bo Troxell's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    35,196
    Thanks
    5,590
    Thanked 12,540 Times in 7,596 Posts

    When you at the emergency only screen did you try to jailbreak it from there and hacktivate it?

  6. #6
    Yes, I did. Right now, I looking at cydia and looking for every program the guy installed that I can recall and attempting to installing and uninstalling to fix it.

  7. #7
    Forum Manager Bo Troxell's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    35,196
    Thanks
    5,590
    Thanked 12,540 Times in 7,596 Posts

    Quote Originally Posted by braids View Post
    Yes, I did. Right now, I looking at cydia and looking for every program the guy installed that I can recall and attempting to installing and uninstalling to fix it.
    Confused, thought you said you restored it. if so all cydia app would have been removed. If not, restore and re-jailbreak see if that cures the problem.

  8. #8
    didn't work. I don't know what I can do at this point asides from selling it for a major lost. Thanks for you help.

  9. #9
    Livin the iPhone Life CaptainChaos's Avatar
    Join Date
    Sep 2008
    Location
    In a van down by the river
    Posts
    4,824
    Thanks
    553
    Thanked 515 Times in 427 Posts

    Don't give up so easily What didn't work?

  10. #10
    I did a restore, which took me to the activation portion of the iphone again. Then I restored again via putting the phone in recovery mode. Then again I restored by the same technique and finally I jailbroke it with redsnow 0.8 (I believe) w/unlock and the results are the same.

    Before that, I restore it to the activation screen once and then jailbroke it. I then repeated the cycle without success of fixing it. I set up an appointment at the genius bar for Wednesday, but I don't know how to approach them about the problem.

    I can't (h)activate it in front of them. If they fix it, they will install 3.1 firmware. If they can fix it, I don't even have a clue how much they will charge.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •