Results 1 to 16 of 16

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: correct upgrade-jailbreak procedure for my case

  1. #1
    Default correct upgrade-jailbreak procedure for my case
    Hi, I want to update from 2.2 to 3.1 ASAP, but after reading guides here and there i still havent understood the correct procedure

    i have an iphone 2G, on 2.2 firmware, i have windows so im just going to use a custom jailbroken firmware

    there are guides that say that if im on older firmware, i should do a CLEAN RESTORE, then jailbreak, there are guides that say that i just have to shift click restore and select the custom firmware, there others that say that i have to be in recovery mode/DFU mode (I dont know the difference between the 2, its confusing, can anyone clear that up?) and then shift click restore

    i dont know what to do

    thanks in advance

  2. #2
    Forum Manager Bo Troxell's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    35,196
    Thanks
    5,590
    Thanked 12,540 Times in 7,596 Posts

    Recovery mode - A special mode in the device allowing firmware restoration; in this mode, the screen of the device shows a graphic
    DFU mode - A special mode in the device that bypasses the loading of the operating system for recovery purposes; in this mode, the screen of the device is blank
    Yes, do a fresh restore, do not use a back-up as it will cause major problems.
    Upgrade = click upgrade in iTunes
    Clean restore = Click restore in iTunes and not restore from backup
    Upgrading a major version needs a clean restore. Upgrading a minor version should be OK with an upgrade.
    Same goes for backups - do not restore from a backup made in a FW with a major change but minor changes are fine.
    A number change is major and a decimal change (e.g. 3.0 -> 3.1) is minor.

  3. #3
    just be sure, the correct procedure then is:

    clean restore to 3.1, then shift click restore to custom ipsw while the device is on and in normal mode, right?

    ok great i got error 1604 after like 10 minutes in "Preparing iPhone for restoring..." and now im stuck in restore mode...

    help please
    Last edited by sniperbr0; 2009-09-20 at 03:20 AM. Reason: Automerged Doublepost

  4. #4
    Forum Manager Bo Troxell's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    35,196
    Thanks
    5,590
    Thanked 12,540 Times in 7,596 Posts

    Run redsn0w again, if it gets stuck again unplug the USB cord for 3 seconds and plug it back in. Are you using the 3.0 .ipsw file? You have to.

  5. #5
    no, i restored a fresh, unjailbroken, locked 3.1 direct from itunes, and then attempted to shift+restore a custom firmware, thats all

    isnt redsn0w incompatible for 3.1?

  6. #6
    Forum Manager Bo Troxell's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    35,196
    Thanks
    5,590
    Thanked 12,540 Times in 7,596 Posts

    ^ your correct sorry misread your post. Go here for info.

  7. #7
    thanks, i followed all the steps until step12, restored to fresh 3.0, then attempted to jailbreak it using redsn0w and now im stuck at "uploading ramdisk" part and i see "downloading Jailbreak Data..." on the iphone for about an hour already... i dont think this is normal

    if i reset the phone or something like that interrupting this procedure, will anything bad happen?

    im starting to pull my hair out already

  8. #8
    Forum Manager Bo Troxell's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    35,196
    Thanks
    5,590
    Thanked 12,540 Times in 7,596 Posts

    If your on 3.0 and running redsn0w, when it gets stuck unplug the USB for 3 secs and then plug it right back in.
    Thought you were on 3.1, did you downgrade?

  9. #9
    yes, i was on fresh 3.1 and then restored to fresh 3.1

    unplugging the usb for 3 secs and plugging it back didnt work, still stuck...

  10. #10
    Forum Manager Bo Troxell's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    35,196
    Thanks
    5,590
    Thanked 12,540 Times in 7,596 Posts

    Quote Originally Posted by sniperbr0 View Post
    no, i restored a fresh, unjailbroken, locked 3.1 direct from itunes,
    Quote Originally Posted by sniperbr0 View Post
    thanks, i followed all the steps until step12, restored to fresh 3.0,
    I'm confused, what firmware are you using?

  11. #11
    right now im on fresh 3.0, attempting to jailbreak it, before you posted that link i was on fresh 3.1, so following the guide i had to go restore 3.0 and jailbreak it, which im at right now

  12. #12
    Forum Manager Bo Troxell's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    35,196
    Thanks
    5,590
    Thanked 12,540 Times in 7,596 Posts

    are you using redsn0w or pwnage?

  13. #13

  14. #14
    Forum Manager Bo Troxell's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    35,196
    Thanks
    5,590
    Thanked 12,540 Times in 7,596 Posts

    you should be using redsn0w 0.8 and the 2 bootloaders if your unlocking also.

  15. #15
    i am

    i decided to restart all the jailbreak process, restored again to fresh 3.0, and started redsnow again, im past the upload ramdisk part, and now its processing stuff in the iphone

  16. #16
    Forum Manager Bo Troxell's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    35,196
    Thanks
    5,590
    Thanked 12,540 Times in 7,596 Posts

    Cool, you should be good to go then.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •