Results 1 to 6 of 6

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: deleted etc/master.passwd -stuck in boot loop now

  1. #1
    Default deleted etc/master.passwd -stuck in boot loop now
    in a wonderfully stupid decision, i decided to follow some instructions to reset my root and mobile passwords by editing master.passwd in the Terminal app ..in the process of copying my edited backup file over the original, i deleted the original (deleted master.passwd and was going to rename master.passwd.bak to it) and i was IMMEDIATELY booted from the application (ifile i think) to springboard. from there, no apps launched (kicked right back to springboard) terminal was still backgrounded so i tried some command line renaming, but i kept getting access denied.

    facing the inevitable after i had tried everything, i locked the phone like normal and it didnt come back on. hard powered down. stuck in boot loop now

    tried rock my phone or some ****, tried re-jailbreaking with purplerain and redsnow (i'm on a 3gs w/ 3.0). the jailbreaks went through the normal processes but after the reboot still nothing.

    did not have my ecid shsh blobs cached with saurik so his instructions didnt work for me.

    this was last thursday, the day after apple stopped signing 3.0 firmwares so if i restore, it'll have to be to legit 3.1 which is something i dont want to do because i dont want to lose the ability to unlock. been using a backup phone since then

    so.. any help is appreciated if there are any suggestions besides waiting for a 3.1 3gs jailbreak.

    thanks

  2. #2
    there is nothing you can do besites wait. but seriously, deleting master.passwd ... what were you thinking? anyway, you're stuck for now

  3. #3
    Quote Originally Posted by BlackWolf View Post
    there is nothing you can do besites wait. but seriously, deleting master.passwd ... what were you thinking? anyway, you're stuck for now
    instructions said make a copy of /etc/master.passwd to /var/mobile/master.passwd, and copy it to /var/mobile/master.passwd.bak

    then i edited the /var/mobile/master.passwd.bak per the instructions when perhaps i should have been editing /var/mobile/master.passwd

    so when it came time to overwrite /etc with the /var/mobile i just copied the .bak file to /etc and figured i'd del the /etc/master.passwd and immediately rename the master.passwd.bak to master.passwd

    but literally the second i deleted master.passwd it kicked me out of the app. WHY would it do that? makes no sense why the app would crash immediately when deleting a password file. if i would have known that obviously i would have overwritten the file, not deleted and renamed.


    so anyone else have any ideas besides to wait?

  4. #4

  5. #5
    Default Anyone
    Did anyone ever figure out how to fix this without restore ? I just really messed up my iphone trying to change the ssh password that i forgot. I deleted the master.passwd file, but i have a backup of it.
    iPhone Owner.

  6. #6
    Default Hi
    MegaGoo, did you find the solution?.. cuz i'v fall to the same situation :P now stuck..

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •