Page 1 of 2 12 LastLast
Results 1 to 20 of 21

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Can't get 3.1 custom ipsw to install - err: 2005 / 1600

  1. #1
    Angry Can't get 3.1 custom ipsw to install - err: 2005 / 1600
    Hi all
    I've been trying tens of time with different setup and can't get to install a custom ipsw for 3.1
    Here's the siterep:

    iPhone 3g, was jailbroken to 3.0.1, running a MacPro with iTunes 9 in Leopard
    Apple usb cable, tried different usb ports, hub no-hub and what not. Tried on an iMac with Snow leopard and itunes 9 too, still no go.

    Was always trying in DFU mode, definitively not recovery. The error I had most of the time at this point was 1600. Had 1604 once or twice.

    I then restored to official 3.0, tried all those things again, error is now mainly 2005.
    I built multiple ipsw with pwnagetool 3.1 myself, tried downloaded versions too, same results.

    I downgraded itunes 9 to itunes 8, same results...

    In short, I can't find any way to have it installed. I did have those kind of issues with other ipsw jailbreaks, but never one that I couldn't manage to solve. Now I must say I really don't know what to do.. so...

    help? please? :P

    Thanks all

    O.

  2. #2
    i have exactly the same problem it gets stuck on the preparing the iphone for restore and then it gives me error after a while.

  3. #3
    Update: Tried with 2 more mac pro (same config as me, itunes 9), the error is back to 1600 ... :/

    WTF?

    Anybody has some insight to this? Getting desperate

    O.

    Edit: Ok that's weird -> Just put itunes 9 back on my computer - error is now 2005. However, on my colleagues mac (same config) that have itunes 9, the error was 1600... Anybody knows what those codes means exactly? Have looked around and didn't find anything, yet
    Last edited by MultipleParadox; 2009-09-16 at 09:06 PM.

  4. #4
    i get the 1604 error while restoring with custom firmware nobody helping.
    btw sorry for hijacking your thread

    look man i saw this post
    For anyone getting the 16xx errors, here's what you do:

    Things you need:
    Pwned 3.1 ipsw
    xPwn (any version)
    CMD (Windows) or Terminal (Mac and Linux)

    1. Open CMD/Terminal and cd to your xPwn directory

    2. Type dfu-util

    3. Drag your custom ipsw to your xPwn folder

    4. Now type "dfu-util (iPhone/iPod version) (name of custom ipsw file).ipsw" without the quotes. Do NOT press enter!!

    5. Plug in your iPhone/iPod and put it into DFU mode

    6. Press enter and open iTunes

    7. Restore to your custom ipsw



    BUT I STILL DONT UNDERSTAND HOW TO DO IT ALL.. PLEASE IF YOU ARE ABLE TO SUCCESSFULLY RESTORE YOURS USING THISM ETHOD PLEASE EXPLAIN TO ME .. thanks
    Last edited by Trayanscragg; 2009-09-16 at 09:54 PM. Reason: Automerged Doublepost

  5. #5
    I've looked into xpwn a bit
    no dfu-util binaries to be found
    I did find the xpwn src on planetbeing's github space, whith dfu-util, but couldn't compile it (I'm no pro at this, did look like a C project and tried gcc on main.c and it throwed a bunch of errors)

    xpwn itself doesn't seem to be the solution :/

    Still stuck at the same point


  6. #6
    i did it i did ittt
    currently restoring with the custom firmwaree

  7. #7
    Retired Moderator Poseidon79's Avatar
    Join Date
    Jan 2008
    Location
    Austin, TX
    Posts
    8,264
    Thanks
    819
    Thanked 1,681 Times in 1,159 Posts

    ^^^ Worthless ^^^^

    Generally each and every time I restore to a custom firmware on my Mac I have to go into /your user name/library/iTunes/devicesupport and delete the file in here first. After that I have to build a NEW ipsw EVERY time I restore. Always works. If y'all are getting this error on windows I can't help ya.

  8. #8
    Poseidon79 - Yeah I just did that, deleted its content and created a new ipsw
    Seems to have gone better than last times (sreen in iphone went white) but still got the 2005 error, and was stucked to white. Unplugging/replugging have had the iphone reboot and stuck at the apple :/

    Trayanscragg: Care to share what you did? I find it a bit ordinary you request help and that we share our experience to help you out but that you don't do the same once you've found a solution :/

    Thanks

  9. #9
    ok so what i did first was pasted the whole XPwn-0.5.7-win32 folder on my desktop.
    then i launched CMD prompt
    and typed in the directory of the location of the folder on the desktop.
    so in this case it would be: cd CUsers\Trayan\Desktop\XPwn-0.5.7-win32
    it will automatically take you into this folder
    then you type: idevice <nameofthecustomfirmware.ipsw> <n82ap> without the arrows and make sure you have the custom firmware in the folder then makesure your device is in DFU mode and itunes and ituneshelper are not running in the task manager
    press enter
    then follow the instructions idevice should crash and the screen should turn white

    then fire up itunes and restore with the custrom firmware

  10. #10
    Thanks Trayan,
    I've JUST managed to have the restore working (it is in the process right now).
    However I didn't use xpwn at all ... I did a complete legit restore to 3.1 on another freshly installed mac having itunes 8, then recreated a new ipsw ON that mac and restored in DFU to taht custom ipsw...

    pretty complicated but it works

    However it's good to know xpwn is good for something (seems to be on windows only though, since I couldn't find anything useful for mac). I'm sure it might comes in handy for other users

    O.

  11. #11
    What's Jailbreak?
    Join Date
    Nov 2007
    Location
    Richmond, Darlington, United Kingdom, United Kingdom
    Posts
    9
    Thanks
    1
    Thanked 0 Times in 0 Posts

    I'm too, getting the error 1600,

    I've got a PPC G5 Dual Core 2Ghz, with 16GB RAM, running the latest version of leopard, and iTunes 9.

    I've JB my iPhone (3G 16GB, o2-UK), loads of times before so I thought I knew what I was doing.

    What is the problem causing this error, mean while it seems I'll have to use my iPhone for the second time in it's life not jail broken, lol until I get it sorted.

    Thanks in advance

    Arbroathsmokie

  12. #12
    iPhone? More like MyPhone
    Join Date
    Oct 2007
    Location
    Western NY
    Posts
    189
    Thanks
    8
    Thanked 8 Times in 8 Posts

    Quote Originally Posted by arbroathsmokie View Post
    I'm too, getting the error 1600,

    I've got a PPC G5 Dual Core 2Ghz, with 16GB RAM, running the latest version of leopard, and iTunes 9.

    I've JB my iPhone (3G 16GB, o2-UK), loads of times before so I thought I knew what I was doing.

    What is the problem causing this error, mean while it seems I'll have to use my iPhone for the second time in it's life not jail broken, lol until I get it sorted.

    Thanks in advance

    Arbroathsmokie
    I had the same problem as well. Here is how I got it to work.

    I am on ATT and restored to 3.1 non jailbroken first. Then I ran ran pwnage tool. I had to enter DFU mode through the steps in pwnage tool. I got an iTunes error first. Clicked OK and then closed iTunes. After that I opened iTunes and clicked option + restore, selected the custom firware and was done. It took a while but it worked.

  13. #13
    scratch what i said...
    Last edited by aceslick911; 2009-09-17 at 03:36 PM.

  14. #14
    Arbroathsmokie, just follow mobopete, it's what worked for me.
    Make sure to have your iphone plugged directly in your mac, not in any kind of hub (like the keyboard's usb plugs and the like)

    BEFORE creating the custom ipsw, delete anything that you can find in ~/Library/iTunes/Device Support

    Good luck

    o.

  15. #15
    What's Jailbreak?
    Join Date
    Nov 2007
    Location
    Richmond, Darlington, United Kingdom, United Kingdom
    Posts
    9
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Well true to form, I tried again today, and I did nothing different, and right off the bat, it worked first time round. Thanks for all of the responses.

    Arbroathsmokie

  16. #16
    i have done mobopete's method and i still cant get the restore to work. i got the white screen on my iphone and an error 2005. i deleted whatever was in the device support folder when i made my custom ipsw but still the same results. im completely stumped.

    i had a jailbroken ver. 3.0 which i updated through itunes 9 to 3.1 on a macbook pro running leopard.

  17. #17
    dont use the dfu technique but instead:
    1) close iTunes,
    2) turn off iPhone,
    3) re-open iTunes(9.0),
    4) hold home button on iPhone while connecting USB,
    5) when connect to iTunes shows up do shift(windows) restore and wa-la!

  18. The Following User Says Thank You to coupdvilln For This Useful Post:

    ggamp01 (2009-10-07)

  19. #18
    anyone discover anything significant? did coupdvilln's idea work?

    EDIT: his method DID work but, I goofed up and selected "activate" in pwnage when I have AT&T. I now have no service. Redoing it now....
    Also side note, I deleted everything in the device support folder before I started.
    Last edited by t.storbeck; 2009-09-29 at 02:26 AM.

  20. #19
    Quote Originally Posted by coupdvilln View Post
    dont use the dfu technique but instead:
    1) close iTunes,
    2) turn off iPhone,
    3) re-open iTunes(9.0),
    4) hold home button on iPhone while connecting USB,
    5) when connect to iTunes shows up do shift(windows) restore and wa-la!
    you are the MAN! that worked perfectly. I was freaking out a bit there till I got to your directions.

  21. #20
    iPhone? More like MyPhone duceduc's Avatar
    Join Date
    Sep 2007
    Location
    Saitama, Japan
    Posts
    249
    Thanks
    2
    Thanked 10 Times in 9 Posts

    Quote Originally Posted by coupdvilln View Post
    dont use the dfu technique but instead:
    1) close iTunes,
    2) turn off iPhone,
    3) re-open iTunes(9.0),
    4) hold home button on iPhone while connecting USB,
    5) when connect to iTunes shows up do shift(windows) restore and wa-la!
    Is this the recovery method? I have to restore my 1G phone couple of times because the activemms2G is messing up the phone on reboot. It seems enabling mms on a 2G iphone with 3.1.2 firmware doesn't work.

    I had to put the phone in recovery mode since dfu mode didn't work. I get 1600 error message.

Page 1 of 2 12 LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •