Results 1 to 14 of 14

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: 2G iPhone won't downgrade 3.1

  1. #1
    Default 2G iPhone won't downgrade 3.1
    i have a slight problem...
    my 2G decided to mess up today while i was using iphone explorer. i thus restored, and only found out later that it had updated to 3.1 as well.
    having lost the unlock/jailbreak and researched online, i've been trying for the past few hours to rollback my firmware. i'm on Vista, and the main problem is that holding [shift]+restore in itunes doesn't give me the option of choosing which firmware to use in the restore; i've tried in 9.0, 8.0, 8.2, and 8.2.1. any help would be greatly appreciated.
    Last edited by and.this.too.shall.pass; 2009-09-15 at 04:15 AM.

  2. #2
    iPhoneaholic sursture's Avatar
    Join Date
    May 2008
    Location
    US - the land of the fat
    Posts
    366
    Thanks
    4
    Thanked 98 Times in 88 Posts

    0 - DO NOT USE iTunes 9 !!!
    1 - U need to HOLD shift then (while holding shift) click restore.
    2 - Read this http://modmyi.com/forums/unlocking-a...ml#post4950610
    Do hope that helps



    _________________________________________________

    **uoʇʇnq „sʞuɐɥʇ„ ǝɥʇ ʇıɥ puɐ puıʞ ǝq noʎ pǝdןǝɥ sɐɥ ǝuoǝɯos ɟı**
    _________________________________________________




  3. #3
    thanks for your reply, but that's what i've been doing. i'll edit my original post to reflect that.
    sorry for being unclear.

  4. #4
    iPhoneaholic sursture's Avatar
    Join Date
    May 2008
    Location
    US - the land of the fat
    Posts
    366
    Thanks
    4
    Thanked 98 Times in 88 Posts

    Hmmm... r u on a PC?

    If so Download "Revo Uninstaller" http://www.revouninstaller.com/download/revosetup.exe

    Run it in AGRESSIVE MODE - this will clean the PC from whatever bug there is - reboot - reinstall iTunes - Redo restore

  5. The Following User Says Thank You to sursture For This Useful Post:

    and.this.too.shall.pass (2009-09-15)

  6. #5
    Community Manager Bo Troxell's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    35,196
    Thanks
    5,590
    Thanked 12,540 Times in 7,596 Posts

    What is the full name of the firmware file you are trying to restore to please, maybe I can help?

  7. #6
    @sursture
    i'm on a PC. i downloaded and installed Revo, but can't find aggressive mode?...

    @blkcadi
    the ipsw is "iPhone1,1_3.0.1_7A400_Restore"
    it was first unlocked with "iPhone1,1_3.0_7A341_Restore"
    i'd be happy to get any version on though...it hasn't let me choose which firmware to install.

  8. #7
    Custom Title angiepangie's Avatar
    Join Date
    Jun 2009
    Location
    The Golden State :)
    Posts
    3,844
    Thanks
    22
    Thanked 222 Times in 211 Posts

    Are you doing all this in DFU mode?
    Try putting the phone in DFU mode before restoring.
    I always feel sorry for the guy in the iPhone commercials. He always gets a call right in the middle of trying to do something

  9. The Following User Says Thank You to angiepangie For This Useful Post:

    and.this.too.shall.pass (2009-09-15)

  10. #8
    iPhoneaholic sursture's Avatar
    Join Date
    May 2008
    Location
    US - the land of the fat
    Posts
    366
    Thanks
    4
    Thanked 98 Times in 88 Posts

    AGRESSIVE MODE:

    Once you start uninstall - you will get the option (default is moderate mode)
    Last edited by sursture; 2009-09-15 at 04:53 AM.

  11. The Following User Says Thank You to sursture For This Useful Post:

    and.this.too.shall.pass (2009-09-15)

  12. #9
    Community Manager Bo Troxell's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    35,196
    Thanks
    5,590
    Thanked 12,540 Times in 7,596 Posts

    Quote Originally Posted by and.this.too.shall.pass View Post
    @sursture
    i'm on a PC. i downloaded and installed Revo, but can't find aggressive mode?...

    @blkcadi
    the ipsw is "iPhone1,1_3.0.1_7A400_Restore"
    it was first unlocked with "iPhone1,1_3.0_7A341_Restore"
    i'd be happy to get any version on though...it hasn't let me choose which firmware to install.
    It's not showing the .ipsw extension?
    you may have to do the following.
    XP or Vista. you need to open "My Computer"
    XP - go to the top menu and select options > Folder Options
    Vista - Top left button that says Organize > Folder and Search Options
    In that window you need to click the " VIEW " tab on top.
    NEED TO SELECT “SHOW HIDDEN FILES AND FOLDERS "
    Then unclick the option to " hide protected operating system files "
    Once that's done click "apply" then ok and exit out of the window.

  13. The Following User Says Thank You to Bo Troxell For This Useful Post:

    and.this.too.shall.pass (2009-09-15)

  14. #10
    @angiepangie
    it is in DFU mode. otherwise it doesn't give the option to restore.

    @sursture
    the option is called "advanced" in the version i downloaded...weird.
    anyways, the problem remains after the uninstall-reboot-reinstall.

    @blkcadi
    it does have the extension, i just left it off in my post. my bad!

    thank you all for your help so far...

  15. #11
    iPhoneaholic sursture's Avatar
    Join Date
    May 2008
    Location
    US - the land of the fat
    Posts
    366
    Thanks
    4
    Thanked 98 Times in 88 Posts

    I would try an other PC or MAC

    Have done 3.1 =>3.0 downgrades on 2G & 3G and not seen the symptoms u r describing.

  16. The Following User Says Thank You to sursture For This Useful Post:

    and.this.too.shall.pass (2009-09-15)

  17. #12
    i'll see if i can use a friend's in the morning.
    thank you all for your help...

  18. #13
    Community Manager Bo Troxell's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    35,196
    Thanks
    5,590
    Thanked 12,540 Times in 7,596 Posts

    hope it works out for you, good luck

  19. The Following User Says Thank You to Bo Troxell For This Useful Post:

    and.this.too.shall.pass (2009-09-15)

  20. #14
    alright, got it to work! kinda weird way too. turns out i just needed to run itunes as an admin for it to work...
    thank you all for your help!

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •