Results 1 to 5 of 5

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.

Thread: iPhone MMS AT&T FAQ..

  1. #1
    Default iPhone MMS AT&T FAQ..

    So after a friend of mine ended up getting MMS setup on his device I decided to give it a try as well.

    After updating the carrier through iTunes 8.2, I kept getting the red exclamation when trying to send any MMS.

    I have narrowed down to where actually the problem is and have solved in 3 different phones to get MMS working.

    If you updated your carrier and cannot MMS yet, you need to change your Txting plan from the "iPhone Text Messaging 200" or "1500" or "Unlimited" to the one that says just "Text Messaging 200" or "1500" or "Unlimited" which is the same price, just a switch on their end.

    The carrier file I'm using is the AT&T 5.1, didn't change any setting on whatever it set to, just rebooted it after sending to the phone. (If you don't know how to do that, there's plenty of info on the forums on how to send that file..).

    Anyways, you do need another AT&T phone that isn't an iPhone, could be anybody elses.

    Once you send the file, put your iPhone SIM into that phone. The one I used was a Motorola Crimson Z9.

    Turn on the phone, hold #1 to call your voicemail, and make a couple of phone calls to anywhere, like 5-6 calls.

    After that login to your AT&T account on AT&T Website (Cell Phones and cell phone plans - | Wireless from AT&T, formerly Cingular) and choose your line from the list (I have a Family Plan so I had to choose my line). You should see the new phone you put the SIM card as the new phone logo on your line. If not, make couple of more calls, LOG OUT of the site, then log back in. When you see the non-iPhone picture, click on "Manage Your Features"

    You will see your iPhone Text Messaging plan selected and your choices for Text Messaging now don't have the "iPhone" next to them. Choose the same plan rate to keep your bill the same, save changes, submit and all.

    You don't even have to reboot your phone.. Try re-sending the Text and it should work. Takes about 20-30 secs to actually go through depending on the size, specially if it's a video. If it doesn't work, I guess you can try rebooting. Carrier settings under "Cellular Data Network" for reference is:

    APN: wap.cingular
    Username: [email protected]
    Password: CINGULAR1
    MMX Proxy:
    MMX Max Message Size: 614400
    MMS UA Prof URL:

    Trust me, that's all there is to it.. I'm in Los Angeles just in case someone follow this exactly and it doesn't work, maybe different cities.. but I doubt there's anything to do with that as long as your plan is right on your account.

    Good luck!

  2. #2
    is that just for the 3gs or will it work for the 2g also? what happens when you put the sim back into your iphone and make a few calls, when you check on att site doesn't it show the iphone again?

  3. #3
    iPhone 2G won't have MMS.. Only 3G and 3GS..

    When you put the SIM back in the iPhone and make a few calls it will revert back to the iPhone.. if it doesn't just do it manually.. No biggie because all you needed to do anyway was to switch the Txt plan..

  4. #4
    iPhone? More like MyPhone Niner1000RR's Avatar
    Join Date
    Jul 2008
    Boca Raton, Florida
    Thanked 28 Times in 27 Posts

    I didn't do any of the above and mine works PERFECT!

    I have a bussiness plan, updated carrier to 5.0 on my 3G[s] and have:
    APN: wap.cingular
    MMS Proxy: wireless.cingluar:80
    MMS Max Message Size: 614400
    MMS UA Prof URL:

    And all was done automatically after I manually installed the ATT bundle from Stealth (via SSH)

  5. #5
    If you have any sort of plan where the Text Messaging plan is Family for all lines (which would unlock MMS since other phones wouldn't all be iPhones, it still needs to work..) or anything else that doesn't say "iPhone Text Messaging" it will work without that procedure..

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts