Page 1 of 3 123 LastLast
Results 1 to 20 of 55

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Apple Blocking Restore of 3.0/3.0.1 Firmware

  1. #1
    Default Apple Blocking Restore of 3.0/3.0.1 Firmware
    Wondering if anyone else has seen this issue.

    I tried to restore my 3GS to 3.0.1, which it's currently running, and received the following message from iTunes, which I assume is a result of connecting to the Apple servers:

    "...could not be restored. This device is not eligible for the requested build."

    The only Google result included a comment saying that Apple is essentially forcing any phone that is to be restored onto 3.1.1. This is NOT good news for a) corporate users who aren't allowed to upgrade at will, or b) jailbreakers who just want to get a fresh start (guess which I am....both!)

    Anyone else experience this and/or find a way around it....

    Marc

  2. #2
    So you can't use a firmware that is already downloaded on your pc. Restoring by holding CTRL then restore and point to that firmware?

  3. #3
    Yes, that is correct, or "Option" on a Mac.

  4. #4
    Thats Rubbish I knew i should jailbreaked it last weekend.
    So i'll just have to hope they create a fix

  5. #5
    Livin the iPhone Life CaptainChaos's Avatar
    Join Date
    Sep 2008
    Location
    In a van down by the river
    Posts
    4,824
    Thanks
    553
    Thanked 515 Times in 427 Posts

    Is this on iTunes 8.2 or the new 9.0?

  6. #6
    Retired Moderator Poseidon79's Avatar
    Join Date
    Jan 2008
    Location
    Austin, TX
    Posts
    8,264
    Thanks
    819
    Thanked 1,681 Times in 1,159 Posts

    Apple has stopped signing 3.0 and 3.0.1 firmwares on for the iPhone 3GS which means you will be forced to restore to 3.1 at this point NO MATTER WHAT.

  7. #7
    Livin the iPhone Life CaptainChaos's Avatar
    Join Date
    Sep 2008
    Location
    In a van down by the river
    Posts
    4,824
    Thanks
    553
    Thanked 515 Times in 427 Posts

    So I cannot jailbreak a 3G now?

  8. #8
    My iPhone is a Part of Me PhoneLine's Avatar
    Join Date
    Aug 2007
    Location
    New York City
    Posts
    508
    Thanks
    65
    Thanked 155 Times in 54 Posts

    Well that stinks. Hopefully a new jailbreak comes along before any corrupt installs cause people to need to restore. This is not a good thing at all

    Wasn't this the reason we were all backing up the IBEC and IBSS files? Perhaps those will come to be useful soon? Would pwnage ipsw's need this signature also?

    Also, what happens if you try and do the restore on a machine with no internet access if you have the ipsw file locally? I'm guessing it will just tell you a connection is needed?

    This really does not seem good though. I don't think I'm installing anything else on my phone for a while. I've had things that I didn't expect would cause issues and ended up with me needing to restore.

    And if your unlocked and need to restore? Oy!

    Quote Originally Posted by CaptainChaos View Post
    So I cannot jailbreak a 3G now?
    This is only the 3G-S. Basicly it means that if you need to resore you are forced to install the newest firmware version. Older versions won't install even if you have the file on your hard drive.

    So, lets say your unlocked on tmobile on 3.0 or 3.0.1 on a 3G-S phone. You install an app and it hoses your phone and you need to restore. Your forced to install 3.1, which then updates the baseband and kills your unlock.
    Last edited by PhoneLine; 2009-09-10 at 05:11 PM. Reason: Automerged Doublepost

  9. #9
    Quote Originally Posted by PhoneLine View Post

    So, lets say your unlocked on tmobile on 3.0 or 3.0.1 on a 3G-S phone. You install an app and it hoses your phone and you need to restore. Your forced to install 3.1, which then updates the baseband and kills your unlock.
    some people managed to restore to 3.0 by using itunes 8.2.

  10. #10
    iPhone? More like MyPhone mattoligy's Avatar
    Join Date
    Aug 2009
    Location
    London
    Posts
    120
    Thanks
    4
    Thanked 11 Times in 9 Posts

    Quote Originally Posted by PhoneLine View Post

    Also, what happens if you try and do the restore on a machine with no internet access if you have the ipsw file locally? I'm guessing it will just tell you a connection is needed?
    It just chucks an error at you! I am so angry about this, I wonder why apple decided to take this route, like we don't already know lol... Under handed mate, thanks apple!!

    I tried so many things erlia to restore my current fw (3.0.1) and couldn't do it luckily it's not urgent for me ATM phones fine I just wanted to restore to gain some speed cut down on the cydia apps lol but what if it was urgent what if I was unable to boot!

    I hope the dev team crack 3.1 very soon and then all apple will have achieved is keeping people from jailbreaking for a few days!

    Hopefully lol

    Matt
    Last edited by mattoligy; 2009-09-10 at 08:31 PM.

  11. #11
    Quote Originally Posted by Romeo26222 View Post
    some people managed to restore to 3.0 by using itunes 8.2.
    could you link to this procedure? I'm on 8.2 and 3GS, not possible to downgrade. It requires a internet connection and contact with apple.com

  12. #12
    Quote Originally Posted by xtrem123 View Post
    could you link to this procedure? I'm on 8.2 and 3GS, not possible to downgrade. It requires a internet connection and contact with apple.com
    check this video
    YouTube - koi2281's Channel

  13. The Following User Says Thank You to Romeo26222 For This Useful Post:

    reemix78 (2009-09-16)

  14. #13
    can't find any confirmation that it works on a 3GS

  15. #14
    I think the only working solution now is "BE PATIENT"

  16. #15
    Retired Moderator StealthBravo's Avatar
    Join Date
    Jan 2008
    Location
    TX  Follow me @StealthBravo
    Posts
    32,474
    Thanks
    44
    Thanked 5,329 Times in 3,113 Posts

    yea, there is no public option yet for downgrading

  17. The Following User Says Thank You to StealthBravo For This Useful Post:

    reaves205 (2009-09-11)

  18. #16
    Retired Moderator z3r01's Avatar
    Join Date
    Jul 2007
    Location
    Brooklyn
    Posts
    5,697
    Thanks
    83
    Thanked 886 Times in 557 Posts

    so if i wanted to get my IBEC and IBSS i cant now?

  19. #17
    ^i think you can but you'll need to update to 3.1 and use the grabber programs to capture your files..

  20. #18
    Retired Moderator z3r01's Avatar
    Join Date
    Jul 2007
    Location
    Brooklyn
    Posts
    5,697
    Thanks
    83
    Thanked 886 Times in 557 Posts

    well, thats a no go definite lol not, i dont care for ultrasn0w , but i do care about jailbreaking

  21. #19
    I'm grabbing a 3Gs tomorrow...do you think the ones in stores would already be updated to 3.1? I don't care about unlocking since I'm a legit ATT customer (sadly), but I don't think I can live without my Winterboard and other goodies. I'm probably just worrying for no reason

  22. #20
    I just got mine yesterday. Ordered it online though. It came with 3.01

Page 1 of 3 123 LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •