Results 1 to 3 of 3

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: 3gs unlock - quick how to

  1. #1
    Default 3gs unlock - quick how to
    hi there,
    so I will be getting my iPhone 3GS in a few days. I currently have an iPhone 2G, so I am absolutly no noob when it comes to the whole unlock/jailbreak stuff, but I just wanted to make sure some things when it comes to the 3GS.

    Is it correct, that: I just need to have 3.0 running and then use redsn0w on my iPhone 3GS. After that, I install ultrasn0w from cydia - and I'm done?

    I'm asking this because I'm a little confused because I read numerous times that you should get "your personalized (signed) dfu/img3 files" on 3.0. Will I need those?

    As far as I know, PwnageTool does not work with the 3GS, right? So what happens if 3.1 comes out? Can I just use a new version of redsn0w? Or will I have to upgrade through iTunes first and THEN use redsn0w?

    Long story short, my two questions are: Can I just use redsn0w and ultrasn0w on 3.0? And do I still need my personalized dfu/img3 files for future firmware releases or is that info outdated by now?

    Thanks!
    Last edited by BlackWolf; 2009-07-20 at 12:37 AM.

  2. #2
    Quote Originally Posted by BlackWolf View Post
    hi there,
    so I will be getting my iPhone 3GS in a few days. I currently have an iPhone 2G, so I am absolutly no noob when it comes to the whole unlock/jailbreak stuff, but I just wanted to make sure some things when it comes to the 3GS.

    Is it correct, that: I just need to have 3.0 running and then use redsn0w on my iPhone 3GS. After that, I install ultrasn0w from cydia - and I'm done?

    I'm asking this because I'm a little confused because I read numerous times that you should get "your personalized (signed) dfu/img3 files" on 3.0. Will I need those?

    As far as I know, PwnageTool does not work with the 3GS, right? So what happens if 3.1 comes out? Can I just use a new version of redsn0w? Or will I have to upgrade through iTunes first and THEN use redsn0w?

    Long story short, my two questions are: Can I just use redsn0w and ultrasn0w on 3.0? And do I still need my personalized dfu/img3 files for future firmware releases or is that info outdated by now?

    Thanks!
    I jailbroke & unlocked the 2G, 3G & 3GS using this method.
    The 3GS comes with 3.0 but you still need the 3GS (Not 3G) 3.0 firmware in order to jailbreak the device. Each device (2G, 3G & 3GS) is got their own 3.0 firmware. You can download them from this site (Download section).

    You just use ultrasn0w 0.8 to jailbreak and then from cydia add the ultrasn0w source & install ultrasn0w for the unlock.

    For a visual step-by-step guide, you can try this site. This link is for the 3GS, but you can find the procedure (Which is almost the same) for both 2G & 3G as well.

    Hope that helps & good luck

  3. #3
    Quote Originally Posted by OutCell View Post
    I jailbroke & unlocked the 2G, 3G & 3GS using this method.
    The 3GS comes with 3.0 but you still need the 3GS (Not 3G) 3.0 firmware in order to jailbreak the device. Each device (2G, 3G & 3GS) is got their own 3.0 firmware. You can download them from this site (Download section).

    You just use ultrasn0w 0.8 to jailbreak and then from cydia add the ultrasn0w source & install ultrasn0w for the unlock.

    For a visual step-by-step guide, you can try this site. This link is for the 3GS, but you can find the procedure (Which is almost the same) for both 2G & 3G as well.

    Hope that helps & good luck
    thanks!
    well, like I said, I've been owning an iphone for almost 2 years now, so I won't need the visual tutorial ... the whole redsn0w and ultrasn0w thing is pretty straightforward.

    but I would still like to know if I need to obtain my personalized (signed) dfu/img3 files for the 3GS in order for me to jailbreak future releases. But I guess I will just grab them to be on the safe side ... .

    oh and I have thought of another question regarding this:

    since the 3GS is jailbroken through redsn0w, what happens if 3.1 is out? because in order to use redsn0w, I first have to install 3.1 on my device, havn't I? but that would update my baseband, so that's not really a good idea. as far as I know pwnageTool can't make 3GS firmwares. so ... how does that work?
    Last edited by BlackWolf; 2009-07-20 at 03:55 PM. Reason: Automerged Doublepost

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •