Results 1 to 3 of 3

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: sshd broken on a 3.0 jailbreak

  1. #1
    Default sshd broken on a 3.0 jailbreak
    After jailbreaking my 2g iphone with 3.0, I installed OpenSSH using Icy.

    I can make the initial connection and authenticate, but I get the following error immediately after authentication:
    Code:
    login as: root
    [email protected]'s password:
    dyld: lazy symbol binding failed: Symbol not found: _login
      Referenced from: /usr/sbin/sshd
      Expected in: /usr/lib/libSystem.B.dylib
    
    dyld: Symbol not found: _login
      Referenced from: /usr/sbin/sshd
      Expected in: /usr/lib/libSystem.B.dylib
    Any ideas on how to resolve this?

  2. #2
    I had the same exact problem. When I uninstalled SSH, I was forced to restart springboard. After doing so, my phone froze with a black screen so I was forced to hard reboot. This caused my phone to not boot up, it stuck at the loading screen.

    Be careful.

  3. #3
    yeah I had the same error I ran respring through sbsettings it works.. Though mobile terminal is doomed. It opens and shows a keyboard and closes.. Just like Cydia and I can't use putty to get to my iPod anymore either.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •