Results 1 to 4 of 4

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: need help with noob question

  1. #1
    Default need help with noob question
    i'm currently running 1.02 unlocked and jailbroken. I mod my iphone some time around Sep last year and haven't mod it since. I'm sorry for asking such a noob question. I wonder what's the best way to upgrade to the up-to-date firmware? I was goona use Ziphone but afraid that it's gonna brick my iphone(with my little knowledge). Any help will be very appreciated.

    thanks in advance.

  2. #2
    i would say download the 1.1.4 firmware. sync the phone so your contacts and stuff gets backed up.
    then put phone into DFU, hold shift and click on restore in itunes and choose the 1.1.4 firmware, restore.
    then unlock and jailbreak with ziphone

  3. #3
    iPhone? More like MyPhone echo's Avatar
    Join Date
    Sep 2007
    Location
    YYZ & KUL
    Posts
    197
    Thanks
    12
    Thanked 23 Times in 21 Posts

    You have several unlocking options... You can use ZiPhone 2.5, iNdependence 1.4b5, or iPlus 2.0. I personally used ZiPhone 2.5 and it went off without a hitch but there have been cases of people having a few problems. I suggest you do some research on all 3 methods to see what suits you best.

    Also, please note that after you jailbreak and unlock, depending on what method you choose, you will need to install further "hacks" to make sure your phone is working at its optimum (AppSupport Patch, AFC2 aka ZiPhone iBrickr Fix, Regions Patch). From what I've seen, iPlus 2.0 does most of that for you. Good luck and let us know what you eventually use.

    cheers,
    e
    15.4" 2.8GHz Unibody MacBook Pro
    Pwnage Unlocked 16GB iPhone (2.1)
    Apple Unlocked 16GB 3G iPhone (2.2)

  4. #4
    Big thanks for Invu and Echo. I got my problem fixed by just upgrading Itunes (duh!!). I used Ziphone to successfully upgraded with no problem so far, utube,SSH and mail are working fine. What's the deal with BL 3.9 baseband, is it necessary to get it back to 4.6 for future upgrade??

    thanks again for the reply guys.
    Last edited by pattdx; 2008-03-13 at 11:12 PM.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •