Ok, so I didn't want to hijack somebody elses post and I've been searching this forum for hours trying to find a solution to my problem but to no avail.

I was happily running 2.2.1 jailbroken and unlocked with Yellowsn0w and decided to take the leap to 3.0 now that some initial issues had been resolved but... I clicked the upgrade button in iTunes (8.2) and the process started as normal and all was fine but it then gave me an error code - I forget which one - and now my phone is stuck with the itunes/usb cable picture on my screen - I am unable to connect to iTunes and iTunes does not detect the phone - I have removed iTunes 8.2 and installed the pre 8.2 release but still no luck - windows (vista) does install the drivers for it but it doesn't show up in "My Computer".

I have tried putting it in DFU mode but no luck.

I am out of ideas and am really not looking forward to taking it to the Apple Store 'cos they will know something is up when they see the custom boot logo.

Thanks in advance!