in the last 2 days both myself and a mate have updated the fw on our iphones to 1.1.4.
I was running 1.1.1, he was on 1.0.2. we followed the guide and it didnt work. This was due to the guide pointing you to the wrong version on Ziphone and that anysim 1.3 wont unlock a 1.1.4 iphone.

to get around this problem we downloaded ziphone from the ziphone website (googled it).
the latest version of Ziphone will unlock a 1.1.4 fw iphone.

I am now running on the latest fw.