Results 1 to 15 of 15

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: sms.db backup

  1. #1
    Smile sms.db backup
    Hi, i have an iphone 3g and it was jailbroken on 2.2.1, i got the sms.db file from var/mobile/***/sms.db, and backed it up. I went and did a full restore thinking i could get my sms, contacts etc back.

    i jailbroke my iphone 3g on 3.0 firmware and everything went well, i got my contacts notes etc back, but then i went to replace my sms.db and then when i went back to my phone it kept respringing over and over again..i had to replace the 3.0 sms.db file.

    Can someone give help me get my sms back on my iphone. I Desperately need them. i have some private things in there.

    Thanks

  2. #2
    Green Apple
    Join Date
    Sep 2008
    Posts
    52
    Thanks
    0
    Thanked 4 Times in 1 Post
    When you perform a backup through iTunes it backs up you sms, contacts mail etc.. So i would say restore from a backup you have otherwise i have no clue.

  3. #3
    I had the exact same experience. I'm restoring to a (newer) old backup now in hopes of restoring my sms.db

    Even though the phone is stuck in a respring loop, WiFi/OpenSSH are still running, so you can delete the sms.db and the phone will stop freaking out (albeit with an empty SMS log).

  4. #4
    Try changing the permission to 0777.

  5. #5
    Correct, I should have mentioned that is my first troubleshooting tactic as well.. Although chmod 0777 did not fix me this time, it often fixes problems like this. Thx for the suggestion.

    FWIW, restoring my 2.2 sms.db from a backup onto the 3.0 firmware worked.

  6. #6
    I took the sms.db from my 2.2.1 iPhone and replaced the 3.0 one. Then I changed the permission to 0777 and it worked. Maybe it's different for each phone.

  7. #7
    I'm having the same problems, how do you change the permission to 0777??

    Thnx

  8. #8
    Hi,
    I also ran into the respringing problem and had to restore and re-jailbreak. Can anyone else confirm the 0777 permissions trick does work using SSH? Does this also apply when restoring 2.2.1 backups of notes.db, safari bookmarks, etc?

    Also, how are you guys able to restore from a 2.2.1 backup after jailbreaking to 3.0? I tried doing that and the progress bar just took forever to finish and crashed at the end. I ended up having to restore and then setting it up as a new phone. Just wondering how you guys are able to successfully retrieve all your backup phone settings, sms.db, safri bookmarks, etc. from itunes.

    Thanks!
    Last edited by leilomos; 2009-06-22 at 09:54 PM.

  9. #9
    i try this and works:

    SFTP into the iPhone, goto
    /private/var/mobile/Library/
    and delete the complete directory SMS. Start the SMS app on the iPhone then and send one sms. SFTP into the iPhone then, goto
    /private/var/mobile/Library/SMS/
    and replace the sms.db in there with the one you have on your PC. Once done immediately restart the iPhone (holding start/sleep -> red slider to shut off -> restart). Will work then.

  10. The Following User Says Thank You to TechnopodMan For This Useful Post:

    leilomos (2009-06-23)

  11. #10
    I got mine from /User/Library/SMS/ and it worked perfectly. I didnt even restart the iphone

  12. #11
    just confirming that setting the permission to 0777 worked for me...

    i somehow made my phone go crazy i think i was messing about with it too much so it kept on respringing...

    so i backed up my sms etc and restored to my custom 3.0FW and i put my sms.db in to the folder /private/var/mobile/Library/SMS/ and then i was stuck with unread message and everytime i tried to send a text it wouldnt work and exit the messages software... tried everything and nothing worked... so i set my permission to 0777 and it finally worked!!!!

    hope this helps guys by the way i did this on winscp right clicked the sms.db and then set the permission from 0644 to 0777


    iPhone? ... No?... MYphone!!!

    "The man who smiles when things go wrong has thought of someone to blame it on"

  13. #12
    Livin the iPhone Life ALL DAY's Avatar
    Join Date
    Feb 2008
    Location
    Chit-Chat
    Posts
    2,274
    Thanks
    43
    Thanked 196 Times in 163 Posts

    OP, you didn't copy the correct SMS folder. As others have said, it's "/User/Library/SMS". Hopefully you have a backup on iTunes to get them from, otherwise you may be S.O.L.
    Respect your elders.

  14. #13
    Hmm, changing permissions to 0777 didn't work for me. I guess the solution is different for different setups. Here's what worked for me. I first logged in to my iPhone via SSH with the user "mobile" (not "root") and password "alpine". Then I copied over my old sms.db to the /private/mobile/Library/SMS directory and changed permissions to 0644. I now have all my old messages and the SMS app is working normally!

    Btw, "/User/Library/SMS" is the same as "private/var/mobile/Library/SMS/" which is the same as "/var/mobile/Library/SMS/".

  15. #14
    Hi i just updated to the firmware 3.0.1 and im still having problems sending sms..

    I replaced
    Draft
    Parts
    sms.db
    sms-legacy.db

    and changed the sms.db to 0777 i got the sms back, but i cannot delete previous text messages. i click Edit > Tick which one i want to delete and Press delete. Get out of sms application, then get into it again and the sms message i deleted is still there. How to fix?

  16. #15
    I updated from FW 3.0.1 to FW 3.1.3 and I can confirm that setting permission to 077 to sms.db worked for me. I can send, recieve and delete messages all normal now.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •