This "problem" with Safari downloading the files only exists because the default action in Safari is to "Open safe files after downloading. To solve the problem, simply go to Safari-Preferences-General and uncheck the option Open "safe" files after downloading.

There, "Problem" solved. No need to download and use Firefox or any other gymnastics.

*Note: I always set this option as unchecked anyhow. I don't like automatically opening files upon downloading. Bad taste in my mouth from my Windows days