Results 1 to 10 of 10

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: 3.0 -> 3.0 JB Failed - Error 1604

  1. #1
    Default 3.0 -> 3.0 JB Failed - Error 1604
    Hey guys,

    I have the iPhone 3G with the newest 3.0 firmware (I know, dumb for upgrading...it was an accident). Now whenever I try to shift+restore with a 3.0 JB firmware, I get the 1604 error.

    How do I fix this?

    Oh, I also have Windows Vista and iTunes 8.2

  2. #2
    The jailbreaking for the 3.0 only works for Mac computers right now but later their will be a version so that windows users can jailbreak their iPhones on widnows, keep check on the home page of MMi

  3. #3
    Oh, even if I have a jailbroken firmware 3.0 ipsw?

  4. #4
    It seems that if you downgrade to 2.2.1, pwn, restore to 3.0, then restore your custom ipsw, it is working for quite a few people.

    Or just wait for Quickpwn

  5. #5
    Did you have it in DFU mode?

  6. #6
    Yeah when I have it in DFU mode, I get like Error 1601 or something.

  7. #7
    Ok, after screwing around with winpwn 2.5, I came up with easy instructions to jailbreak 3.0 3G, untested on 2g or touch.

    1. Doesn't matter what firmware you start with!
    2. open winpwn and choose quickpwn instead of custom, its the option next to expert.
    3. Just so you can see the debug window, turn expert mode on as well.
    4. run winpwn, if you don't have the 2.0 firmware, you may have to download and browse to it, I believe it belongs in my documents directory by default.
    5. winpwn asks you for 1 of 3 firmwares, I used 2.0, so choose that and it lets you choose a logo or whatever, doesnt matter.
    6. Now it will let you go into dfu mode with onscreen instructions.
    7. Debug prompt should show you when you entered the dfu mode, i hear from other places if you let it go all the way winpwn will crash and the screen turns white
    8. With your iphone at a white screen, go to itunes and shift + restore to 3.0 custom firmware.

    If you did this and it worked for you, let me know.

  8. #8
    Cool. I finally got it to work. So basically, I downloaded OS 3.0 Beta 5 for 3G and the QuickPWN that works with that. I used QuickPWN to jailbreak the iPhone back to Beta 5. It ends up stuck in the recovery mode after that. Then I simply Shift + Restore in iTunes with the Custom 3.0 and it worked. Yup!

  9. #9
    this worked great for me except my phone is not active.... i doesnt see ATT network - any thoughts??

  10. #10
    iPhone? More like MyPhone
    Join Date
    Apr 2009
    Location
    SoCal
    Posts
    156
    Thanks
    6
    Thanked 11 Times in 8 Posts

    Quote Originally Posted by Deaken View Post
    this worked great for me except my phone is not active.... i doesnt see ATT network - any thoughts??
    when the .ipsw was created it was set to activate by itself since you have AT&T you need to activate it with itunes.
    SO you have to have the .ipsw that is not activated and requires you to activate it through itunes

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •