Hey guys,

After FREAKING OUT when i tried to downgrad from 3.0 in time for the official 3.0 update when i received error 20, i had a LONG chat with apple support, to no avail, and tried some self-soothing as follows:

I first held down the home button and the power button, then let go of power, it fixed the phone! wasn't in DFU, but it restarted as per normal and was usable...

Next step:

actually put the phone in DFU (check how but im pretty sure; while plugged in, hold both down for 10 seconds, let go of power, keep holding home till your computer does something (makes a 'usb device connected' sound), or says installing usb drivers....

next step:

restore using the shift+restore method, you can download the firmware anywhere...

restore will work, you'll get an error 1013, ignore it, thats about it not being able to downgrade the base band...

next step:

open quickpwn, do the holding of buttons step, then DO NOT jailbreak it again, it wont work... wait for 3.0 official (tomorrow) and upgrade officially, exit quickpwn and chill

Next step:

Wait for the fantabulous DevTeam to liberate 3.0!!!

hope this helps,

Darkness