Results 1 to 6 of 6

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: 2.2.1 can be unlocked???

  1. #1
    My iPhone is a Part of Me vietkool's Avatar
    Join Date
    Sep 2007
    Location
    TX
    Posts
    628
    Thanks
    36
    Thanked 2 Times in 2 Posts

    Default 2.2.1 can be unlocked???
    Hi,

    I was browsing on net and I saw some ad state that the version 2.2.1 can be soft(ware) unlocked no turbo SIM adapter needed. is it true or scam?

  2. #2
    Retired Moderator Poseidon79's Avatar
    Join Date
    Jan 2008
    Location
    Austin, TX
    Posts
    8,264
    Thanks
    819
    Thanked 1,681 Times in 1,159 Posts

    It's more of a question of baseband, not firmware. The iPhone 3G gets a baseband update to 2.30 when you update the firmware to 2.2.1. If this device was manufactured around or before Sept 2008 it has an exploit that can be used to downgrade the baseband to 2.28 which can be unlocked with yellowsn0w. If your device was manufactured after this date you're stuck and cannot unlock without a SIM chip. The way you can test is by jailbreaking and downloading 3G Fuzzy Baseband Downgrader which will tell you immediately if you can downgrade.

    If you have a first generation iPhone it can be unlocked no matter what b/c the baseband does not get upgraded from 4.05.

  3. #3
    My iPhone is a Part of Me vietkool's Avatar
    Join Date
    Sep 2007
    Location
    TX
    Posts
    628
    Thanks
    36
    Thanked 2 Times in 2 Posts

    I have 2.28 base band on my 3G now is it safe to upgrade to 2.2.1 and unlock again with Pwn and yellowsnow?

  4. #4
    Retired Moderator Poseidon79's Avatar
    Join Date
    Jan 2008
    Location
    Austin, TX
    Posts
    8,264
    Thanks
    819
    Thanked 1,681 Times in 1,159 Posts

    Not safe... as states above you will upgrade your baseband to 2.30 which is NOT unlockable. The only way you can upgrade is to download or build a custom 2.2.1 IPSW with pwnage tool and then restore to that.

  5. #5
    My iPhone is a Part of Me vietkool's Avatar
    Join Date
    Sep 2007
    Location
    TX
    Posts
    628
    Thanks
    36
    Thanked 2 Times in 2 Posts

    thanks buddy, where do I download the 2.2.1 custom so when I upgrade, the baseband will not update to 2.30? I have found this site here but not really sure the 2.2.2_5H11 is the correct one

    http://www.coderetard.com/2009/02/03...upgrade-guide/

    please advise
    Last edited by vietkool; 2009-05-27 at 10:53 PM.

  6. #6
    What's Jailbreak?
    Join Date
    May 2009
    Location
    chicago
    Posts
    11
    Thanks
    0
    Thanked 0 Times in 0 Posts

    how do i find out my boot loader and how can i get 5.8 on my phone because ther is a way to do it with no turbo sim. look and please help?!?!?
    iClarified - iPhone - How to Downgrade Your iPhone 3G 2.30 (2.2.1) Baseband for Unlock

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •